Bug 80427 - FILEOPEN: LibreOffice Crashes after a view seconds when trying to open a pptx file
Summary: FILEOPEN: LibreOffice Crashes after a view seconds when trying to open a pptx...
Status: CLOSED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.2.4.2 release
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-06-23 20:25 UTC by icerabbit
Modified: 2014-06-27 11:45 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description icerabbit 2014-06-23 20:25:05 UTC
Problem description: 
LibreOffice hangs / crashes after a brief while attempting to open a file. 

Steps to reproduce:
1. Open attached pptx file
2. Watch progress bar proceed 20%
3. LibreOffice crashes 

Current behavior:
Crashes

Expected behavior:
Allow me to see the file
              
Operating System: Mac OS X
Version: 4.2.4.2 release
Comment 1 Yousuf Philips (jay) (retired) 2014-06-23 20:55:28 UTC
Hi icerabbit,

You hadnt attached the pptx file.
Comment 2 icerabbit 2014-06-23 23:12:35 UTC
I see now. The report went through, it uploads for a minute or so, but then errors that  the file is too big. 

The file is directly available online here:

http://www.google.com/url?sa=t&rct=j&q=&esrc=s&source=web&cd=1&cad=rja&uact=8&ved=0CB8QFjAA&url=http%3A%2F%2Fftp3.syscom.mx%2Fusuarios%2Ffcarrillo%2FMaterial%2520Grafico%2Fintroduction%2520of%2520hikvision%2520ivms-5200.pptx&ei=H7OoU4KgCfTNsASt6YGoBQ&usg=AFQjCNEeYVgEhWFWGt-EITvDR5dN3s98zQ&sig2=tS8IgCVnJ6PdMeascKpfZA


With apologies for the messy google URL is giving me. It comes up as the first result in google search with "hikvision ivms introduction pptx" should that obscure link not work.
Comment 3 Yousuf Philips (jay) (retired) 2014-06-24 05:12:42 UTC
Hi icerabbit,

I tested < http://ftp3.syscom.mx/usuarios/fcarrillo/Material%20Grafico/introduction%20of%20hikvision%20ivms-5200.pptx > on Linux Mint with 4.1.6, 4.2.5 and 4.3rc1 and on Windows 7 with 4.1.6 and 4.2.4 and the file opened successfully. I'm assuming this maybe a OSX only issue, so can you let us know which version of Mac OS X your running.
Comment 4 retired 2014-06-24 13:05:26 UTC
WORKSFORME 10.9.3 LO 4.3RC1

please retry with http://www.libreoffice.org/download/pre-releases/

reopen should the issue persist.
Comment 5 icerabbit 2014-06-24 14:51:57 UTC
Happy to report as well, that it works for me too in LO 4.3RC1

Crash had already been sent to Apple (through their automated system)

OS Version:      10.9.3 (Build 13D65)
Architecture:    x86_64

Command:         LibreOffice
Path:            /Applications/LibreOffice.app/Contents/MacOS/soffice
Version:         4.2.4002 (???)
Parent:          launchd [184]

PID:             1534
Event:           hang
Duration:        1.70s
Steps:           18 (100ms sampling interval)

Hardware model:  Macmini6,2
Active cpus:     8
Fan speed:       1802 rpm

Free pages:      2055 pages (+1122)
Pageins:         26 pages
Pageouts:        0 pages
Swapins:         0 pages
Swapouts:        0 pages

Process:         soffice [1534]
Path:            /Applications/LibreOffice.app/Contents/MacOS/soffice
Architecture:    x86_64
Parent:          launchd [184]
UID:             501
Task size:       1575211 pages (-102299)
CPU Time:        0.990s

Etc ...
Comment 6 retired 2014-06-24 15:20:44 UTC
No worries, Apple won't do a thing... Ok, glad this is working for you as well. It's always worth testing the latest version, since not seldom, issues have already been fixed.
Comment 7 Yousuf Philips (jay) (retired) 2014-06-24 16:50:29 UTC
Does it crash in 4.2.5 for you Foss, as we would need to look into fixing it for the 4.2.6 release.
Comment 8 retired 2014-06-24 21:05:17 UTC
icerabbit, would you be willing to test 4.2.5?
http://www.libreoffice.org/download/libreoffice-fresh/
Comment 9 icerabbit 2014-06-25 20:12:13 UTC
Removed LO 4.3 RC1. Installed LO 4.2.5 Fresh.

File opens fine.

Good thing it somehow was already fixed for 4.2.5, due to some earlier report or known issue, I guess.

Thank you, everyone, for your prompt assistance!
Comment 10 retired 2014-06-26 09:39:24 UTC
And thank you for testing. Closing.
Comment 11 Alex Thurgood 2014-06-27 09:02:45 UTC
First, there are two Asian fontfaces in the document that are not in my OSX system. I know this because I opened the file in Keynote and it is kind enough to tell me so. It even says it will replace them by TimesRoman (nice UI advantage over LO there ;-) )
Comment 12 Alex Thurgood 2014-06-27 09:38:02 UTC
Damn, should've read through to the end beforehand :-) WFM too
Comment 13 Yousuf Philips (jay) (retired) 2014-06-27 11:45:54 UTC
(In reply to comment #11)
> First, there are two Asian fontfaces in the document that are not in my OSX
> system. I know this because I opened the file in Keynote and it is kind
> enough to tell me so. It even says it will replace them by TimesRoman (nice
> UI advantage over LO there ;-) )

posted your comment to my bug 78186. :)