Download it now!
Bug 80509 - LibreOffice Allows Selecting 64 Bit Java in Windows but Gives Error when Using
Summary: LibreOffice Allows Selecting 64 Bit Java in Windows but Gives Error when Using
Status: RESOLVED DUPLICATE of bug 37089
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Java-Runtime-JRE
  Show dependency treegraph
 
Reported: 2014-06-25 03:16 UTC by Joel Madero
Modified: 2016-10-16 10:42 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joel Madero 2014-06-25 03:16:24 UTC
Repro Steps:
On 32 bit version of LibreOffice on Windows 64 bit build (W7 x64 here)

1) Install 64 bit Java if not already installed
2) In LibreOffice go to
    a) tools -> options -> advanced
    b) Click "Add... on the right side of the Java box
    c) Select 64 bit path (C:/Program Files/Java/jre7
    d) Click Ok
    e) wait a few seconds to see the new detected version of JRE show up
    f) Select new version shown (make sure the Location below the box reads  "C:\Program Files\java\jre7")
    
3) Setup a new base file
   a) File -> New -> Database
   b) Click "finish"

Observed: You get an error (I've seen two distinct ones, one says JRE defective, the other says No Java installation found)

Expected: Never be able to select a 64 bit version if you can't use it


Minor - not going to prevent high quality work but can slow it down as the user tries to figure out what is going on
Low - not going to affect many people, I think by default both 32bit and 64 bit versions of Java are installed on most (if not all) Windows builds). If you are on Linux and have a 64 bit version hopefully users are installing 64 bit version of LibreOffice
Comment 1 Yousuf Philips (jay) (retired) 2014-06-25 03:19:57 UTC
Confirmed on Windows 7 64-bit with java 1.8 64-bit enabled. I get a JRE defective dialog, followed by another error dialog stating 'No Java installation could be found. Please check your installation.'
Comment 2 Alex Thurgood 2015-01-03 17:41:22 UTC Comment hidden (no-value)
Comment 3 Maxim Monastirsky 2015-07-27 04:32:12 UTC

*** This bug has been marked as a duplicate of bug 37089 ***