Download it now!
Bug 80513 - Asian Phonetic Guide: Ruby text does not show up before minimize-and-maximize the window
Summary: Asian Phonetic Guide: Ruby text does not show up before minimize-and-maximize...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.6.2 release
Hardware: x86 (IA32) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: notBibisectable, regression
Depends on:
Blocks: CJK
  Show dependency treegraph
 
Reported: 2014-06-25 07:11 UTC by Kevin Suo
Modified: 2015-12-17 10:57 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
How Step 3 Looks (24.54 KB, image/png)
2014-06-26 05:09 UTC, Yousuf Philips (jay) (retired)
Details
how it looks when click "Apply" and "Close" (44.70 KB, image/png)
2014-06-26 05:17 UTC, Kevin Suo
Details
How it looks when minimize-and-maximize the window (44.63 KB, image/png)
2014-06-26 05:18 UTC, Kevin Suo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Suo 2014-06-25 07:11:16 UTC
Description:

This bug was initially report in the Chinese LibreOffice discussion forum:
http://libreofficechina.org/thread-32-1-1.html

In Asian Phonetic Guide, after set the phonetic text (注音) and hit "Apply", phonetic texts are not applied to the target chars immediately. It would be applied if you minimize and then maximize the main window.

Steps:
1. Make sure you enabled CJK option in Tools-Options settings.
2. New Writer, input (or copy and paste) the Chinese chars "中 国" (please note: there is a space between the two chars)
3. Select the two chars, then go to "Format - Asian Phonetic Guide", set "zhong" and "guo" for each of the two chars, respectively.
4. Hit "Apply".

Current Behaviour:
Phonetic is not applied to the target chars immediately at step 4.
However, when you minimize and then maximize the libreoffice window, phonetic will show up.

Expected:
Phonetic should be applied to the target chars immediately at step 4 when you hit "Apply".

(This bug behaviour does not happen with Apache OpenOffice 4.1.0.)

OS: Windows XP SP3
Version: 4.3.0.1.
"博雅 (179746686)" in the Chinese QQ chatroom confirms that he can reproduce in win7 LO4.1.6.
Comment 1 Kevin Suo 2014-06-26 05:09:21 UTC
P.S.:
To reproduce, you don't need to be in Chinese UI. English UI is OK to reproduce this bug behaviour.
Comment 2 Yousuf Philips (jay) (retired) 2014-06-26 05:09:49 UTC
Created attachment 101780 [details]
How Step 3 Looks
Comment 3 Yousuf Philips (jay) (retired) 2014-06-26 05:17:04 UTC
Confirmed on Linux Mint in 3.6.7, 4.2.4, and 4.3.0. It works correctly in 3.3.0. It is a simple redraw issue as alt+tab twice fixes it.
Comment 4 Kevin Suo 2014-06-26 05:17:16 UTC
Created attachment 101781 [details]
how it looks when click "Apply" and "Close"
Comment 5 Kevin Suo 2014-06-26 05:18:26 UTC
Created attachment 101782 [details]
How it looks when minimize-and-maximize the window
Comment 6 Michael Stahl (CIB) 2014-06-27 20:50:26 UTC
on Linux, can reproduce this on 4.1.6 and master

it's quite annoying though, sometimes it works and sometimes not?

it apparently happens even back in 3.6.7 although less often...
Comment 7 Matthew Francis 2014-12-20 10:16:47 UTC
Unfortunately it seems impossible to reproduce this reliably towards the beginning of the 43all bibisect repository. Clearly the bug is there, but the fact that it can't be reproduced on demand means that an accurate bibisect result can't be achieved

Setting Whiteboard:notBibisectable
Comment 8 Kevin Suo 2015-12-03 05:35:59 UTC
Could not reproduce with
Version: 5.0.4.1 (x64)
Build ID: 2def61bcbb29a7a8611b833682fe1291910b11ad
Locale: zh-CN (zh_CN)
Win10x64.

Set to RESOLVED WORKSFORME.
Comment 9 Robinson Tryon (qubit) 2015-12-17 10:57:12 UTC
Migrating Whiteboard tags to Keywords: (notBibisectable)
[NinjaEdit]