Download it now!
Bug 80526 - FILEOPEN: DOCX textbox "Word Wrap text in shape" property not imported correctly
Summary: FILEOPEN: DOCX textbox "Word Wrap text in shape" property not imported correctly
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
4.1.6.2 release
Hardware: All All
: medium normal
Assignee: Balázs Regényi
URL:
Whiteboard: interoperability target:7.1.0
Keywords: filter:docx
: 136820 (view as bug list)
Depends on:
Blocks: OOXML-Shapes
  Show dependency treegraph
 
Reported: 2014-06-25 14:14 UTC by Pete
Modified: 2020-09-29 12:02 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
A badge for a 91 year old lady's birthday (163.95 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-06-25 14:14 UTC, Pete
Details
LibO 4.1 VS Word 2013 (240.08 KB, image/png)
2014-06-26 08:45 UTC, Yousuf Philips (jay) (retired)
Details
How it looks in 4.0 without the ribbon (123.63 KB, image/png)
2014-06-26 08:46 UTC, Yousuf Philips (jay) (retired)
Details
Example file minimized in Word (16.28 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2020-09-02 18:26 UTC, NISZ LibreOffice Team
Details
The example file opened in Word and current Writer (134.51 KB, image/png)
2020-09-02 18:33 UTC, NISZ LibreOffice Team
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Pete 2014-06-25 14:14:24 UTC
Created attachment 101747 [details]
A badge for a 91 year old lady's birthday

DOCX file made in MS Office not formatted properly.
Comment 1 Yousuf Philips (jay) (retired) 2014-06-26 08:42:40 UTC
Confirmed in 4.1 and above on Linux Mint. In the DOCX file, there are two frames that have text in it. One for '91' and a second for 'and still having fun!'. The frame sizes being created for the two are being horizontally expanded rather than vertical. In 4.0.6, it doesnt expand the frame vertically or horizontally, but instead, shows a red error to indicate that more text is available.
Comment 2 Yousuf Philips (jay) (retired) 2014-06-26 08:45:22 UTC
Created attachment 101789 [details]
LibO 4.1 VS Word 2013
Comment 3 Yousuf Philips (jay) (retired) 2014-06-26 08:46:10 UTC
Created attachment 101790 [details]
How it looks in 4.0 without the ribbon
Comment 4 QA Administrators 2015-07-18 17:43:51 UTC Comment hidden (obsolete)
Comment 5 Buovjaga 2015-10-22 17:07:44 UTC
Still confirmed.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: fcc2415ade6ae93710bbbda9f7e163045e323105
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-10-21_16:55:13
Locale: fi-FI (fi_FI)
Comment 6 Aron Budea 2016-08-15 00:59:14 UTC
No improvement in v5.2.0.4.
Comment 7 QA Administrators 2018-07-19 02:41:41 UTC Comment hidden (obsolete)
Comment 8 NISZ LibreOffice Team 2020-09-02 18:26:35 UTC
Created attachment 165041 [details]
Example file minimized in Word
Comment 9 NISZ LibreOffice Team 2020-09-02 18:33:25 UTC
Created attachment 165042 [details]
The example file opened in Word and current Writer

In Word the "Word wrap text in shape" setting is turned OFF, but on opening the file it is turned OFF in Writer.

Version: 7.1.0.0.alpha0+ (x64)
Build ID: 1e0cfd5662d95cea84e80e4fe10d52c3b1101ae6
CPU threads: 4; OS: Windows 6.3 Build 9600; UI render: default; VCL: win
Locale: hu-HU (hu_HU); UI: en-US
Calc: CL
Comment 10 NISZ LibreOffice Team 2020-09-16 09:52:08 UTC
(In reply to NISZ LibreOffice Team from comment #9)
> In Word the "Word wrap text in shape" setting is turned OFF, but on opening
> the file it is turned OFF in Writer.
>
Of course it's turned ON in Writer on import.
Comment 11 NISZ LibreOffice Team 2020-09-18 12:29:53 UTC
*** Bug 136820 has been marked as a duplicate of this bug. ***
Comment 12 NISZ LibreOffice Team 2020-09-22 13:48:01 UTC
Note: there are actually two problems here: 
- the attribute value is incorrectly imported
- when manually changing the value in the dialog, it is not applied to the textframe, but it's applied to the shape (these are separate things under the hood) - similar to the spacing to border values as reported in bug #121513.

Changing title to limit this report to the first, import issue.
We also have now but #136881 about exporting this.
Comment 13 Commit Notification 2020-09-29 10:26:16 UTC
Regényi Balázs committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/commit/61291a63c0f9a57064300e7afc8222b4ae4e155a

tdf#80526 DOCX: import word-wrap textbox setting

It will be available in 7.1.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.