Bug Hunting Session
Bug 80599 - PRINTING: Print comments at end of sheet
Summary: PRINTING: Print comments at end of sheet
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.5.1 rc
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Calc-Comments
  Show dependency treegraph
 
Reported: 2014-06-27 14:04 UTC by bugzilla
Modified: 2018-11-27 16:38 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
xls file with properties that are not applied when printing (18.00 KB, application/x-msexcel)
2014-06-27 14:04 UTC, bugzilla
Details
Print from LO 4.2 (74.44 KB, application/pdf)
2018-06-07 14:49 UTC, Timur
Details
Print from LO 6.2+ (74.20 KB, application/pdf)
2018-06-07 14:49 UTC, Timur
Details
Print from MSO 2013 (49.06 KB, application/pdf)
2018-06-07 14:49 UTC, Timur
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bugzilla 2014-06-27 14:04:21 UTC
Created attachment 101868 [details]
xls file with properties that are not applied when printing

Problem description: MS Office compatibility issue - when an Excel sheet is printed, some Print settings are not applied.

Steps to reproduce:
1. Open the attached test xls in MS Excel and open Page Setup - Tab Sheet. In "Print" section, set "Comments" = "At end of sheet".
2. Open and print the test xls in LibreOffice, and check what happened to the comments.

Current behavior: The comments are printed in the table.

Expected behavior: The comments should appear at the end of the printout but not in the table.

              
Operating System: Windows 7
Versions tested: 4.2.5 and 4.3 dev
Comment 1 Jens S 2014-06-28 09:33:53 UTC
If the comments are visible on screen - they are also visible on the same place on the print AND on the following sheet. Not visible comments only print on the next page. I could live with that.
But I have a problem that there is no footer on the print at all. On print preview the page-number is correct. Header always correct.

In my opinion the problem is different printer drivers.

Operation system: Windows 8.1
LibreOffice 4.2.5
Printer: HP Officejet J4580
Comment 2 raal 2014-11-16 22:57:28 UTC
Setting as enhancement, allow to print comments at end of sheet
Comment 3 Timur 2018-06-07 14:49:06 UTC
Created attachment 142588 [details]
Print from LO 4.2
Comment 4 Timur 2018-06-07 14:49:28 UTC
Created attachment 142589 [details]
Print from LO 6.2+
Comment 5 Timur 2018-06-07 14:49:57 UTC
Created attachment 142590 [details]
Print from MSO 2013
Comment 6 Timur 2018-06-07 14:53:24 UTC
I don't understand "Current behavior" and "Expected behavior". LO and MSO are similar. 
Do you mean printing comments on the same sheet just after the content/table? If so, we need dev evaluation first. MSO also doesn't have that. 
I set back to Needinfo to reevaluate this bug and to have clear expected result.
Comment 7 Xisco Faulí 2018-06-12 09:29:57 UTC Comment hidden (obsolete)
Comment 8 Thanos 2018-06-26 05:58:50 UTC Comment hidden (spam)
Comment 9 Timur 2018-11-27 16:38:30 UTC
Reported didn't clarify so we must close. 
I guess reporter was confused with what was explained in Comment 1: 
in XLS will LO print both visible comments on page and on the following sheet. If print on page is not needed, comments can be turned off with View-Comments. I consider that behavior logical and fine.
Note that XLSX has it's own bug 121714.