Download it now!
Bug 80604 - FORMATTING: Font combobox doesn't function correction when set to use both western and CJK fonts
Summary: FORMATTING: Font combobox doesn't function correction when set to use both we...
Status: RESOLVED DUPLICATE of bug 73617
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.0.0.beta1
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
: 83480 (view as bug list)
Depends on:
Blocks: CJK
  Show dependency treegraph
 
Reported: 2014-06-27 15:45 UTC by Yang Fan
Modified: 2015-03-04 17:04 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Test case for the bug. (17.50 KB, application/vnd.ms-excel)
2014-07-02 13:34 UTC, Yang Fan
Details
the video of the bug (1.42 MB, application/x-7z-compressed)
2014-07-03 13:18 UTC, Yang Fan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yang Fan 2014-06-27 15:45:25 UTC
I select some cells, intending to change the font.
When i released the scrollbar of the font Combobox, the list of fonts freshed in few seconds. I cannot choose the font i want.
Comment 1 Yang Fan 2014-06-27 15:51:42 UTC
The bug occured when the text of selection are in diffrent fonts.
Comment 2 Yousuf Philips (jay) (retired) 2014-06-29 01:31:47 UTC
Hello Yang,

I attempted to reproduce this issue both on Linux and Windows with 4.3.0 and wasnt able to. If you are still using 4.3.0 beta 1, i encourage you to upgrade to 4.3.0 rc 1 and see if the problem is still there. If it is still there, please provide a sample document along with instructions on how to reproduce the error.
Comment 3 Yang Fan 2014-07-02 13:34:07 UTC
Created attachment 102136 [details]
Test case for the bug.

Open the attachment(学习计划-副本.xls).It's written in Chinese.
Select both D4 and D5. Two cells use different fonts.
Then, try to change the font.

I tried in 4.3.0.1 rc. The bug appeared again.
Comment 4 Yousuf Philips (jay) (retired) 2014-07-02 14:56:14 UTC
I selected D4 and D5 and i opened the font drop down menu and the list was available and i could select another font. Can you send in a screenshot of who it looks for you.
Comment 5 Maxim Monastirsky 2014-07-03 12:26:39 UTC
I'm able to reproduce the bug with 4.3.0.2 under Windows 7 & Linux Mint 17:

1. Select D4 (and note that the combo box text field is empty).
2. Open the drop-down and scroll the list using the mouse wheel
   - OR -
   Scroll using the scrollbar to some position, and move the pointer over the list.

This seems to be related to the fact that D4 contains both Western and Asian text, each of them using a different font (that's why the text field is empty, I guess). I'm able to reproduce the same with a cell containing Western & CTL text or Asian & CTL text. I'm not able to reproduce this with a cell containing a text of one kind of language (e.g. only Western), even though it uses several fonts.
Comment 6 Yang Fan 2014-07-03 13:18:14 UTC
Created attachment 102198 [details]
the video of the bug

The attachment is the video of the bug.
May be it's related to the font preview.
Comment 7 Yousuf Philips (jay) (retired) 2014-07-03 22:29:03 UTC
Thanks Yang for the screencast. Yes i can confirm it on 4.2.5 on Linux Mint. I wasnt able to reproduce it previously as i was mistakenly selecting D4 and D5. :)
Comment 8 Yang Fan 2014-07-04 15:09:18 UTC
I'm so glad to make a contribution to LibreOffice.
Comment 9 Yousuf Philips (jay) (retired) 2014-07-04 19:19:06 UTC
Thank you for taking the time to make the contribution. If you speak chinese, do join the libreoffice chinese forum at < http://www.libreofficechina.org/ > and also assist in the chinese translation at < https://translations.documentfoundation.org/zh_cn/ >.
Comment 10 Maxim Monastirsky 2014-09-04 08:36:04 UTC
*** Bug 83480 has been marked as a duplicate of this bug. ***
Comment 11 Maxim Monastirsky 2014-10-23 19:16:55 UTC

*** This bug has been marked as a duplicate of bug 73617 ***