Bug 80617 - UI: Simplification of status bar page numbering
Summary: UI: Simplification of status bar page numbering
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: Other All
: medium enhancement
Assignee: Samuel Mehrbrodt (CIB)
QA Contact:
URL:
Whiteboard: target:4.4.0
Keywords:
Depends on:
Blocks:
 
Reported: 2014-06-28 03:40 UTC by Yousuf Philips (jay)
Modified: 2014-12-20 21:40 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
5-page ODT, p.A, p.a, and p.i (with 2 filler pages) using custom page styles. (13.00 KB, application/vnd.oasis.opendocument.text)
2014-07-03 07:42 UTC, Owen Genat (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) 2014-06-28 03:40:15 UTC
The status bar page numbering system is quite confusing, especially to new users, especially when you have multiple page styles in a document. Examples of this can be found in < http://www.microsoft.com/investor/reports/ar13/docs/2013_Annual_Report.docx > where on one page it shows 'Page 4 / 302' and then on the next it shows 'Page 1  5 / 302'. I also came across a document not so long ago that some pages in the document looked like 'Page 2  1 / 3' and others looked like 'Page 3 / 3' because LibO shrinks page numbers that look like 'Page 3  3 / 6' into 'Page 3 / 6'. As i dont know where the file is that i saw this in, i was playing around to recreate it and LibO showed me a page number 'Page v / 5'.

I finally decided to send this issue in when i came across a tweet yesterday of a similar issue < https://twitter.com/Rosella500/status/482578903115247616 > which the user stated the status bar showed it like this 'Page 1/3, Page 0/3, Page 1 3/3'.

As the actual page's page number is an optional thing to be displayed, i think the better means of displaying the actual page's number is after and not before and to always show it, even if its equal to the numbered page number. e.g. 'Page 5 / 302 ( 1 )', 'Page 5 / 302 ( v )'. I also think a tooltip would be quite useful to explain this.
Comment 1 Owen Genat (retired) 2014-06-28 11:12:47 UTC
(In reply to comment #0)
> As the actual page's page number is an optional thing to be displayed, i
> think the better means of displaying the actual page's number is after and
> not before and to always show it, even if its equal to the numbered page
> number. e.g. 'Page 5 / 302 ( 1 )', 'Page 5 / 302 ( v )'. I also think a
> tooltip would be quite useful to explain this.

There needs to be some way of visually discriminating between the two and this would seem one method. Word keeps details relating to the current page together, which I feel makes more sense. LO could use "p. iv | Page 4 / 302" and then "p. 1 | Page 5 / 302". Confirmed. Status set to NEW.
Comment 2 Yousuf Philips (jay) 2014-06-28 17:03:46 UTC
Thanks for confirming but i think the 'Page 4 / 302 | p. iv' would be more suitable as the 'Page X / X' part wont be moving left and right when you go to pages which have and dont have a page number.
Comment 3 Owen Genat (retired) 2014-07-02 10:55:03 UTC
(In reply to comment #2)
> ... i think the 'Page 4 / 302 | p. iv' would be more suitable as 
> the 'Page X / X' part wont be moving left and right 

Fair enough. This also applies to lengthy formats, such as Roman numerals. In this sense it is a consideration, regardless of whether the page numbers are always displayed or contextually suppressed, which indicates the Proposed and Alt.B forms (in the examples below) as preferable.

(In reply to comment #2)
> ... pages which have and dont have a page number.

I am not clear on what this means. All pages have a page number (the format of which is set on the Page tab when editing the page style). Whether that number is displayed (on the page) or not is a separate issue. The status bar displays metadata about document pages, and so IMO should _always_ display the current page number (in the set format) as well as the positional information within the document. This also helps indicate the format a page number field will use prior to insertion.

In LO (at present) the "Page a b / c" form only occurs after the point where page numbers have been reset. Pages prior to this point (at least in an ODT) always display "Page a / b", when "a" in this case can take any form of page number e.g., "Page 1 / 99", "Page A / 99", "Page a / 99", "Page i / 99", etc. Here is a basic example, using Arabic numerals, renumbering after p.2:

Current          Proposed            Alt.A                 Alt.B
-------          --------            -----                 -----
"Page 1 / 99"    "Page 1 / 99 (1)"   "p.1 | Page 1 / 99"   "Page 1 / 99 | p.1"
"Page 2 / 99"    "Page 2 / 99 (2)"   "p.2 | Page 2 / 99"   "Page 2 / 99 | p.2"
"Page 1 3 / 99"  "Page 3 / 99 (1)"   "p.1 | Page 3 / 99"   "Page 3 / 99 | p.1"

Under this enhancement request I see pages prior to renumbering as also always displaying in the same form for consistency. Here is another example, with each page after the first using renumbering and a different format each time:

Current          Proposed            Alt.A                 Alt.B
-------          --------            -----                 -----
"Page 1 / 99"    "Page 1 / 99 (1)"   "p.1 | Page 1 / 99"   "Page 1 / 99 | p.1"
"Page A 2 / 99"  "Page 2 / 99 (A)"   "p.A | Page 2 / 99"   "Page 2 / 99 | p.A"
"Page a 3 / 99"  "Page 3 / 99 (a)"   "p.a | Page 3 / 99"   "Page 3 / 99 | p.a"
"Page i 4 / 99"  "Page 4 / 99 (i)"   "p.i | Page 4 / 99"   "Page 4 / 99 | p.i"

Automatically inserted pages (e.g., a left filler page prior to a page using the Right Page page style) are not selectable and so no details of these pages can be displayed in the status bar.
Comment 4 Yousuf Philips (jay) 2014-07-03 02:59:27 UTC
(In reply to comment #3)
> (In reply to comment #2)
> > ... pages which have and dont have a page number.
> 
> I am not clear on what this means. All pages have a page number (the format
> of which is set on the Page tab when editing the page style).

This meant that you can go to a page which is in "Page b / c" format, example 'Page 4 / 302', and then the following page is in "Page a b / c" format, example 'Page 1  5 / 302'. So to me 'Page 4 / 302' doesnt have a page number according to the printed page numbers on the page.
Comment 5 Owen Genat (retired) 2014-07-03 07:42:18 UTC
Created attachment 102184 [details]
5-page ODT, p.A, p.a, and p.i (with 2 filler pages) using custom page styles.

(In reply to comment #4)
> So to me 'Page 4 / 302' doesnt have a page number according 
> to the printed page numbers on the page.

As I explained, what is displayed on the page is not relevant to what is displayed in the status bar. Refer the attached example. None of the pages display a page number in the document, but all display page numbering information, in addition to positional information, in the status bar. This enhancement will simply make these two pieces of information more consistent and clear.
Comment 6 Yousuf Philips (jay) 2014-07-03 22:48:57 UTC
Thanks for the sample file. I think you made a mistake with the format of Alt A and Alt B in comment 3, as there is a missing space after the 'p.', as it was "p. 1 | Page 5 / 302" (comment 1) and "Page 4 / 302 | p. iv" (comment 2).
Comment 7 Owen Genat (retired) 2014-07-05 05:05:13 UTC
(In reply to comment #6)
> I think you made a mistake with the format of Alt A and Alt B in comment 3, 
> as there is a missing space after the 'p.', as it was "p. 1 | Page 5 / 302" 
> (comment 1) and "Page 4 / 302 | p. iv" (comment 2).

Yes. There should indeed be an extra space after the period. Thanks.
Comment 8 Commit Notification 2014-08-26 14:23:23 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=6f9a52abc8a9c8bf98568a5653c25404ef017cac

fdo#80617 Simplification of status bar page numbering



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Samuel Mehrbrodt (CIB) 2014-08-26 14:27:25 UTC
Please test and see how you like it.
The syntax I used is: Page 4/302 (Page iv)
since I don't think shortcuts (p.) are easily understandable.
Comment 10 Yousuf Philips (jay) 2014-08-26 15:07:48 UTC
Have to wait for the build to come out but i fine with it if there are spaces between the '/' - meaning 'Page 4 / 302 (Page iv)'.

Thanks again for the help these last few days getting my enhancements in. I have a few other ones that i'd love for you to check out if you have the time, all being quite easy to complete. :)
Comment 11 Adolfo Jayme 2014-08-27 11:48:33 UTC
@Samuel: your patch uses concatenated brackets, instead of a complete string including them. This will cause trouble when it comes to translations.
Comment 12 Samuel Mehrbrodt (CIB) 2014-08-27 12:07:10 UTC
Thanks for the hint, I'll fix that.
Comment 13 Samuel Mehrbrodt (CIB) 2014-08-27 19:38:13 UTC
(In reply to comment #10)
> Have to wait for the build to come out but i fine with it if there are
> spaces between the '/' - meaning 'Page 4 / 302 (Page iv)'.

Why do you think there should be spaces before and after the slash? Wikipedia says that usually you don't put a space there with a few exceptions, but none of the exceptions matches our case. See http://en.wikipedia.org/wiki/Slash_%28punctuation%29#In_English_text (last paragraph in that section)
Comment 14 Yousuf Philips (jay) 2014-08-27 21:52:49 UTC
Was suggesting ' / ' as that is currently how it is, but was thinking to suggest 'of' as it is in ms word and its more understandable, of course translation would also need to be kept in mind for that.
Comment 15 Owen Genat (retired) 2014-08-28 08:49:53 UTC
(In reply to comment #9)
> Please test and see how you like it.
> The syntax I used is: Page 4/302 (Page iv)
> since I don't think shortcuts (p.) are easily understandable.

Thanks Samuel. I am OK with your suggested format. Will test it once the daily deb x86_64 build picks it up.
Comment 16 Commit Notification 2014-08-30 08:25:44 UTC
Samuel Mehrbrodt committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4b4e4ccf8d571fd6f6ee538c4e406b07fc810e2d

fdo#80617 Use complete string to allow translation for page number info



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 17 Yousuf Philips (jay) 2014-08-30 10:34:47 UTC
maybe a patch can be put into 4.3 which wont need any extra translation, similar to your original patch, meaning - 'Page 4/302 (Page iv)'.

@Adolfo: what do you think?
Comment 18 Adolfo Jayme 2014-08-30 19:37:24 UTC
(In reply to comment #17)
> maybe a patch can be put into 4.3 which wont need any extra translation,
> similar to your original patch, meaning - 'Page 4/302 (Page iv)'.
> 
> @Adolfo: what do you think?

@Jay: I’m not really sure… I am thinking that if we hack a new string just to avoid translation work, we can’t ensure that the result will be correct for every language. If this is really desired in libreoffice-4-3, a new, complete string would be simpler and much better.

Now, as a translator I won’t mind translating this extra string, but note that I’m speaking for myself only. You should write to the l10n mailing list to let others know about this and see what they think.
Comment 19 Yousuf Philips (jay) 2014-08-30 20:38:30 UTC
(In reply to comment #13)
> Why do you think there should be spaces before and after the slash?

Well i just opened attachment 102184 [details], and i see why the no spacing wasnt a good idea. It showed 'Page 1/5' and most people seeing '1/5' would thing one-fifth or one over five. Atleast that is how i saw it. :)

(In reply to comment #18)
> @Jay: I’m not really sure… I am thinking that if we hack a new string just
> to avoid translation work, we can’t ensure that the result will be correct
> for every language. If this is really desired in libreoffice-4-3, a new,
> complete string would be simpler and much better.

Yes its best to be safe than sorry and if it is to be backported, its best to be done as is, so they wont have to redo another one for 4.4.

> Now, as a translator I won’t mind translating this extra string, but note
> that I’m speaking for myself only. You should write to the l10n mailing list
> to let others know about this and see what they think.

Mail sent into the mailing list to see what they think.
Comment 20 Samuel Mehrbrodt (CIB) 2014-08-31 17:56:49 UTC
(In reply to comment #19)
> (In reply to comment #13)
> > Why do you think there should be spaces before and after the slash?
> 
> Well i just opened attachment 102184 [details], and i see why the no spacing
> wasnt a good idea. It showed 'Page 1/5' and most people seeing '1/5' would
> thing one-fifth or one over five. Atleast that is how i saw it. :)

I've now used "of" instead of the slash. So it looks like "Page 1 of 5".

 
> (In reply to comment #18)
> > @Jay: I’m not really sure… I am thinking that if we hack a new string just
> > to avoid translation work, we can’t ensure that the result will be correct
> > for every language. If this is really desired in libreoffice-4-3, a new,
> > complete string would be simpler and much better.
> 
> Yes its best to be safe than sorry and if it is to be backported, its best
> to be done as is, so they wont have to redo another one for 4.4.
> 
> > Now, as a translator I won’t mind translating this extra string, but note
> > that I’m speaking for myself only. You should write to the l10n mailing list
> > to let others know about this and see what they think.
> 
> Mail sent into the mailing list to see what they think.

I don't think this should be backborted. It's just a little annoyance, not a real bug.
Comment 21 Yousuf Philips (jay) 2014-08-31 22:23:44 UTC
(In reply to comment #20)
> I've now used "of" instead of the slash. So it looks like "Page 1 of 5".

Yes i know we are going with 'of' instead, but i was just noting why '/' without spaces wasnt a good idea if we had gone with that. :)

> I don't think this should be backborted. It's just a little annoyance, not a
> real bug.

Well when i reported it 2 months back, i was hoping that it would land in 4.3, as it had annoyed me for quite a while before i submitted the bug, but now we'd have to wait another 5 months for 4.4 to be released to see it. To the twitter user who reported 'Page 1/3, Page 0/3, Page 1 3/3', the system wasnt understandable. But if you dont want to backport it, we can just leave it at that.
Comment 22 Mike §chinagl 2014-12-20 21:40:44 UTC
This bug fix comes with LibreOffice 4.4 (release notes https://wiki.documentfoundation.org/ReleaseNotes/4.4) 


Page number in the statusbar are more easily understood when page number styles are used. 

See a graphic of the work:
https://wiki.documentfoundation.org/File:Statusbar_page_numbers.png