Bug Hunting Session
Bug 80625 - EDITING: page number not displayed in specific document
Summary: EDITING: page number not displayed in specific document
Status: RESOLVED DUPLICATE of bug 35694
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other Linux (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-06-28 10:05 UTC by junge
Modified: 2015-01-21 10:19 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
sample document (41.18 KB, application/vnd.oasis.opendocument.text)
2014-07-01 00:35 UTC, Yousuf Philips (jay) (retired)
Details
Field Insert Error (40.22 KB, image/png)
2014-07-02 05:38 UTC, dar
Details

Note You need to log in before you can comment on or make changes to this bug.
Description junge 2014-06-28 10:05:24 UTC
Problem description: 

Steps to reproduce:
1. Activate Footer, insert "page number"
2. right-click on footer, choose "feldbefehl..." in context menue
3. enter value in textfield correction (f.e. 3)

Current behavior:
first page numbered with "3", all folowing pages not numbered at all :-(

Expected behavior:
1st page: page number 3
2nd page: page number 4
3rd page: page number 5
and so on ...

Don't no the translation for "feldbefehl". I'm using a german version of libreoffice.

              
Operating System: Debian
Version: 4.2.5.2 release
Comment 1 Yousuf Philips (jay) (retired) 2014-06-28 23:38:46 UTC
Hi Junge,

I couldnt reproduce this, can you attach a document that is showing this behaviour so we can investigate it.
Comment 2 Cor Nouws 2014-06-29 10:37:03 UTC
Also, junge: did you first ask for user-support. For example there is a group of users with a great variety of skills that can offer help with questions:
  http://www.libreoffice.org/get-help/community-support/
IMO this kind of stuff just works fine.
So for now I close as WORKSFORME. Might there turn out to be a problem in some specific details, then pls reopen with those details. 

Kind regards
Cor
Comment 3 Yousuf Philips (jay) (retired) 2014-07-01 00:35:13 UTC
Created attachment 102037 [details]
sample document

Holger sent this

------------------

Hello.

As attachment you will find the document with the wrong page numbering. I retried it under Arch-Linux with LibreOffice 4.2.5.2. The new behaviour now is, that even the first page isn't displayed correctly.

In my bug-report I forgot to mention that the ODT-File is in landscape format. Might this be a problem?

Greetings

Holger

----------------------------

Note: Please click on the bug number link provided in the email and you will be taken to this bugzilla page, where you can add comments and attachments.
Comment 4 Yousuf Philips (jay) (retired) 2014-07-01 03:15:40 UTC
Hi Holger,

I tested the document and i get no page numbers in any of the pages, even though the page number field is in the footer. You stated in the description that you can see page 3 on the first page, but in order for that to happen, you would have had to set the page number offset to 2 in order for that to happen.

I tested the file on 3.3, 3.6, 4.0, 4.1, 4.2, 4.3 and master and none returned a page number on any page. I tested it in Calligra Words and it returned page 4 on the first page, but none on the rest of the pages. I removed the footer and made a new one and any page number which had the number 3 or more has a blank number.
Comment 5 Cor Nouws 2014-07-01 05:29:50 UTC
Remove footer, inert footer and field again & there is is. Still weird...
Comment 6 dar 2014-07-02 05:38:53 UTC
Created attachment 102108 [details]
Field Insert Error
Comment 7 dar 2014-07-02 05:39:48 UTC
Comment on attachment 102108 [details]
Field Insert Error

I have what I believe is the same bug or similar. Upon Field Insert Page Number, into the footer, the resulting inserted field is displayed as: Page Numbers
If I choose date, the result displayed is: Time(Fixed)

However, if I open the document in Calligra Words, those fields are displayed correctly.

I am currently using LibreOffice Version: 4.3.0.1
Build ID: 9ed0c4329cf13f882dab0ee8b9ecd7b05e4aafbb

I have attached a screenshot
Comment 8 Yousuf Philips (jay) (retired) 2014-07-02 18:37:39 UTC
Hi Dar,

If possible, can you send in a sample document showing your error.
Comment 9 Matthew Francis 2015-01-21 10:19:29 UTC

*** This bug has been marked as a duplicate of bug 35694 ***