Bug Hunting Session
Bug 80643 - FORMULAEDITOR: Math equation visualization error
Summary: FORMULAEDITOR: Math equation visualization error
Status: RESOLVED DUPLICATE of bug 76239
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Formula Editor (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: possibleRegression
Depends on:
Blocks:
 
Reported: 2014-06-28 18:57 UTC by Ricardo
Modified: 2015-12-15 10:58 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Print Screen showing the problem. (71.62 KB, image/png)
2014-06-28 18:57 UTC, Ricardo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ricardo 2014-06-28 18:57:38 UTC
Created attachment 101931 [details]
Print Screen showing the problem.

Problem description: 

Steps to reproduce:
1. Open Libreoffice Math
2. Type C ( %THETA ) or, other example:
3. Type %omega_g

Current behavior: The first equation C ( %THETA ) appears with simbols like a telephone. The second, %omega_g, the g letter appears out of correct place. See the attached print screen.

Expected behavior: In the version 4.2.4.2 the equations appear Ok, like the print screen I am sending attached.

              
Operating System: Windows 7
Version: 4.2.5.2 release
Last worked in: 4.2.4.2 release
Comment 1 ign_christian 2014-06-29 10:18:52 UTC
Not reproducible in LO 4.2.5.2 and 4.3.0.1 - Ubuntu 12.04 x86

Have you tried using fresh user profile ?
https://wiki.documentfoundation.org/UserProfile
Comment 2 Ricardo 2014-06-29 12:28:19 UTC
Hi Christian

Thank you for answering. How I am making my undergraduate final work in Libreoffice, I immediately downgraded to 4.2.4.2 version to continue my academic work. I read quickly the wiki link trying to understand about user profile, but I didn't found anything about "fresh user profile" or, more precisaly, I didn't understant what it means.
If you have more questions please send me.
I'm using LO in Windows 7 x64, my computer is Dell Optiplex 780.

 
Ricardo B. Morim 


______________________________________


"De cada um segundo sua capacidade a cada um segundo sua necessidade".


Em Domingo, 29 de Junho de 2014 7:18, "bugzilla-daemon@freedesktop.org" <bugzilla-daemon@freedesktop.org> escreveu:
 


 
ign_christian  changed bug 80643 

What
Removed
Added
OS All  Windows (All)  
Comment # 1 on bug 80643 from ign_christian  
Not reproducible in LO 4.2.5.2 and 4.3.0.1 - Ubuntu 12.04 x86 Have you tried using fresh user profile ? https://wiki.documentfoundation.org/UserProfile
________________________________
 You are receiving this mail because: 
	* You reported the bug.
Comment 3 ign_christian 2014-06-30 03:37:13 UTC
Hi Ricardo..

Sorry to hear that you don't understand. I'll try my best to explain better.

Fresh user profile = using new profile (similar to install fresh LO) = reset user profile if LO default profile ever changed (in Tools > Options).

Sometimes user profile generates wrong behavior after crash or version upgrading.

So in your case, Windows From Vista, folder "%appdata%\libreoffice\4\user" should be deleted OR renamed to back it up (it's advised if you're not sure deleting that).

Btw, incorrect result appeared when you type equation in 4.2.5.2 OR when you open file that was saved by 4.2.4.2 ?
Comment 4 ign_christian 2014-06-30 03:39:25 UTC
Anyway..please don't reply directly from email. But use attached link in the email instead.
Comment 5 Ricardo 2014-06-30 10:25:15 UTC
Hi

I understood now. Thank you for explanation.
It appeared when I opened my file, in Writter. I tried open Math and type the same equation C ( %THETA ) and the problem hold on.

 
Ricardo B. Morim 


______________________________________


"De cada um segundo sua capacidade a cada um segundo sua necessidade".


Em Segunda-feira, 30 de Junho de 2014 0:37, "bugzilla-daemon@freedesktop.org" <bugzilla-daemon@freedesktop.org> escreveu:
 


 
ign_christian  changed bug 80643 

What
Removed
Added
CC    ign_christian@yahoo.com  
See Also    https://bugs.freedesktop.org/show_bug.cgi?id=80696  
Comment # 3 on bug 80643 from ign_christian  
Hi Ricardo.. Sorry to hear that you don't understand. I'll try my best to explain better. Fresh user profile = using new profile (similar to install fresh LO) = reset
user profile if LO default profile ever changed (in Tools > Options). Sometimes user profile generates wrong behavior after crash or version
upgrading. So in your case, Windows From Vista, folder "%appdata%\libreoffice\4\user"
should be deleted OR renamed to back it up (it's advised if you're not sure
deleting that). Btw, incorrect result appeared when you type equation in 4.2.5.2 OR when you
open file that was saved by 4.2.4.2 ?
________________________________
 You are receiving this mail because: 
	* You reported the bug.
Comment 6 Maxim Monastirsky 2014-06-30 13:10:40 UTC
Hi Ricardo,

Please open the fonts folder, and check if there is a font called 'OpenSymbol'. In case you don't have this font, download it from http://cgit.freedesktop.org/libreoffice/core/plain/extras/source/truetype/symbol/opens___.ttf, and install it. Does it solve your problem?
Comment 7 ign_christian 2014-06-30 13:51:59 UTC
Thanks Maxim for the assistance. Indeed we had OpenSymbol installed in Ubuntu so the bug can't be reproduced. So this is possibly a clone of Bug 76239.

@Ricardo.. please, once again, don't reply directly from email
Comment 8 Ricardo 2014-06-30 22:57:46 UTC
(In reply to comment #6)
> Hi Ricardo,
> 
> Please open the fonts folder, and check if there is a font called
> 'OpenSymbol'. In case you don't have this font, download it from
> http://cgit.freedesktop.org/libreoffice/core/plain/extras/source/truetype/
> symbol/opens___.ttf, and install it. Does it solve your problem?


Hi

I have only "OpenSymbol Regular" in path C:\windows\Fonts.
I'll try to intall it as soon as possible. But, as I mentioned before, I downgraded to LO 4.2.4.2 because I am doing my final undergraduate work. To install v. 4.2.5.2 I need to uninstall current version and it takes time. As soon as possible I will do it.

Thak you.
Comment 9 Ricardo 2014-07-01 21:44:16 UTC
Hi

I would like to thank you. I installed the OpenSymbol font and now it's working.
My equations are in normal form on LO 4.2.5.

Libreoffice is the best! 


Thanks!

 
Ricardo B. Morim 


______________________________________


"De cada um segundo sua capacidade a cada um segundo sua necessidade".


Em Segunda-feira, 30 de Junho de 2014 10:11, "bugzilla-daemon@freedesktop.org" <bugzilla-daemon@freedesktop.org> escreveu:
 


 
Maxim Monastirsky  changed bug 80643 

What
Removed
Added
Status UNCONFIRMED  NEEDINFO  
CC    momonasmon@gmail.com  
Ever confirmed    1  
Comment # 6 on bug 80643 from Maxim Monastirsky  
Hi Ricardo, Please open the fonts folder, and check if there is a font called 'OpenSymbol'.
In case you don't have this font, download it from http://cgit.freedesktop.org/libreoffice/core/plain/extras/source/truetype/symbol/opens___.ttf,
and install it. Does it solve your problem?
________________________________
 You are receiving this mail because: 
	* You reported the bug.
Comment 10 ign_christian 2014-07-02 05:30:06 UTC
So it's duplicate to Bug 76239. Please comment on that bug if you see same problem in the future

*** This bug has been marked as a duplicate of bug 76239 ***
Comment 11 Robinson Tryon (qubit) 2015-12-15 10:58:01 UTC
Migrating Whiteboard tags to Keywords: (possibleRegression)
[NinjaEdit]