Bug 80657 - UI: Addition of navigator page number field to Page Preview Toolbar
Summary: UI: Addition of navigator page number field to Page Preview Toolbar
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: ux-advise (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: low enhancement
Assignee: Gülşah Köse
QA Contact:
URL:
Whiteboard: target:5.1.0
Keywords: difficultyBeginner, easyHack, skillCpp, topicCleanup
Depends on:
Blocks: 80838
  Show dependency treegraph
 
Reported: 2014-06-28 23:21 UTC by Yousuf Philips (jay)
Modified: 2016-10-25 19:21 UTC (History)
8 users (show)

See Also:
Crash report or crash signature:


Attachments
how the page number field would look on the toolbar (5.57 KB, image/png)
2014-06-28 23:21 UTC, Yousuf Philips (jay)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) 2014-06-28 23:21:51 UTC
Created attachment 101949 [details]
how the page number field would look on the toolbar

It would be nice to be able to jump to a particular page while in page preview mode without have to use the mouse to scroll to the particular page. So i'd like to suggest the addition to the page preview toolbar, the page number field found in the navigator dialog.
Comment 1 Cor Nouws 2014-06-30 20:54:00 UTC
nice!
Comment 2 Michael Meeks 2014-07-01 11:45:19 UTC
The navigator dialog code is in:

sw/source/uibase/utlui/navipi.cxx:

void SwNavigationPI::GotoPage()
{
...

has some code that we should prolly factor out and re-use somehow =)

In terms of adding a toolbar control with a field in it; here is an example of that:

git grep SvxColorToolBoxControl

Will show you how the Colour Toolbox controls (with their drop down) are created, registered etc.

Thanks !
Comment 3 jeyli 2014-09-22 08:56:45 UTC
I think it's very difficult to re-use code from void SwNavigationPI::GotoPage() in navipi.cxx because there are too many dependencies between variables and methods.
Comment 4 Yousuf Philips (jay) 2014-09-22 11:01:09 UTC
Thanks jeyli for trying. Is it easier to create a new page jump field instead?
Comment 5 Rishabh 2014-11-24 21:37:34 UTC
If this bug is still open, I would like to take it up as my first bug. Any suggestions ?
Comment 6 Yousuf Philips (jay) 2014-11-24 22:25:52 UTC
Yes it is still open Rishabh. Please go for it. :D
Comment 7 Cor Nouws 2014-11-26 17:37:14 UTC
(In reply to Rishabh from comment #5)
> If this bug is still open, I would like to take it up as my first bug. Any
> suggestions ?

Thanks, Please look at comment 2 (here too ;) ) and if you need more suggestions, go to the developer mail list or irc.
Cor
Comment 8 Yousuf Philips (jay) 2015-02-17 07:30:36 UTC
@Cor: 'needDevEval', not 'NeedsDevEval', is described as "Use when you think a bug will qualify as an easy hack and you are requesting a developer to confirm.", but a developer (meeks) has already confirmed this, so why are you replacing the whiteboard keywords?

https://wiki.documentfoundation.org/QA/Bugzilla/Fields/Whiteboard/Advanced#needDevEval
Comment 9 Cor Nouws 2015-02-17 10:19:58 UTC
Sorry - mistake in bulk handling!
Comment 10 Brent Ritzema 2015-04-07 00:59:51 UTC
Hi it looks like this isn't being worked on at the moment. I would like to work on it. I was wondering if someone could point me to the file(s) that contains the current page preview toolbar code. Then if they could also give me some direction on how to add things to that part of the toolbar while also giving some suggestions.. That would be wonderful.

Thanks,
Brent
Comment 11 Brent Ritzema 2015-04-07 04:19:53 UTC
Okay so I found the actual code for this action of setting which page you want to go to.. (sw/srouce/uibase/uiview/pview.cxx) However I can't seem to find where pressing this button calls this code. I tried to find it based on the MV_PAGE_UP case, but I could not find where the toolbar was at all. I am trying to find the location where activating this button calls the MovePage function, however I can't find that. I also can't find where I can add another button to the toolbar (probably the same place). If someone could point me in the correct direction that would be great.
Comment 12 Gülşah Köse 2015-10-23 20:29:19 UTC
Hi all,

I'm about to complete this issue. I've sent 4th version patch: https://gerrit.libreoffice.org/#/c/19335/4

I need help. I've defined my problem as comment in gerrit. Now i want to get aPageNum's value from SID_JUMP_TO_SPECIFIC_PAGE case to jump to page which user's want. How can i do it?
Comment 13 Commit Notification 2015-11-01 17:42:50 UTC
Gulsah Kose committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c2a76550a287adf8bdbe93c02395fb80cb11c950

tdf#80657 Adding new field to jump to specific page.

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 14 Robinson Tryon (qubit) 2015-12-16 00:10:44 UTC
Migrating Whiteboard tags to Keywords: (EasyHack DifficultyBeginner SkillCpp TopicCleanup  )
[NinjaEdit]