Download it now!
Bug 80668 - FILESAVE: Table row height not retained when reopened from saved html file
Summary: FILESAVE: Table row height not retained when reopened from saved html file
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-06-29 09:10 UTC by Grigoriy Kramarenko
Modified: 2015-03-04 17:08 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Original report from ERP system (4.51 KB, text/html)
2014-07-12 05:54 UTC, Grigoriy Kramarenko
Details
Report after save (5.33 KB, text/html)
2014-07-12 05:54 UTC, Grigoriy Kramarenko
Details
Original view (52.39 KB, application/pdf)
2014-07-12 05:56 UTC, Grigoriy Kramarenko
Details
this is how it looks like in 3.6 for me (52.16 KB, application/pdf)
2014-07-12 22:09 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Grigoriy Kramarenko 2014-06-29 09:10:53 UTC
Problem description: all 4.x.x versions work with HTML not correct. These versions can not be used to open the html-reports prepared by other programs.

Steps to reproduce:
1. Open NEW file in Writer.
2. Add table (2x2 or greate) on page and filling it.
3. Memory height of rows in table.
4. Save document as HTML file and close.
5. Open this HTML file... 

Current behavior:
Every row in table is very biggest by height.

Expected behavior:
The document should look exactly as it was originally.

Latest known-working version: 3.6.7
           
Operating System: All
Version: 4.2.5.2 release
Comment 1 Yousuf Philips (jay) (retired) 2014-07-06 03:25:04 UTC
Hello DJ,

I tested the issue in 3.3.0, 3.6.7 and 4.2.5 on Linux Mint and all produced the same bigger space. If this doesnt happen for you, please provide the html file produced that works fine in 3.6.7.
Comment 2 Grigoriy Kramarenko 2014-07-12 05:54:11 UTC
Created attachment 102656 [details]
Original report from ERP system
Comment 3 Grigoriy Kramarenko 2014-07-12 05:54:49 UTC
Created attachment 102657 [details]
Report after save
Comment 4 Grigoriy Kramarenko 2014-07-12 05:56:42 UTC
Created attachment 102658 [details]
Original view
Comment 5 Grigoriy Kramarenko 2014-07-12 05:58:29 UTC
Hello Jay,

I use GNU/Debian Wheezy + Libreoffice 3.5.4.2 from repo.
My staff work in Windows and they use Libreoffice 3.6.7.

We open reports from our ERP-System in Writer. On these versions opens fine. But reopen after saving do not works. 

See attach...
Comment 6 Yousuf Philips (jay) (retired) 2014-07-12 22:09:39 UTC
Created attachment 102683 [details]
this is how it looks like in 3.6 for me

I've attached how the html file looks in 3.6.7. Basically having large rows.
Comment 7 Grigoriy Kramarenko 2014-07-13 02:32:22 UTC
So the situation is even worse than I thought. Absolutely unpredictable behavior in 3 version.
Comment 8 Yousuf Philips (jay) (retired) 2014-07-13 15:20:44 UTC
Yes i wouldnt rely on html opening correctly between versions as with your example file, it doesnt open correctly in 4.2 and above, so i had to file 3 bugs for that about the page size being incorrect, borders not appearing, cell background not showing, and html styles not appearing correctly.

I removed all the css from your sample html file and changed it to a non-css html file and that loaded better in 4.2, but when i saved the file, it converted it to a css based html file, with css styles defined in style="" rather than in class="".