Download it now!
Bug 80680 - Solver crashes on Windows on a particular spreadsheet (summary: comment 17)
Summary: Solver crashes on Windows on a particular spreadsheet (summary: comment 17)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: All Windows (All)
: high critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: notBibisectable, regression
: 88544 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-06-29 15:22 UTC by Charlie
Modified: 2015-12-17 10:57 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
XLS file referenced by the original bug report (81.50 KB, application/vnd.ms-excel)
2014-10-07 12:47 UTC, Philipp Weissenbacher
Details
Apple call trace (82.34 KB, text/plain)
2015-01-19 17:01 UTC, Alex Thurgood
Details
full bt (25.79 KB, text/plain)
2015-01-20 13:03 UTC, Alex Thurgood
Details
OSX - fragment of SAL_LOG=yes output (781 bytes, text/plain)
2015-01-29 07:32 UTC, Matthew Francis
Details
Screenshot: solving with 4.5 alpha from Jan 25 2015 (43.98 KB, image/jpeg)
2015-01-29 08:41 UTC, Buovjaga
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Charlie 2014-06-29 15:22:20 UTC
I'm reporting this bug in the Windows release of LO. I have experienced this under releases 4.2.4.2 and 4.2.5.2. 

I’m using the solver to find the minimum of a non-linear function calculated in the spreadsheet found here:
http://claub.net/temp/Solver-crashes-CALC.xls

The optimized quantity is a sum-of-squares error, cell A134, and the value in this cell should fall to 10 or less. I set up the solver to find a minimum by manipulating the values in cells F13 through F17. The initial values I choose are F13=1.0 and the other set to zero.

The solver runs for what seems like a long time (more than a minute on my machine) and makes some progress reducing the error. Then it, and calc, crash and close. This happens every time. In the LO Calc solver, I have tried both the DEPS and SCO algorithms and both only make very slow progress and then crash.

When I open the spreadsheet in Excel and use its solver (the GRG nonlinear algorithm) to perform the minimization from the same initial conditions (and others) it finishes in about 1-2 seconds and never crashes. This seems to indicate that the minimization problem itself is not the cause of the crashing behavior. Also, I reported this bug on another forum, and a user there could not reproduce the crash under GNU/Linux running LO v4.1 and v4.2 so it might be a LO Windows build-specific problem.

Thanks,

Charlie
Comment 1 Ken Biondi 2014-07-27 20:53:34 UTC
I confirmed this bug.  Changing status to highest blocker since this bug always causes LO to close.

MSO 2013 returns a value of 0.016671001 in less than 2 seconds.

I tested using:

x86-64
WIN 8
Version: 4.2.5.2
Build ID: 61cb170a04bb1f12e77c884eab9192be736ec5f5
Comment 2 Björn Michaelsen 2014-08-21 12:21:18 UTC
(This is an automated message.)

LibreOffice development currently prioritizes bugs with the so called MAB (most annoying bugs) -- as this bug has not run through that process (including writing a short rationale for this bug being a candidate and other who are watching the tracker bug silently approving that rationale etc.) its priority is set to high. Note this is effectively no change in the urgency assigned to this bug, as we are currently not making a difference between high and highest and severity is untouched.

You can find out more about MABs and how the process works by contacting libreoffice qa on irc:

 http://webchat.freenode.net/?channels=libreoffice-qa

The QA wiki page also gives you hints on how to get in contact with the team (if IRC fails you, your next best choice is the mailing list):

 https://wiki.documentfoundation.org/QA
Comment 3 Philipp Weissenbacher 2014-10-07 12:47:03 UTC
Created attachment 107490 [details]
XLS file referenced by the original bug report

I added the file provided as a link by the original bug author so that our testing infrastructure can pick it up.
Comment 4 Markus Mohrhard 2014-12-29 16:02:18 UTC
Blockers are reserved for developers and the release engineers. If that would have been a blocker it would have been brought to the attention of the ESC already and as we see it did not block any release.
Comment 5 Alex Thurgood 2015-01-19 16:58:47 UTC
Confirming also on OSX 10.10.1


How to reproduce

1) Open an empty Calc document
2) Navigate to Tools > Solver
3) Spinning beachball appears, leading to sudden window closure SIGABRT
Comment 6 Alex Thurgood 2015-01-19 16:59:25 UTC
Tested on master 4500alpha OSX 10.10.1


Enclosing Apple call trace
Comment 7 Alex Thurgood 2015-01-19 17:00:23 UTC
Application Specific Information:
abort() called
terminating with unexpected exception of type com::sun::star::loader::CannotActivateFactoryException
Comment 8 Alex Thurgood 2015-01-19 17:01:25 UTC
Created attachment 112487 [details]
Apple call trace
Comment 9 Alex Thurgood 2015-01-20 13:03:45 UTC
Created attachment 112546 [details]
full bt

Full backtrace with master 4500alpha
Comment 10 Alex Thurgood 2015-01-20 13:21:58 UTC
Regression over

Version: 4.1.4.2
Build ID: 0a0440ccc0227ad9829de5f46be37cfb6edcf72
Comment 11 Alex Thurgood 2015-01-20 13:24:11 UTC
Worksforme in

Version: 4.2.4.2
Build ID: 63150712c6d317d27ce2db16eb94c2f3d7b699f8

OSX 10.10.1
Comment 12 Alex Thurgood 2015-01-20 13:25:51 UTC
Crashes in

Version: 4.3.5.2
Build ID: 3a87456aaa6a95c63eea1c1b3201acedf0751bd5

OSX 10.10.1
Comment 13 Owen Genat (retired) 2015-01-24 23:34:25 UTC
*** Bug 88544 has been marked as a duplicate of this bug. ***
Comment 14 Spencer Graves 2015-01-25 01:05:23 UTC
Solver works with LO Calc 4.3.4.1 without the "Solver for nonlinear programming 0.9" extension under Windows 7, successfully minimizing a quadratic.  However, with this extension, Solver kills Calc saying, "LibreOffice quit unexpectedly" with LO 4.3.4.1, 4.3.5.1, 4.3.6.1, 4.4.0.2 under Mac OS X 10.10.1 and 4.3.5.2 under Windows 7.  With LO 4.3.5.1 under Ubuntu 14.04 LTS without this extension when asked to minimize a quadratic (A1=1, A2=2, A3=(a1-a2)*(a1-a2), min. a3 by varying A1), it displays a different error message:  "No solution was found.  The model is not linear."  I can't find how to install this extension under Ubuntu nor how to delete it under any of the other operating systems.  However, I got this same message under LO 4.3.5.2 under Mac OS X 10.10.1.  In that case, I was able to install the extension and convert the "No solution" message to "LO quit unexpectedly".  If someone can help me install the "Solver for nonlinear programming 0.9" under Ubuntu or remove or disable it elsewhere, I can do more tests.  Thanks for your support of LibreOffice.  As I said for another FOSS project, people all over the world live better today because of your contributions to this project.  Spencer Graves
Comment 15 Matthew Francis 2015-01-29 07:32:17 UTC
Created attachment 112903 [details]
OSX - fragment of SAL_LOG=yes output

The attached fragment of SAL_LOG=yes output suggests that for OSX at least we are trying to load libCbc.3.dylib from the wrong place when Solver is invoked
Comment 16 Matthew Francis 2015-01-29 07:34:04 UTC
Setting Whiteboard - notBibisectable; this is a Windows and OSX only bug, and doesn't appear to be in the bibisect range available for OSX
Comment 17 Matthew Francis 2015-01-29 07:51:43 UTC
The OSX problem mentioned above turns out to be unrelated, and will be fixed on bug 80370.

This bug report is for an issue that is specific to Windows, as reported in comment 0 and confirmed in comment 1
Comment 18 Buovjaga 2015-01-29 08:41:31 UTC
Created attachment 112905 [details]
Screenshot: solving with 4.5 alpha from Jan 25 2015

It didn't crash, but am I doing it right?

Win 7 Pro 64-bit Version: 4.5.0.0.alpha0+
Build ID: 784d069cc1d9f1d6e6a4e543a278376ab483d1eb
TinderBox: Win-x86@62-TDF, Branch:MASTER, Time: 2015-01-25_23:07:36
Comment 19 Buovjaga 2015-01-29 08:51:35 UTC
Setting to NEEDINFO as I'm not sure, what the exact reproduction steps are.
Comment 20 Spencer Graves 2015-02-05 19:36:26 UTC
FIXED in LO 4.5.0.0alpha0_MacOS_x86-64.dmg under OS X 10.10.1 and OS X 10.10.2.  To be precise, it worked with my toy example A1=1, A2=2, A3=(A1-A2)^2, Tools -> Solver -> minimize A3 by varying A1.  Answer was close to 2 in 10.10.1 and displayed as exactly 2 in 10.10.2.  Much thanks to the LO developers!
Comment 21 Buovjaga 2015-02-05 19:46:22 UTC
Thanks for testing. Setting to WFM per comment 20.
Comment 22 Robinson Tryon (qubit) 2015-12-17 10:57:16 UTC
Migrating Whiteboard tags to Keywords: (notBibisectable)
[NinjaEdit]