Bug Hunting Session
Bug 80693 - EDITING: fill cell with random numbers with min = max
Summary: EDITING: fill cell with random numbers with min = max
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.4.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:6.2.0
Keywords: needsDevEval
Depends on:
Blocks:
 
Reported: 2014-06-29 21:51 UTC by libreoffice.bugzilla
Modified: 2018-06-01 09:18 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description libreoffice.bugzilla 2014-06-29 21:51:40 UTC
select some cells
use Edit > Fill > Random number
put same value in minimum and maximum
click apply or ok button
=> infinite loop
Comment 1 Ken Biondi 2014-07-27 15:58:11 UTC
What exactly do you mean by "infinite loop"?  Can you explain this infinite loop behavior? Anyway, nothing strange happened for me when I tried to recreate this bug in LO 4.2.5.2
Comment 2 Algot Runeman 2014-07-29 23:11:46 UTC
Test System:
Kubuntu 4.13.2
LibreOffice 4.2.4.2

The described behavior occured for me, stalling the system. Attempting to close the dialog box caused a popup to say the application was not responding (Infinite loop?)

I would expect the behavior to be a message to say that the min and max cannot be the same.

LibreOffice 4.3.0.3

Same behavior as 4.2.3.2
Comment 3 Ken Biondi 2014-07-30 02:42:46 UTC
(In reply to comment #1)
> What exactly do you mean by "infinite loop"?  Can you explain this infinite
> loop behavior? Anyway, nothing strange happened for me when I tried to
> recreate this bug in LO 4.2.5.2

I misread the original bug description.  I can now confirm this in 4.2.5.2.
Comment 4 QA Administrators 2015-09-04 02:49:15 UTC Comment hidden (obsolete)
Comment 5 Robinson Tryon (qubit) 2015-12-10 07:26:37 UTC Comment hidden (obsolete)
Comment 6 QA Administrators 2017-01-03 19:41:01 UTC Comment hidden (obsolete)
Comment 7 Commit Notification 2018-05-29 18:28:26 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f5af8615e40bca1a747695c8ca28675c4ab0d384

uitest for bug tdf#104117 and tdf#80693

It will be available in 6.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 raal 2018-05-30 05:19:22 UTC
Cannot reproduce with Version: 6.2.0.0.alpha0+
Build ID: c0fbf99e5601da27c59d131bcca24fafd259e508
CPU threads: 4; OS: Linux 4.4; UI render: default; VCL: gtk3; 
and 6.0.4.2 (x64), windoes 7

Please retest with current version. Thank you.
Comment 9 Xavier Van Wijmeersch 2018-05-30 14:24:34 UTC
Cannot reproduce with

Version: 6.1.0.0.beta1+
Build ID: e42f6174d30c9f2211bdaffdefb011eeb9ead1fc
CPU threads: 8; OS: Linux 4.14; UI render: default; VCL: kde4; 
Locale: nl-BE (en_US.UTF-8); Calc: group threaded
Comment 10 Xisco Faulí 2018-06-01 09:18:56 UTC
Thanks for retesting with the latest master version
Setting to RESOLVED WORKSFORME as the commit fixing this issue hasn't been identified.