Bug Hunting Session
Bug 80735 - Add option to force soffice to Start Center
Summary: Add option to force soffice to Start Center
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-01 00:06 UTC by Luke
Modified: 2014-07-06 03:53 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2014-07-01 00:06:01 UTC
In Linux with a fresh build of LibreOffice, when you start ./soffice the start center will load until you select a new document. From then on ./soffice will launch directly to whatever type you selected "new" on in the start center. For example, if you started it and selected new writer, it would be the same as ./soffice --writer. From then on, writer will launch instead of the start center with the "./soffice" command. In the --help there is no option to launch the Start Center.

If this behavior is by design, then there should be a parameter like ./soffice --center to go back to the start center.
Comment 1 V Stuart Foote 2014-07-01 20:56:28 UTC

*** This bug has been marked as a duplicate of bug 77590 ***
Comment 2 Luke 2014-07-05 00:25:27 UTC
Can you please confirm that in Linux selecting "Create: Writer Document" is supposed to prevent the Start Center from ever loading again? This is a feature and not a bug? If it is by design, I guess you can close this bug as a dupe.
Comment 3 V Stuart Foote 2014-07-06 02:41:17 UTC
(In reply to comment #2)
> Can you please confirm that in Linux selecting "Create: Writer Document" is
> supposed to prevent the Start Center from ever loading again? This is a
> feature and not a bug? If it is by design, I guess you can close this bug as
> a dupe.

No, that is not what should happen. Rather, when you are finished with the Writer document and save (or rename) it, use <Ctrl> F4 to close the Writer window. When no other documents of any component are open--the soffice.bin process will shift things back to the Start Center.  Using <Alt> F4, or exiting the program will kill the soffice.bin process completely.

This all works correctly for me on Centos RHEL 6.5, 64-bit with 
Version: 4.3.0.2
Build ID: 14ed55896fdfcb93ff437b85c4f3e1923d2b1409
Comment 4 Luke 2014-07-06 03:53:55 UTC
I just built a the latest version of branch master. When I execute ./soffice, LibreOffice is no longer defaulting to writer. I think this issue has been fixed recently.