Download it now!
Bug 80750 - FILESAVE: Drawing inside chart lost in LO 4.2.x
Summary: FILESAVE: Drawing inside chart lost in LO 4.2.x
Status: RESOLVED DUPLICATE of bug 74333
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.0.0.beta1
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: regression
Depends on:
Blocks:
 
Reported: 2014-07-01 07:46 UTC by Stefan
Modified: 2014-07-02 22:26 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments
Screenshot (306.91 KB, image/jpeg)
2014-07-01 14:14 UTC, Stefan
Details
Example for the Squares in a diagramm (502.28 KB, image/jpeg)
2014-07-01 14:27 UTC, Stefan
Details
Sample file (153.21 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-07-02 06:17 UTC, Stefan
Details
Screenshot (333.67 KB, image/jpeg)
2014-07-02 06:18 UTC, Stefan
Details
Screenshot (319.54 KB, image/jpeg)
2014-07-02 06:18 UTC, Stefan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stefan 2014-07-01 07:46:45 UTC
Problem description: Drawings like squares or lines are not saved and disapear after one re-opens a file (*.ods).

Steps to reproduce:
1. create a file
2. put in a coloured square or a line
3. save and close the file
4. re-open the file

Current behavior:

Expected behavior:

              
Operating System: Windows 7
Version: 4.2.5.2 release
Last worked in: 4.2.4.2 release
Comment 1 ign_christian 2014-07-01 12:46:15 UTC
Not reproducible in LO 4.2.5.2 - Ubuntu 12.04 x86

@Stefan, have you tried resetting user profile?
https://wiki.documentfoundation.org/UserProfile
Comment 2 Stefan 2014-07-01 13:54:07 UTC
I have to specify my message:
A square or Line in the sheet remains, but a drawing in a diagramm disappears. Thats new in the newest version. it worked in the older versions.
Comment 3 ign_christian 2014-07-01 14:04:50 UTC
Please provide step by step procedure to reproduce the problem. We can't locate the bug with minimalist info.

Then please change status back to UNCONFIRMED after you provide all details.
Comment 4 Stefan 2014-07-01 14:14:31 UTC
Created attachment 102073 [details]
Screenshot

The thick red line in the diagramm is painted by me. After i have saved the file, closed it and opend it again, the red line has diesappeared.
Comment 5 Stefan 2014-07-01 14:23:07 UTC
I try it once more to describe what I have done and where I have a problem.

In CALC I created a sheet, where i write down my training on bycicle. In this sheet I created a diagram, which shows me how much km I drove in average in the past time.

In this Diagramm I draw a red line, which shows me, where I should be, to reach my goal to drive 5 km a day.

This red line dissappeares after I saved, closed and re-opened the File.

The same happened in another file, where I coloured some areas in a diagramm by drawind a red, a yellow and a green transparent square.
Comment 6 Stefan 2014-07-01 14:27:38 UTC
Created attachment 102074 [details]
Example for the Squares in a diagramm
Comment 7 ign_christian 2014-07-01 16:12:36 UTC
Em..I still can't reproduce. Perhaps you could attach sample document for testing (with chart) & explain how we should draw the line ?
Comment 8 Stefan 2014-07-02 06:17:48 UTC
Created attachment 102109 [details]
Sample file
Comment 9 Stefan 2014-07-02 06:18:24 UTC
Created attachment 102110 [details]
Screenshot
Comment 10 Stefan 2014-07-02 06:18:48 UTC
Created attachment 102111 [details]
Screenshot
Comment 11 Stefan 2014-07-02 06:22:10 UTC
(In reply to comment #7)
> Em..I still can't reproduce. Perhaps you could attach sample document for
> testing (with chart) & explain how we should draw the line ?

I have submitted 3 Files: a the ods-file and to Screenshots (wit and withot the Line and the square.

Take the samplefile, double-click on the diagramm and paint somthing in the diagramm. Do not paint in the sheet across the Diagram, because then the lines will not move if you move the diagramm.

I Hope, this will help to reproduce the bug.
Comment 12 ign_christian 2014-07-02 07:17:43 UTC
Ok I got it. Using chart in sheet '2014 Daten' and painting using simple line inside x-y chart area. Lost after saving & reopening.

Reproduced in 4.2.5.2, 4.2.0.0.beta1
Not reproduced in 4.1.6.2, 4.3.0.1

So the problem is in 4.2.x, I wonder how it works well in 4.2.4.2 as stated in comment 0 ?
Comment 13 ign_christian 2014-07-02 16:02:46 UTC
> So the problem is in 4.2.x, I wonder how it works well in 4.2.4.2 as stated
> in comment 0 ?
Just did testing, also broken in 4.2.4.2. Not only ODS, also XLSX. Only XLS survived.
Comment 14 Markus Mohrhard 2014-07-02 22:26:49 UTC

*** This bug has been marked as a duplicate of bug 74333 ***