Bug 80752 - UX proposal, a relatively easy way to improve LibreOffice visual appearance (but not Ribbons)
Summary: UX proposal, a relatively easy way to improve LibreOffice visual appearance (...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: needsUXEval
: 64184 99219 (view as bug list)
Depends on:
Blocks: Notebookbar Toolbars
  Show dependency treegraph
 
Reported: 2014-07-01 07:59 UTC by Ljiljan
Modified: 2017-04-15 20:05 UTC (History)
9 users (show)

See Also:
Crash report or crash signature:


Attachments
image appareance (54.79 KB, image/png)
2014-07-01 07:59 UTC, Ljiljan
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Ljiljan 2014-07-01 07:59:43 UTC
Created attachment 102058 [details]
image appareance

Problem description: 

This is not problem. This is idea for improvement (sugesstion) which could make LibreOffice even better than Microsoft Office. 

Idea is the following: all toolbars will have the same (fixed) position while above toolbar you can select which toolbar to use. In this case, menus are still kept while ribbons from Microsoft Office is not imitated. I find this even better solution than Ribbons (image is attached).

I believe this is not difficult to implement. Users could also select the way toolbars behave.  



Steps to reproduce:
Since this is not a bug, but sugesstion (I came to this site by cliclinkg Help -> Send Feedback), there are no steps to reproduce.

Current behavior:

Default way of appearing toolbars can disturb you. For example: you draw a line in Impress and "Line and Formatting" toolbar pop up or appear on toolbar line (in this case your content/ slide is moved or zoom out). Also, they take too much space since you use more that one toolbar at the time. 

Expected behavior:

Existing toolbars will be used, but the way they behave will change. Toolbars will have fixed position. Specific toolbars will appear if you click on table or drawing a object, while users can easly click which toolbar to use.
              
Operating System: Ubuntu
Version: 4.2.5.2 release
Comment 1 Cor Nouws 2014-07-01 08:58:12 UTC
Hi Ljiljian

Nice idea to add to the discussion. > UX-advise :)
Thanks,
Cor
Comment 2 Adolfo Jayme 2014-07-01 10:02:58 UTC
Hi, just chiming in for a friendly side comment:

> I believe this is not difficult to implement

Unless you’re a developer and you have studied a part of the LibreOffice code base, you have no idea of how easy or difficult it would be to implement.
That is something I get to hear many, many times on bug trackers, but it will be implemnted only when someone finds the time to do it.
Comment 3 Ljiljan 2014-07-01 10:10:11 UTC
I wasn't trying to say that this could be done in 5 minutes, but it is much easier than building ribbons for example. But solutions is good and different than ribbons.

Existing toolbars will be used. Those toolbars can have fixed position already. The new code that should be done is that only one toolbar is visible at the moment  and it always appear below menu. Also, a frame with toolbar names should be added which will control what is visibled. 

I am aware that this is pretty simplistic explanation. As I said, it is not 5-minute work, but much easier to implement than existing sidebar (which was borrowed from OO).
Comment 4 V Stuart Foote 2014-07-01 12:29:49 UTC
Lijan,

Interesting UX idea, thanks for the mockup. Essentially a menu of toolbars. But only the active toolbar would be exposed--and structured so as to appear in a common location.  

Bear in mind that it must function well, in addition to any fresh visual appeal.

Suspect it would need to have tear aways (user chooses toolbars which can be exposed at all times and positioned as they prefer).

Please register and expand on it over on the Design wiki -- https://wiki.documentfoundation.org/Design
Comment 5 Hillar 2014-07-01 12:42:47 UTC
Isn't it similar idea?:
http://t6uni.deviantart.com/#/art/OOo-mockup-181260508?hf=1
Comment 6 Ljiljan 2014-07-01 13:58:29 UTC
It's not the same because my idea does not require building new toolbars/ ribons but only the way they behave... 

I like the idea (http://t6uni.deviantart.com/#/art/OOo-mockup-181260508?hf=1) but it requires to build everything from the beginning.
Comment 7 Heiko Tietze 2014-07-02 08:28:53 UTC
For me, a big advance of LO over MSO is the flexibility of toolbars. I'm using two sidebars on my widescreen, one left-hand with the Navigator and on the right with the formatting stuff. 
Toolbars are dockable. That means you drag it to a certain position and it should be sticky there, and just hidden when not applicable. If you dock for instance the toolbar for table formatting at the bottom left and the graphics details on the same position you should achieve what you describe right now. Otherwise I would treat it as a bug (docked position is not properly stored).
Comment 8 Yousuf Philips (jay) (retired) 2014-07-31 06:45:42 UTC
Just dropping my two cents. The problem i see with this single bar proposal is that users would constantly need to switch from toolbar to toolbar to get most work done. Here is a simple example.

If i needed to insert a table, i'd have to activate the standard toolbar, then maybe i write my name in the first cell and then i want to make it bold. I'd then have to switch to the formatting toolbar to do so, then maybe i want to link my name to my twitter url. I'd have to again switch to the standard toolbar in order to do so.

I dont think that limiting libreoffice to a single toolbar will be beneficial as it simply reduces the amount of features that are accessible at a given time.

Also from your proposed image, it seemed as if menus were eliminated, which would be a bad thing, as not all features found in menus are available in toolbars.
Comment 9 Norbert X 2014-10-04 11:54:08 UTC
I'll copy my comment from https://bugs.freedesktop.org/show_bug.cgi?id=81475#c23 here:

I think that dynamic appearance/disappearance of toolbars is not a good idea.

For me it is comfortable to place toolbars once and use them when I want to use them, not contextually (current object- or action- dependent).
But now in 4.3.2 toolbars disappear even if they have Lock Toolbar Position option checked. Please enable static toolbar positions. 

Popping toolbars may cause attention switch and may lower document author's productivity. Otherwise you will create another stupid, ugly, non-usable Ribbon/MFI. I think that many LibreOffice users would be happy with MS Office 2003-like interface.

Users do not need bells and whistles, they need comfortable and customizable interface. This interface should allow users to place and pin (lock) toolbars as they want and use keyboard shortcuts for more productivity (for example, the fastest way to add Cross-Reference is to press <Alt-i><e>).
Comment 10 Ljiljan 2014-10-04 16:37:55 UTC
My suggestion was not to remove current way of toolbar behavour, but rather to add possibilities for users to choose. You want flexibile toolbars -> somewhere in options you should be able to select it. You want fixed toolbar, but changing accoring to context -> you should be able to select this option.

Current toolbar behaviour is annyoing (not completely, but at least 20% of my time). There is no way to disable some toolbars for appearing and changing their position (somehow you can change for current session). 

I would like to completely switch to sidebar, but some options are still missing there so combination of toolbar and sidebar is still required.

I prefer minimalistic design. Only most important toolbars should be enabled. When I want to insert table, table toolbar popup but it usualy take some aditional place on my screen and it moves my text down. When I click somewhere else (outside table) it dissapears and move my text up. Then you move again to the table and toolbars appear and move your text up/ down. I agree that this problem would be fixed if I keep table toolbar on fixed position, but that means less space for real work (writing text and creating other content). I find this annoying, but I understand that some people want to have 25 toolbars open at the same time. But I don't. So creating this option would give both group of people what they want.

Table toolbar is not the only problem. Navigation toolbar keeps pop-up-ing as well as some other toolbars.
Comment 11 Yousuf Philips (jay) (retired) 2014-10-06 03:06:27 UTC
(In reply to Ljiljan from comment #10)
> I would like to completely switch to sidebar, but some options are still
> missing there so combination of toolbar and sidebar is still required.

As you would like to switch exclusively to the sidebar, then IBM Symphony's single toolbar row, plus contextual toolbar, is the best way to achieve this. I have gathered quite a bit of info on how this can be made possible at < https://redmine.documentfoundation.org/boards/1/topics/163 >. You can see a screenshot of Symphony's single toolbar row at -

https://redmine.documentfoundation.org/attachments/download/235/IBM%20Symphony%20Toolbars.png

> I prefer minimalistic design. Only most important toolbars should be
> enabled. When I want to insert table, table toolbar popup but it usualy take
> some aditional place on my screen and it moves my text down. When I click
> somewhere else (outside table) it dissapears and move my text up. Then you
> move again to the table and toolbars appear and move your text up/ down. I
> agree that this problem would be fixed if I keep table toolbar on fixed
> position, but that means less space for real work (writing text and creating
> other content). I find this annoying, but I understand that some people want
> to have 25 toolbars open at the same time. But I don't. So creating this
> option would give both group of people what they want.

I think you can fix the table toolbar popup issue by moving it to the top next to the standard or formatting toolbars. I have been working on bringing the table toolbar options into the sidebar. More details can be found at < https://redmine.documentfoundation.org/boards/1/topics/121 > and a mockup can be seen at -

https://redmine.documentfoundation.org/attachments/download/217/proposal%20-%20table.png
Comment 12 Yousuf Philips (jay) (retired) 2015-01-06 12:54:00 UTC
Stumbled on this bug report again and noticed that the mockup resembled Zoho Writer's toolbar UI.

https://www.zoho.com/mail/images/online-word-processor.png

https://gigaom2.files.wordpress.com/2009/03/zohonew.png
Comment 13 Ljiljan 2015-01-07 06:59:33 UTC
I like the ZOHO way of solving this problem.

How much would it cost to pay someone for implemention of this option? (as alternative way of toolbar appearance)? And how to offer this? Just wondering :) I think LO team would not mind if this option is implemented. It could be enabled in Tools -> Options -> LibreOffice -> View:

 " [x] Standard way of toolbar behaviour
   [ ] Fixed way of toolbar behaviour"

This is one additional global variable (TOOLBAR_BEHAVIOUR).

Current code for "standard way" already exist, so just new code of showing and hiding toolbars should be implemented :)
Comment 14 QA Administrators 2015-07-18 17:35:26 UTC Comment hidden (obsolete)
Comment 15 QA Administrators 2015-09-04 03:00:45 UTC Comment hidden (obsolete)
Comment 16 Yousuf Philips (jay) (retired) 2015-09-04 08:03:42 UTC
Not sure why this was left as NEEDINFO, so setting it back to NEW.
Comment 17 Heiko Tietze 2016-08-02 15:16:03 UTC
*** Bug 64184 has been marked as a duplicate of this bug. ***
Comment 18 Robinson Tryon (qubit) 2016-08-25 05:49:32 UTC Comment hidden (obsolete)
Comment 19 Heiko Tietze 2016-09-16 08:10:25 UTC
This idea has been realized and is finalized now. See 102062 for what's missing.
Comment 20 Heiko Tietze 2016-09-21 08:01:27 UTC
*** Bug 99219 has been marked as a duplicate of this bug. ***