Download it now!
Bug 64184 - CONFIGURATION: Enhancement Bug - gnome3 extension ribbon
Summary: CONFIGURATION: Enhancement Bug - gnome3 extension ribbon
Status: RESOLVED DUPLICATE of bug 80752
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: ux-advise (show other bugs)
Version:
(earliest affected)
3.6.6.2 release
Hardware: Other Linux (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-05-03 14:17 UTC by Megh Parikh
Modified: 2016-08-02 15:16 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
The terminal extension and the taskbar extension in the panel (84.70 KB, image/png)
2013-05-03 14:17 UTC, Megh Parikh
Details
The proposed UI (43.21 KB, image/svg+xml)
2013-05-23 16:41 UTC, Megh Parikh
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Megh Parikh 2013-05-03 14:17:40 UTC
Created attachment 78810 [details]
The terminal extension and the taskbar extension in the panel

Problem description: 
A GNOME3 Extension Provides much flexibility.
This request is about making better use of this for GNOME desktop environment.
This request will help designing a very customizable toolbar using the capabilities of HTML and Javascript.

Steps to reproduce:
1. A gnome3 extension can be developed with a very customizable HTML 
   interface / a ms office ribbon likeinterface which uses dbus for 
   communication with libreoffice applications.
2. It can have a drop down thing like drop down terminal extension of 
   gnome3, a drop down should open whenever libreoffice is opened.
3. It can also have tabs using source-code from the taskbar gnome3  
   extension.
4. Also for Bold, Italic and Underline AND alignment options buttons
   like  the nautilus location bar should be used using CSS and check
   and radio buttons respectively.
5. I suggest using Black and white themes like Faenza Icons

Current behavior: The libreoffice toolbar looks dull and many a times 
     buttons are hard to find. Customization doesnt bring much change 
     and separators should be dynamic.

Expected behavior:The libreoffice toolbar will look interesting.
     Buttons will be easier to find as HTML customiztion will have 
     flexibitity and separators would be dynamic.

              
Operating System: Fedora
Version: 3.6.6.2 release
Comment 1 Megh Parikh 2013-05-23 16:41:16 UTC
Created attachment 79714 [details]
The proposed UI
Comment 2 Megh Parikh 2013-05-23 16:46:17 UTC
The GS idea was abandoned because I heard this is possible with GTK
And then libreoffice can use this interface
Comment 3 Megh Parikh 2013-05-23 16:46:56 UTC
Also include support for the older interface
Comment 4 mahfiaz 2013-05-23 18:45:16 UTC
This on here is generally a proposal to use ribbons but with extra suggestions about choice of tools, which makes it duplicate of #56711.
Also, it is not a good idea to make main toolbar to work over dbus.

As for monochromatic icons, these are already in works.

*** This bug has been marked as a duplicate of bug 56711 ***
Comment 5 Megh Parikh 2013-05-24 17:40:45 UTC
(In reply to comment #4)
> This on here is generally a proposal to use ribbons but with extra
> suggestions about choice of tools, which makes it duplicate of #56711.
> Also, it is not a good idea to make main toolbar to work over dbus.
> 
> As for monochromatic icons, these are already in works.
> 
> *** This bug has been marked as a duplicate of bug 56711 ***

The Dbus idea was dropped
Also this UI is quite diff from MS office Ribbon inteface
Pls see the new atachment : " The proposed UI "
what i mean by opening the menus line is like pressing Alt key + (F/E/V,etc.)
I have provided button which will open the line
I like the menus UI rather than opening each menu as toolbar (Like ribbon)
Comment 6 Megh Parikh 2013-05-24 17:42:00 UTC
(In reply to comment #5)
> (In reply to comment #4)
> > This on here is generally a proposal to use ribbons but with extra
> > suggestions about choice of tools, which makes it duplicate of #56711.
> > Also, it is not a good idea to make main toolbar to work over dbus.
> > 
> > As for monochromatic icons, these are already in works.
> > 
> > *** This bug has been marked as a duplicate of bug 56711 ***
> 
> The Dbus idea was dropped
> Also this UI is quite diff from MS office Ribbon inteface
> Pls see the new atachment : " The proposed UI "
> what i mean by opening the menus line is like pressing Alt key + (F/E/V,etc.)
> I have provided button which will open the line
> I like the menus UI rather than opening each menu as toolbar (Like ribbon)


pressing the Alt key in firefox

I think I should file it has a new bug as much of my idea has changed
Comment 7 Megh Parikh 2013-05-24 17:43:45 UTC
The GNOME idea was dropped as i learned form GS list that this could be done through GTK
and no need for GS when GTK is so flexible
Comment 8 Joel Madero 2014-11-06 21:56:54 UTC
Moving to UNCONFIRMED for QA input. Thanks
Comment 9 Robinson Tryon (qubit) 2014-12-22 04:40:50 UTC
TO: UX
FROM: QA
Happy Holidays!
Comment 10 Heiko Tietze 2016-08-02 15:16:03 UTC
Thanks for adding your idea here. Actually the toolbar is being under review close to what you suggest. https://wiki.documentfoundation.org/Development/NotebookBar

The reference ticket is 80752, so I close this one as a duplicate.

*** This bug has been marked as a duplicate of bug 80752 ***