Bug 80774 - replace "edit file" with "toggle read-only"
Summary: replace "edit file" with "toggle read-only"
Status: RESOLVED DUPLICATE of bug 80538
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: ux-advise (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: Other Windows (All)
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-01 23:18 UTC by pb
Modified: 2014-07-20 06:06 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description pb 2014-07-01 23:18:51 UTC
In the file open dialog, there is a check mark for "open read-only".

When a file is open read-only, the window title says "read-only".

But for some extremely obscure (to me) reason, the method for toggling between having a file open as read-only, and open with read-write, is called "edit file".  If the file is already open for writing, the plain meaning of that would be a no-op.

It would make much more sense to label this operation as "toggle read-only" or some other phrase that contains the words "read-only."

In addition, it would be useful if this operation appeared under the "File" menu.

Finally, the help documentation is extremely opaque on the subject of read-only:  "Use the Edit File icon to activate or deactivate the edit mode."

Upon first reading this, I had no clue what "activate or deactivate the edit mode" might mean.  Again, this should use the phrase "read-only."  Also, it would be helpful if the help indicated where I might find this "Edit File icon."
Operating System: Windows 7
Version: 4.2.5.2 release
Comment 1 Adolfo Jayme 2014-07-20 06:06:30 UTC
I think we should be removing this button and replacing it with an infobar instead. See bug 80538 comment 11.

*** This bug has been marked as a duplicate of bug 80538 ***