Bug 80793 - FILESAVE: ODS Duplicated attribute in content.xml
Summary: FILESAVE: ODS Duplicated attribute in content.xml
Status: RESOLVED DUPLICATE of bug 80499
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA odf
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-02 08:39 UTC by Sergey Leschenko
Modified: 2014-07-03 13:24 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
File with duplicated attribute (48.02 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-07-02 08:39 UTC, Sergey Leschenko
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Sergey Leschenko 2014-07-02 08:39:49 UTC
Created attachment 102116 [details]
File with duplicated attribute

Problem description: 
When saving ods document, Spreadsheet generates incorrect content.xml.

Steps to reproduce:
Reproducible difficult - steps could not be determined.

Current behavior:
Appears duplicate attribute.

When opening this document we have next error:
Read-Error.
Format error discovered in the file in sub-document content.xml at 2,128014(row,col).

In content.xml on this position we have:

<style:text-properties style:font-name="Arial" fo:font-size="10pt" style:country-asian="SA" style:font-name-asian="Arial" fo:font-weight="normal" style:font-weight-asian="normal" style:font-weight-complex="normal" style:font-name=""/>

In this tag we have duplicated "style:font-name".
When we delete style:font-name="" and pack content of file back to ods - Spreadsheet opening this document correctly.

Also we had same error, but with duplicated fo:color="#000000"

Operating System: Fedora
Version: 4.2.5.2 release
Comment 1 reportingbugs100 2014-07-02 09:32:19 UTC
Can confirm had a document that had the exact same issue with style:font-name="" been the duplicated field in content.xml

4.2.5.2 on windows 7
Comment 2 Jorendc 2014-07-02 20:43:31 UTC
(In reply to comment #1)
> Can confirm had a document that had the exact same issue with
> style:font-name="" been the duplicated field in content.xml
> 
> 4.2.5.2 on windows 7

Then we can mark this bug as NEW.

Kind regards,
Joren
Comment 3 Maxim Monastirsky 2014-07-03 13:24:29 UTC

*** This bug has been marked as a duplicate of bug 80499 ***