Bug 80845 - FILESAVE: User variable data entered into template not saved
Summary: FILESAVE: User variable data entered into template not saved
Status: RESOLVED DUPLICATE of bug 67207
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA interoperability ooxml odf
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-03 10:42 UTC by Kiran Palla
Modified: 2015-01-16 13:49 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Template I tried saving in MS word (26.84 KB, application/vnd.oasis.opendocument.text-template)
2014-07-03 10:42 UTC, Kiran Palla
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Kiran Palla 2014-07-03 10:42:31 UTC
Created attachment 102192 [details]
Template I tried saving in MS word

Problem description: 

I created a template document with some user variables. I tried to create a microsoft word document from that template. All user variables are not saved in microsoft word document.
Steps to reproduce:
1. Set default file save format to -> Microsoft Word
2. Create and Save a Template with some user variables.
3. Create a new document from that template.
4. Fill up the variables.
5. Save the document (to the default docx format).
6. Close all files.
7. Open the Docx file. User variables are lost in this file.

Current behavior:
All the user variable data is just vanishing if saved in microsoft word format.

Expected behavior:
The variables should stay in microsoft word also. As Microsoft word also supports fields, there is a problem in conversion of fields (variables) from Writer to MS Word.

IF that is not possible immediatly, atleast the data in the variables should stay as plain text in the document.
              
Operating System: Windows (other)
Version: 4.2.4.2 release
Comment 1 Yousuf Philips (jay) (retired) 2014-07-06 02:48:54 UTC
Hello Kiran,

I can confirmed in Linux Mint in 3.3.0, 4.2.5, 4.3.0 and master that the data entered in the fields arent saved in docx or odt formats.
Comment 2 Kiran Palla 2014-07-07 03:51:21 UTC
I noticed this problem in Windows Vista Home Basic.

I am not entering user variables directly in docx format.
I am putting them into a ott file, so I can use the file regularly.
Then input some data into the variables and save as docx file. Then I opened using MS Word, then no variables are there.

If I save in writer format, then variables are working fine.
Comment 3 Matthew Francis 2015-01-16 13:49:25 UTC

*** This bug has been marked as a duplicate of bug 67207 ***