Download it now!
Bug 80859 - FILEOPEN: error opening MS Excel 2003 XML document
Summary: FILEOPEN: error opening MS Excel 2003 XML document
Status: RESOLVED DUPLICATE of bug 68742
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-03 16:49 UTC by Bob Bib
Modified: 2015-03-05 15:07 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
zipped document #1 (47.33 KB, application/zip)
2014-07-03 16:49 UTC, Bob Bib
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bob Bib 2014-07-03 16:49:46 UTC
Created attachment 102204 [details]
zipped document #1

Software environment: libreoffice/1:4.2.5-1 @ Debian/amd64

---

After extracting the document from the attached ZIP archive:
a) if you just try to open it in LO Calc, it just opens a "Text Import" dialog, which is not helpful;
b) if you try to open it via the file open dialog, explicitly selecting the "Microsoft Excel 2003 XML" file type, it tries to open the document, but fails with "General Error. General input/output error."

However, there are some helpful things in the console output (see below), so after making the followings steps it finally opens up the document:
1) remove the newline at the beginning of the file;
2) replace the " "'s with ordinary spaces;
3) replace single ampersands with "&"'s.

---

Entity: line 2: parser error : XML declaration allowed only at the start of the document
<?xml version="1.0"?>
     ^
Entity: line 139: parser error : Entity 'nbsp' not defined
        <Cell ss:StyleID="sC1"><Data ss:Type="String">&nbsp;01813</Data></Cell>
                                                            ^
...
  
Entity: line 6036: parser error : xmlParseEntityRef: no name
ss:StyleID="sP2"><Data ss:Type="String">Пульт Philips RC242252901652 (HDD &
                                                                               ^
...

---
Comment 1 Algot Runeman 2014-07-27 19:05:32 UTC
Test System:
Kubuntu 4.13.2
LibreOffice 4.2.0.2

Was able to confirm that the attached (unzipped) file will not open into LibreOffice cal.

I get text file import with a file-click open or from within calc.
Comment 2 ign_christian 2014-07-28 06:52:54 UTC
Odd problem..

@Maxim, would you mind have a quick look here?
Comment 3 Maxim Monastirsky 2014-07-28 08:02:07 UTC
The console output says it all. The attached file has invalid XML syntax. All the issues described here are already covered by Bug 38361 & Bug 68742, so I see no point in keeping this bug open.
Comment 4 ign_christian 2014-07-28 09:44:30 UTC
Thanks Maxim. Marking this as dup to Bug 68742

*** This bug has been marked as a duplicate of bug 68742 ***