Download it now!
Bug 80862 - FILEOPEN: Opening a file (every kind of file .odt .doc .xls .ppt ....), changes its modification date on MacOS
Summary: FILEOPEN: Opening a file (every kind of file .odt .doc .xls .ppt ....), chang...
Status: RESOLVED DUPLICATE of bug 75467
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: Other Mac OS X (All)
: high critical
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-03 17:22 UTC by Adriano Belletti
Modified: 2014-07-04 06:36 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Adriano Belletti 2014-07-03 17:22:36 UTC
MacBook Pro Intel i7
MacOS X 10.6.8
LibreOffice 4.2.5.2

Problem description: 

Steps to reproduce:
1. just open a file, every kind of file (.odt .doc .xls .ppt ...). Don't edit it.
2. look in the finder for file info, and you'll see modification time has been updated to now, even if you didn't edit the file.

Current behavior:
opening a file, without editing it, change its modification time attribute

Expected behavior:
opening a file, without editing it, doesn't have to change modification time
              
Operating System: Mac OS X
Version: 4.2.5.2 release
Comment 1 Adriano Belletti 2014-07-03 18:06:10 UTC
Opening the same file with OpenOffice doesn't change the modification time.

LibreOffice changes the mtime BEFORE to open the file:
- open a file with OpenOffice, and keep it opened
- look in the finder: the file has still the original mtime
- open the same file with LibreOffice... and when the 'Document in use' alert pops up, the mtime of the file (still opened in OO) has already been changed, updated to now.
- so, even if I choose to cancel the fileopen process, the mtime of the file is changed
Comment 2 Jorendc 2014-07-03 20:27:34 UTC
Looks like a dupe of bug 75467.

Kind regards,
Joren

*** This bug has been marked as a duplicate of bug 75467 ***
Comment 3 Adriano Belletti 2014-07-04 06:36:33 UTC
Yes, it is.

It seems MacOS 10.6.8 the bug appears only with MacOS 10.6.8 (and maybe older)