Bug 80956 - CONFIGURATION: Bogus missing bracket
Summary: CONFIGURATION: Bogus missing bracket
Status: RESOLVED DUPLICATE of bug 81711
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-05 19:36 UTC by Jonathan Camilleri
Modified: 2014-07-27 18:50 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
PPC (15.02 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2014-07-05 19:36 UTC, Jonathan Camilleri
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan Camilleri 2014-07-05 19:36:32 UTC
Created attachment 102307 [details]
PPC

Problem description: 
The formula in cell C27:C66 appears to have been highlighted to have a missing bracket, however, MS Excel does not highlight this problem and a visual inspection does not seem to indicate that there is a missing bracket.

Current behavior:
Is it possible that square brackets [] are not parsed by LibreOffice?


              
Operating System: Windows (other)
Version: 4.2.5.2 release
Comment 1 Urmas 2014-07-06 02:04:07 UTC
Does LO support structured references at all?
Comment 2 Algot Runeman 2014-07-27 18:41:48 UTC
Test System:
Kubuntu 4.13.2
LibreOffice 4.2.0.2

During the opening of the file, a popup says, "This file contains links to other files. Should they be updated?"

Does that have any bearing on the error?

My system DOES report the error code "Err 508" for all the listed cells. looking at each cell does not show a missing bracket.

=A*(L-(Table1[[#this row],[x]]/B)^(1/Ex)^Ey)

When opening the file in LibreOffice 4.3.0.3 the formula reports differently.
=A*(L-(Table1[#this row,x]/B)^(1/Ex)^Ey)
(Note the different number of brackets).
Comment 3 Joel Madero 2014-07-27 18:47:13 UTC
LibreOffice does not support structured references:

http://ask.libreoffice.org/en/question/11977/using-excel-structured-references-syntax-in-calc/
Comment 4 Joel Madero 2014-07-27 18:47:28 UTC
Marking as:
Enhancement
Comment 5 Joel Madero 2014-07-27 18:50:27 UTC
Actually this is a duplicate of another enhancement request created by one of our developers. Marking as such.

*** This bug has been marked as a duplicate of bug 81711 ***