Download it now!
Bug 81004 - EDITING: Insert special character --> Select --> dialog Format > Character leads to crash
Summary: EDITING: Insert special character --> Select --> dialog Format > Character le...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.3.0.0.alpha1
Hardware: Other All
: highest critical
Assignee: David Tardon
URL:
Whiteboard: target:4.4.0 target:4.3.0
Keywords: regression
Depends on:
Blocks:
 
Reported: 2014-07-07 13:03 UTC by Cor Nouws
Modified: 2014-07-15 11:07 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
test file with special character (12.07 KB, application/vnd.oasis.opendocument.graphics)
2014-07-07 13:06 UTC, Cor Nouws
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Cor Nouws 2014-07-07 13:03:39 UTC
Draw

F2, hit document, type some text
Insert special character
Select that one
Open dialog Format > Character

  > Opens empty and in a few seconds:  crash
Comment 1 Cor Nouws 2014-07-07 13:06:49 UTC
Created attachment 102374 [details]
test file with special character
Comment 2 Cor Nouws 2014-07-07 13:09:16 UTC
already problem in Alpha 1
Comment 3 Kevin Suo 2014-07-09 08:45:54 UTC
Confirm with 4.3.0.2, Win XP SP3.
Comment 4 Commit Notification 2014-07-09 12:45:42 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8817e5e3a0d92a4febae955ced7a35c52cb08910

fdo#81004 this looks like a mis-merge to me



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2014-07-13 09:20:02 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=90939f2b5dfc8a7aafc255322f0fcb66f670241e&h=libreoffice-4-3

fdo#81004 this looks like a mis-merge to me


It will be available in LibreOffice 4.3.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2014-07-15 11:07:37 UTC
David Tardon committed a patch related to this issue.
It has been pushed to "libreoffice-4-3-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f52577053763b287d21da0067970c5727ff087cc&h=libreoffice-4-3-0

fdo#81004 this looks like a mis-merge to me


It will be available already in LibreOffice 4.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.