Bug 81008 - DOCX export: first and subsequent header problems
Summary: DOCX export: first and subsequent header problems
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.6.2 release
Hardware: x86 (IA32) All
: highest critical
Assignee: Not Assigned
URL:
Whiteboard: BSA interoperability ooxml
Keywords: bibisected, regression
Depends on:
Blocks: mab4.2
  Show dependency treegraph
 
Reported: 2014-07-07 16:05 UTC by florinequals
Modified: 2020-09-04 12:29 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
text with first-page header 'Sermon St Gregory's Offchurch' that won't let itself be altered. (13.03 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-07-07 16:05 UTC, florinequals
Details

Note You need to log in before you can comment on or make changes to this bug.
Description florinequals 2014-07-07 16:05:29 UTC
Created attachment 102380 [details]
text with first-page header 'Sermon St Gregory's Offchurch' that won't let itself be altered.

Problem description:   I previously reported first/subsequent header problems (in May) with the previous release of LO: first header appearing on second page as well with associated forced new page and reformatting of the paragraph going over the page change.

This seems to have been fixed, but now the first header in my template won't let itself be overwritten.  I have changed the header and saved, closed the doc and found the original version when I reopened.  I have done this twice.

Steps to reproduce:
1. ....  Open document attached
2. ....  Change text in first page header
3. ....  Save and close

Current behavior:  On reopening, the original text of header reappears

Expected behavior:  the altered text should appear

              
Operating System: Mac OS X
Version: 4.1.6.2 release
Comment 1 Yousuf Philips (jay) (retired) 2014-07-11 02:34:06 UTC
Dear florinequals,

I can confirm that it doesnt work in 4.2.5 and 4.3.1 but does in 4.1.6 on Linux Mint. What is weird is that the thumbnail that appears in the start center in 4.3, show it with the altered text.
Comment 2 Joel Madero 2014-07-12 05:31:23 UTC
Setting Priority:

Critical - substantial data loss on a very simple test case
Highest - MAB 4.2 (regression + serious data loss)


f2554751603ad8537257b3cf52d6171056c76eeb is the first bad commit
commit f2554751603ad8537257b3cf52d6171056c76eeb
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Fri Oct 18 05:12:11 2013 +0000

    source-hash-f42768fe0b60ecbbe9c68d775329bf28c0690131
    
    commit f42768fe0b60ecbbe9c68d775329bf28c0690131
    Author:     Caolán McNamara <caolanm@redhat.com>
    AuthorDate: Mon Sep 2 11:00:05 2013 +0100
    Commit:     Caolán McNamara <caolanm@redhat.com>
    CommitDate: Mon Sep 2 12:22:34 2013 +0100
    
        Resolves: fdo#68794 blank placeholders when there is no known language yet
    
        Change-Id: I7f43144bd61ddc575d8b7094567433fdfd5ee291

:100644 100644 201a17de07e17bd7debfdfe6ca43381e0cbfb343 12e94aaaed81846299f7c651da9b7cdfdaea5416 M	ccache.log
:100644 100644 6cc4c780f897b089bb359873db4fccd70b0c81e5 3ea3177036d3389e1c40e9c6c93c81c233297cd7 M	commitmsg
:100644 100644 2153cb6a9483927f005548244e5b98d99dca72c1 0078d4a35a067ec61accb624b78ced5467d42364 M	dev-install.log
:100644 100644 5544a3ca7ed6b28cc305c7b50b859e415b2e25d0 43dbebe038278acde4ca66aa7e8abcced5bdd20c M	make.log
:040000 040000 c053397df7eeda869c774fb1a0ef0d24e38b7e90 e21ced5098ed0fafcf81768c9d8e8f8e4e34888f M	opt

# bad: [423a84c4f7068853974887d98442bc2a2d0cc91b] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect start 'latest' 'oldest'
# good: [e02439a3d6297a1f5334fa558ddec5ef4212c574] source-hash-6b8393474974d2af7a2cb3c47b3d5c081b550bdb
git bisect good e02439a3d6297a1f5334fa558ddec5ef4212c574
# bad: [4850941efe43ae800be5c76e1102ab80ac2c085d] source-hash-980a6e552502f02f12c15bfb1c9f8e6269499f4b
git bisect bad 4850941efe43ae800be5c76e1102ab80ac2c085d
# skip: [a043626b542eb8314218d7439534dce2fc325304] source-hash-9379a922c07df3cdb7d567cc88dfaaa39ead3681
git bisect skip a043626b542eb8314218d7439534dce2fc325304
# skip: [aba65c3e4c0df07e4909aeefb758cdb688242bf6] source-hash-827524abfb4b577d08276fde40929a9adfb7ff1a
git bisect skip aba65c3e4c0df07e4909aeefb758cdb688242bf6
# bad: [c81a8a0dcfc1ed095a80e4485c89dd0fcaf73f31] source-hash-c69ed33628ec0b7abf6296539cf280d6c4265930
git bisect bad c81a8a0dcfc1ed095a80e4485c89dd0fcaf73f31
# bad: [1d4980621741d3050a5fe61b247c157d769988f2] source-hash-89d01a7d8028ddb765e02c116d202a2435894217
git bisect bad 1d4980621741d3050a5fe61b247c157d769988f2
# good: [ba096f438393091574da98fe7b8e6b05182a8971] source-hash-8499e78ca03c792f4fa2650e02b519094ba0baa8
git bisect good ba096f438393091574da98fe7b8e6b05182a8971
# good: [e75547cbd2d9d480ba13e119a8df8098c9d3a0a3] source-hash-69f686774cfeb803fdd63ed1ef07ff70550930de
git bisect good e75547cbd2d9d480ba13e119a8df8098c9d3a0a3
# good: [bac2489ff3b644bd046102e379bff5a6c6c469d9] source-hash-621c1e491e56db5416da1c763aaff862e8ede67a
git bisect good bac2489ff3b644bd046102e379bff5a6c6c469d9
# good: [0b24b35122b1aec8721035679954b10f82a23540] source-hash-cdab3d619ca0389d4c14e3b50fb66bbadcf5c52f
git bisect good 0b24b35122b1aec8721035679954b10f82a23540
# good: [21be8eddb95a12408b74f43d3effb9dc9821e99e] source-hash-bcc51fb2ebdf77a1cc089857775fd742085b45b6
git bisect good 21be8eddb95a12408b74f43d3effb9dc9821e99e
# good: [e33eaf662f84503c8de782d6677d9eb1b0b0d96b] source-hash-6c3d74e8b779b1eb2d9779ed84f1518e078113c4
git bisect good e33eaf662f84503c8de782d6677d9eb1b0b0d96b
# bad: [f2554751603ad8537257b3cf52d6171056c76eeb] source-hash-f42768fe0b60ecbbe9c68d775329bf28c0690131
git bisect bad f2554751603ad8537257b3cf52d6171056c76eeb
# first bad commit: [f2554751603ad8537257b3cf52d6171056c76eeb] source-hash-f42768fe0b60ecbbe9c68d775329bf28c0690131
Comment 3 florinequals 2014-07-12 14:00:47 UTC
Thank you!!


On 12 Jul 2014, at 06:31, bugzilla-daemon@freedesktop.org wrote:

> Joel Madero changed bug 81008 
> What	Removed	Added
> Hardware	Other	x86 (IA32)
> OS	Mac OS X (All)	All
> Whiteboard	BSA BibisectRequest interoperability ooxml            	BSA bibisected interoperability ooxml            
> Severity	normal	critical
> Priority	medium	highest
> CC	  	jmadero.dev@gmail.com
> Blocks	  	65675
> 
> Comment # 2 on bug 81008 from Joel Madero
> Setting Priority:
> 
> Critical - substantial data loss on a very simple test case
> Highest - MAB 4.2 (regression + serious data loss)
> 
> 
> f2554751603ad8537257b3cf52d6171056c76eeb is the first bad commit
> commit f2554751603ad8537257b3cf52d6171056c76eeb
> Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
> Date:   Fri Oct 18 05:12:11 2013 +0000
> 
>     source-hash-f42768fe0b60ecbbe9c68d775329bf28c0690131
> 
>     commit f42768fe0b60ecbbe9c68d775329bf28c0690131
>     Author:     Caolán McNamara <caolanm@redhat.com>
>     AuthorDate: Mon Sep 2 11:00:05 2013 +0100
>     Commit:     Caolán McNamara <caolanm@redhat.com>
>     CommitDate: Mon Sep 2 12:22:34 2013 +0100
> 
>         Resolves: fdo#68794 blank placeholders when there is no known language
> yet
> 
>         Change-Id: I7f43144bd61ddc575d8b7094567433fdfd5ee291
> 
> :100644 100644 201a17de07e17bd7debfdfe6ca43381e0cbfb343
> 12e94aaaed81846299f7c651da9b7cdfdaea5416 M    ccache.log
> :100644 100644 6cc4c780f897b089bb359873db4fccd70b0c81e5
> 3ea3177036d3389e1c40e9c6c93c81c233297cd7 M    commitmsg
> :100644 100644 2153cb6a9483927f005548244e5b98d99dca72c1
> 0078d4a35a067ec61accb624b78ced5467d42364 M    dev-install.log
> :100644 100644 5544a3ca7ed6b28cc305c7b50b859e415b2e25d0
> 43dbebe038278acde4ca66aa7e8abcced5bdd20c M    make.log
> :040000 040000 c053397df7eeda869c774fb1a0ef0d24e38b7e90
> e21ced5098ed0fafcf81768c9d8e8f8e4e34888f M    opt
> 
> # bad: [423a84c4f7068853974887d98442bc2a2d0cc91b]
> source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
> # good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00]
> source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
> git bisect start 'latest' 'oldest'
> # good: [e02439a3d6297a1f5334fa558ddec5ef4212c574]
> source-hash-6b8393474974d2af7a2cb3c47b3d5c081b550bdb
> git bisect good e02439a3d6297a1f5334fa558ddec5ef4212c574
> # bad: [4850941efe43ae800be5c76e1102ab80ac2c085d]
> source-hash-980a6e552502f02f12c15bfb1c9f8e6269499f4b
> git bisect bad 4850941efe43ae800be5c76e1102ab80ac2c085d
> # skip: [a043626b542eb8314218d7439534dce2fc325304]
> source-hash-9379a922c07df3cdb7d567cc88dfaaa39ead3681
> git bisect skip a043626b542eb8314218d7439534dce2fc325304
> # skip: [aba65c3e4c0df07e4909aeefb758cdb688242bf6]
> source-hash-827524abfb4b577d08276fde40929a9adfb7ff1a
> git bisect skip aba65c3e4c0df07e4909aeefb758cdb688242bf6
> # bad: [c81a8a0dcfc1ed095a80e4485c89dd0fcaf73f31]
> source-hash-c69ed33628ec0b7abf6296539cf280d6c4265930
> git bisect bad c81a8a0dcfc1ed095a80e4485c89dd0fcaf73f31
> # bad: [1d4980621741d3050a5fe61b247c157d769988f2]
> source-hash-89d01a7d8028ddb765e02c116d202a2435894217
> git bisect bad 1d4980621741d3050a5fe61b247c157d769988f2
> # good: [ba096f438393091574da98fe7b8e6b05182a8971]
> source-hash-8499e78ca03c792f4fa2650e02b519094ba0baa8
> git bisect good ba096f438393091574da98fe7b8e6b05182a8971
> # good: [e75547cbd2d9d480ba13e119a8df8098c9d3a0a3]
> source-hash-69f686774cfeb803fdd63ed1ef07ff70550930de
> git bisect good e75547cbd2d9d480ba13e119a8df8098c9d3a0a3
> # good: [bac2489ff3b644bd046102e379bff5a6c6c469d9]
> source-hash-621c1e491e56db5416da1c763aaff862e8ede67a
> git bisect good bac2489ff3b644bd046102e379bff5a6c6c469d9
> # good: [0b24b35122b1aec8721035679954b10f82a23540]
> source-hash-cdab3d619ca0389d4c14e3b50fb66bbadcf5c52f
> git bisect good 0b24b35122b1aec8721035679954b10f82a23540
> # good: [21be8eddb95a12408b74f43d3effb9dc9821e99e]
> source-hash-bcc51fb2ebdf77a1cc089857775fd742085b45b6
> git bisect good 21be8eddb95a12408b74f43d3effb9dc9821e99e
> # good: [e33eaf662f84503c8de782d6677d9eb1b0b0d96b]
> source-hash-6c3d74e8b779b1eb2d9779ed84f1518e078113c4
> git bisect good e33eaf662f84503c8de782d6677d9eb1b0b0d96b
> # bad: [f2554751603ad8537257b3cf52d6171056c76eeb]
> source-hash-f42768fe0b60ecbbe9c68d775329bf28c0690131
> git bisect bad f2554751603ad8537257b3cf52d6171056c76eeb
> # first bad commit: [f2554751603ad8537257b3cf52d6171056c76eeb]
> source-hash-f42768fe0b60ecbbe9c68d775329bf28c0690131
> 
> You are receiving this mail because:
> You reported the bug.
Comment 4 Luke Deller 2014-09-04 14:09:13 UTC
It looks like this is fixed by b4ccde72b8e2e45e7276d5b08b182495a1b1a617 (master) / bcbeac44ca54f41fb80a027214b9eb2ec1eb14dd (libreoffice-4-3)

Using the steps to reproduce, I tested that the bug is reproducible in bcbeac44ca54f41fb80a027214b9eb2ec1eb14dd^ (commit before) and not in bcbeac44ca54f41fb80a027214b9eb2ec1eb14dd.

This fix will be available in LibreOffice 4.3.2
Comment 5 Björn Michaelsen 2014-10-11 13:54:53 UTC
(In reply to Luke Deller from comment #4)
> It looks like this is fixed by b4ccde72b8e2e45e7276d5b08b182495a1b1a617
> (master) / bcbeac44ca54f41fb80a027214b9eb2ec1eb14dd (libreoffice-4-3)
> 
> Using the steps to reproduce, I tested that the bug is reproducible in
> bcbeac44ca54f41fb80a027214b9eb2ec1eb14dd^ (commit before) and not in
> bcbeac44ca54f41fb80a027214b9eb2ec1eb14dd.
> 
> This fix will be available in LibreOffice 4.3.2
Thus closing as FIXED.
Comment 6 Robinson Tryon (qubit) 2015-12-17 08:25:42 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]