Download it now!
Bug 81026 - Exporting .odf file to pdf caused figures to disappear from the .odf file, figures were not exported correctly to pdf file either. (Serious bugs!)
Summary: Exporting .odf file to pdf caused figures to disappear from the .odf file, fi...
Status: RESOLVED DUPLICATE of bug 46447
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.2.4.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-08 03:22 UTC by Henry
Modified: 2014-07-21 12:32 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
FIle that was corrupted after trying to export to PDF (394.52 KB, application/pdf)
2014-07-08 03:31 UTC, Henry
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Henry 2014-07-08 03:22:41 UTC

    
Comment 1 Henry 2014-07-08 03:31:22 UTC
Created attachment 102404 [details]
FIle that was corrupted after trying to export to PDF

Using LibreOffice 4.2.4.2, exported a .odp file to a PDF file and two bad things happened: the images in the .odp file were not transferred except the very first AND all figures except the first are now missing in the .odf file.
Comment 2 sophie 2014-07-09 13:38:06 UTC
Hi, can you provide your original odp file? what is the format of the image? Thanks - set as Needinfo until we get the file. Sophie
Comment 3 Henry 2014-07-09 14:31:41 UTC
bugzilla-daemon@freedesktop.org writes:

> [1]sophie changed [2]bug 81026
>
> +---------------------------------------------------------+
> |      What      |   Removed   |          Added           |
> |----------------+-------------+--------------------------|
> | Status         | UNCONFIRMED | NEEDINFO                 |
> |----------------+-------------+--------------------------|
> | CC             | �           | gautier.sophie@gmail.com |
> |----------------+-------------+--------------------------|
> | Ever confirmed | �           | 1                        |
> +---------------------------------------------------------+
>
> [3]Comment # 2 on [4]bug 81026 from [5]sophie
>
>  Hi, can you provide your original odp file? what is the format of the image?
>  Thanks - set as Needinfo until we get the file. Sophie

I am using LibreOffice 4.2.5.2 (latest version) with Ubuntu 14.04.

I put an example of a corrupted .odp file at this URL

    http://www.phy.duke.edu/~hsg/bad-impress-file.odp

look at slides 15 and 16. You can compare this with a PDF export of
the .odp file that I made

    http://www.phy.duke.edu/~hsg/bad-impress-file.pdf

before the file became corrupted.

Most of the images that disappear are in .png format, e.g., I used the
Ubuntu screen capture utility Screenshot to grab part of some image on
the screen (typically from some web page), then copy and paste the
image directly into LibreOffice Impress without saving it into a file.

I believe there have been some cases though where the missing image
came from importing the image from an external file, rather than
copying and pasting. But most of the problems seem to be with images
that were pasted directly into Impress.

As others have pointed out, this bug is extremely alarming and
frustrating since it means that I can't tell in advance whether one of
of my presentation files will display correctly, and it can take a lot
of time to recover the images and repair the problem. The bug is also
happening frequently, just about every Impress (.odp) file I have
created during the last few weeks has lost some images upon opening a
saved .odp file.

LibreOffice should make this a very high priority to fix since Impress
is currently too unreliable to use, and this means that my Linux based
computers are not usable for preparing talks until this is fixed.

   Thanks,

   Henry
Comment 4 sophie 2014-07-09 14:47:27 UTC
Hi, the odp file you provided have missing images for slide 15 and 16. I can't reproduce the problem with pdf export, all the images contained in the odp are well exported to pdf. Left as unconfirmed as I can't reproduce even with my own file - Sophie
Comment 5 Henry 2014-07-09 15:01:20 UTC
bugzilla-daemon@freedesktop.org writes:

> [1]sophie changed [2]bug 81026
>
> +-----------------------------------------+
> |      What      | Removed  |    Added    |
> |----------------+----------+-------------|
> | Status         | NEEDINFO | UNCONFIRMED |
> |----------------+----------+-------------|
> | Ever confirmed | 1        |             |
> +-----------------------------------------+
>
> [3]Comment # 4 on [4]bug 81026 from [5]sophie
>
>  Hi, the odp file you provided have missing images for slide 15 and 16. I can't
>  reproduce the problem with pdf export, all the images contained in the odp are
>  well exported to pdf. Left as unconfirmed as I can't reproduce even with my own
>  file - Sophie

Sophie,

What you are asking for seems impossible to satisfy: I don't know if
the bug has occurred until I open up a saved .odp file and find the
images missing. At that point, there is no original file to give you,
the file has been irreversibly damaged.

Somehow saving the .odp file is what is causing the corruption since
the file is ok while I am actively using Impress. So how am I supposed
to give you an original file and its corrupted version since I can't save
the file without corrupting it?

Can you try creating a .odp Impress file, pasting in an image created
with Screenshot (or someother screen capture utility), saving the
file, and then seeing if the saved file is corrupted (image not
accessible)?

Since this bug happens frequently for me and for others, it needs to
be addressed by LibreOffice, it is a very serious bug. 

If you can't reproduce the bug, then, based on my own experience in
writing a lot of code, someone will need to rewrite the part of the
Impress code that handles inserting images until the code is more
clear and more concise. At some point, the bug will be accidently
eliminated (by writing better and different code) or because it
the code is so clear that it becomes obvious why there is a bug.

    Thanks,

    Henry
Comment 6 Henry 2014-07-09 15:13:44 UTC
One other thought:

I have thought of saving some of the .odp files in .pptx format as a
backup but found this was not practical because the conversion of .odp
to .pptx also has some significant bugs in which certain images (e.g.,
created by the TexMaths equation program) and certain text (display of
bullets) are not exported correctly to the .pptx file.

See slide 10 of these two files:

    http://www.phy.duke.edu/~hsg/good-file.odp

    http://www.phy.duke.edu/~hsg/good-file.pptx

as an example where the conversion from .odp to .pptx is not done
correctly.

Perhaps this is a bug related to missing images since the TexMaths
program creates a standard image (GIF?) that should be handled
straightforwardly when exporting.

    Thanks,

    Henry
Comment 7 ign_christian 2014-07-18 15:52:23 UTC
Hi Henry.. Looks like you're reporting a duplicate to some bugs:

- About ODP filesave with save as link: Bug 80849 & Bug 81423
- About ODP filesave with embedded images: Bug 46447

Please be noted only 1 bug per bug report. PPTX filesave is different problem that should be reported in another bugs and you could search that.

@Sophie, I tend to mark this as dupe to Bug 46447
Comment 8 sophie 2014-07-21 12:32:50 UTC
yes, it's a dup of #46447. Sophie

*** This bug has been marked as a duplicate of bug 46447 ***