Bug 81078 - (VIEWING, EDITING) Missing picture observed in pptx presentation
Summary: (VIEWING, EDITING) Missing picture observed in pptx presentation
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-09 05:57 UTC by Matt Hirsch
Modified: 2014-08-11 23:38 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matt Hirsch 2014-07-09 05:57:29 UTC
In the pptx presentation available here:

http://www.slideshare.net/mhirsch45/a-switchable-light-field-camera-architecture-with-angle-sensitive-pixels-and-dictionarybased-sparse-coding

the image of the sensor on the right side of slide 5 shows up as an empty box called "Picture 16".

I suspect this is different than the problem observed in this bug: https://bugs.freedesktop.org/show_bug.cgi?id=46447

In the "classic" libreoffice missing picture bug the picture goes missing after a save operation, and it is found that the picture is no longer contained in the presentation archive or xml. However, in this case the image is in the presentation (it is rendered properly on slideshare and in powerpoint 2010) but it does not show up in libreoffice. Perhaps the cause is related, but this seems more deterministic and perhaps easier to debug.
Comment 1 Jean-Baptiste Faure 2014-07-23 18:12:07 UTC
Your hyperlink does not link to any file, only a website. Please give the correct link.

Set status to NEEDINFO. Please set it back to UNCONFIRMED once you have provided requested informations.

Best regards. JBF
Comment 2 Matt Hirsch 2014-07-23 18:38:18 UTC
I've rehosted the file here:  http://web.media.mit.edu/~mhirsch/ICCP14_upload.pptx

You can also click the "save" link at the top of the first website in order to save the file.
Comment 3 Robinson Tryon (qubit) 2014-07-27 00:58:37 UTC
TESTING on Ubuntu 12.04.4 + LO 4.3.0.3

(In reply to comment #2)
> I've rehosted the file here: 
> http://web.media.mit.edu/~mhirsch/ICCP14_upload.pptx

Is it possible to reproduce the bug with a presentation smaller than 45MB? I'd try deleting all slides after #5 and see if the problem remains.

(In reply to comment #0)
> the image of the sensor on the right side of slide 5 shows up as an empty
> box called "Picture 16".

CONFIRMED. I see an empty element for Picture 16, and a white question mark inside a grey circle (is the latter image part of the original file?)

> In the "classic" libreoffice missing picture bug the picture goes missing
> after a save operation, and it is found that the picture is no longer
> contained in the presentation archive or xml. However, in this case the
> image is in the presentation (it is rendered properly on slideshare and in
> powerpoint 2010) but it does not show up in libreoffice. Perhaps the cause
> is related, but this seems more deterministic and perhaps easier to debug.

This sounds similar to bug 81517, but that's a binary xls and this an ooxml pptx.

Narrowing-down the test case to a minimal reproducible file would greatly accelerate our ability to track down this bug.
Comment 4 Matt Hirsch 2014-07-27 01:38:05 UTC
I won't have access to powerpoint for another week or so, but I will try to reduce the size of the slide set next time it becomes available.
Comment 5 Terrence Enger 2014-08-11 20:32:35 UTC
FWIW, I see the broken image in various LibreOffice versions back to
bibisect-43all oldest.


My attention goes to ppt/media/image21.png embeddedin the .pptx:

"The GNOME imager viewer" 3.4.2, as delivered with debian-wheezy
64-bit complains:

    Could not load image "image21.png".
    Fatal error reading PNG imagefile IDAT: CRC error

while Beyond Compare version 3.3.10 (a proprietary file comparison
utiltity from Scooter Software) complains:

    ppt/media/image21.png   bad CRC 1967134b  (should be c6c34b02)


So, Matt,

What program created ICCP14_upload.pptx?  If other than LibreOffice, I
lean toward resolving this report NOTOURBUG.

If you used LibreOffice to create the .pptx, I would ask you to do
some things.
    
(*) Did something bad happen between your upload and my download?  My
    ICCP14_upload.pptx has an md5sum ad27101012364074ca777d7acb350f72.
    Is your file the same?

(*) Can you view the image in a file viewer?

(*) What is the md5sum of the image file you started with?  The
    image21.png that I extracted has md5sum
    58c507f7bc27e4ab9ca5d0d0b8f87d38.  If they are the same, then
    LibreOffice is again off the hook, I think.  If they are
    different, and if you used LibreOffice to create the .pptx, we
    need instructions on how to create a .pptx with the error: each
    keystroke and each mouseclick would be good.
Comment 6 Matt Hirsch 2014-08-11 21:45:37 UTC
It was created in powerpoint. I'm not sure how the image would have been corrupted, but I can see how that would lead to unpredictable behavior. I guess you can close the bug.
Comment 7 Terrence Enger 2014-08-11 23:38:16 UTC
Thank you, Matt, for you prompt response.  I am setting bug status
RESOLVED NOTOURBUG.

One has to wonder what kind of corruption lets slideshare and
powerpoint show the image, but I am not even close to being able to
look into that.