Bug 81093 - Unable use Base with JRE 7 (OS X 10.9.4)
Summary: Unable use Base with JRE 7 (OS X 10.9.4)
Status: RESOLVED DUPLICATE of bug 74877
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
4.3.0.2 rc
Hardware: x86-64 (AMD64) Mac OS X (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-09 08:27 UTC by Frantisek Erben
Modified: 2014-10-16 06:29 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
JRE JDK installed version (107.08 KB, image/png)
2014-07-09 08:28 UTC, Frantisek Erben
Details
Crash log (21.87 KB, application/zip)
2014-07-09 08:29 UTC, Frantisek Erben
Details
Crash while opening ODB file (90.50 KB, application/zip)
2014-07-09 08:42 UTC, Frantisek Erben
Details
Several crashlogs from open Bug-Crash.odb file (1.67 KB, application/zip)
2014-07-09 08:43 UTC, Frantisek Erben
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Frantisek Erben 2014-07-09 08:27:34 UTC
How to reproduce
Install JRE and JDK 7u60 (64bit) on clean OS X 10.9.4. (no Apple Java 1.6)
See included screenshot JREversion.png)
Launch LO (64bit) and set correct JRE in LO preferences.
Relaunch LO.
Create new Base Database, in Database wizard window click on Finish, fill any name in Save dialog and click on Save.

Current state:
LO quit immediately and OS X system dialog about install Java SE 6 appear.
Console.app output:
"09/07/14 10:16:02,706 com.apple.launchd.peruser.501[279]: (org.libreoffice.script.236048[2192]) Exited with code: 97"

Wanted state:
Normal continue.

Additional info:
While testing/reproducing this bug LO once crash, I don't know if it was caused by this bug, it might be consequence of something else, but this crash log included too.
Comment 1 Frantisek Erben 2014-07-09 08:28:08 UTC
Created attachment 102465 [details]
JRE JDK installed version
Comment 2 Frantisek Erben 2014-07-09 08:29:13 UTC
Created attachment 102466 [details]
Crash log
Comment 3 Frantisek Erben 2014-07-09 08:41:51 UTC
Additional info:
LO crash also if I try open included file (it was created while previous step create database file - described in bug "Description").
LO crashes immediatelly in different states of stack – several logs included (Crash when open ODB file.zip).
Comment 4 Frantisek Erben 2014-07-09 08:42:47 UTC
Created attachment 102468 [details]
Crash while opening ODB file
Comment 5 Frantisek Erben 2014-07-09 08:43:40 UTC
Created attachment 102469 [details]
Several crashlogs from open Bug-Crash.odb file
Comment 6 Julien Nabet 2014-07-20 10:40:19 UTC
Do you save the file on local hard disk or on a share network?
Did you install any LO specific extensions?
Also, it you've got 2 times the same jre, if you confirm this, could you uninstall completely Java and install again last Java version (64 bits)?

For the test, could you rename your LO directory profile and give it a new try? (see https://wiki.documentfoundation.org/UserProfile#Mac_OS_X)
Comment 7 Frantisek Erben 2014-07-22 06:08:54 UTC
(In reply to comment #6)
> Do you save the file on local hard disk or on a share network?
Local disk. IMHO it is not save-related problem.

> Did you install any LO specific extensions?
No – clean installation. IMHO it is not extensions-related problem.

> Also, it you've got 2 times the same jre, if you confirm this, could you
> uninstall completely Java and install again last Java version (64 bits)?
It is not the same – both is 64bit Java but:
1st is at /Library/Internet Plug-in/JavaAppletPlugin.plugin (JRE)
2nd is at /Library/Java/JavaVirtualMachines/jdk… (JDK)

> For the test, could you rename your LO directory profile and give it a new
> try? (see https://wiki.documentfoundation.org/UserProfile#Mac_OS_X)
I've try it, but it does not help. IMHO it is problem while idetify Java environment and another way of Oracle integration.

Similar problem has for example ImageJ.app – it cannot recognize Oracle Java and for run needs Apple Java – workaround is launch ij.jar directly from Trminal.app java -Xmx2048m -jar \"/Applications/ImageJ/ImageJ64.app/Contents/Resources/Java/ij.jar\" -ijpath /Applications/ImageJ
Comment 8 Julien Nabet 2014-07-22 06:30:23 UTC
Frantisek: thank you for your feedback.

Stephan: thought you might be interested in this one since it might be a Java/LO problem.
Comment 9 Julien Nabet 2014-10-11 18:05:46 UTC
I noticed this part in one of the bt:
8   com.apple.CoreServices.CarbonCore   0x00007fff904c42bc GetPathVolFSAttributes(char const*, unsigned int, FSAttributeInfo*, unsigned int, unsigned char*) + 417
9   com.apple.CoreServices.CarbonCore   0x00007fff904c3a4e PathGetObjectInfo(char const*, unsigned int, unsigned int, short*, unsigned int*, unsigned int*, char*, unsigned int*, unsigned char*, unsigned int*) + 196
10  com.apple.CoreServices.CarbonCore   0x00007fff904c38d0 FSPathMakeRefInternal(unsigned char const*, unsigned int, unsigned int, FSRef*, unsigned char*) + 111
11  com.apple.CoreFoundation            0x00007fff8d7c8d08 _CFGetFSRefFromURL + 232
12  com.apple.CoreFoundation            0x00007fff8d7c8c05 CFURLGetFSRef + 37
13  com.apple.CoreServicesInternal      0x00007fff89591442 _CFURLCreateBookmarkDataFromFile + 81
14  libuno_sal.dylib.3                  0x000000010e97dd87 macxp_resolveAlias + 183

I wonder why carbon (an API for backward compatibility, see http://en.wikipedia.org/wiki/Carbon_%28API%29) appears here.
See also http://opengrok.libreoffice.org/xref/core/sal/osl/unx/system.c#146 for macxp_resolveAlias

Tor: thought you might be interested.

Frantisek: meanwhile, would you have some time to give a try after having upgraded to MacOs 10.9.5?
Comment 10 Tor Lillqvist 2014-10-12 07:18:03 UTC
Since when am I interested in Base?
Comment 11 Julien Nabet 2014-10-12 07:25:07 UTC
Tor: I was thinking about MacOs more than Base.
Comment 12 Frantisek Erben 2014-10-14 10:48:09 UTC
(In reply to Julien Nabet from comment #9)
> Frantisek: meanwhile, would you have some time to give a try after having
> upgraded to MacOs 10.9.5?

Hello, I can confirm the same behavior on OS X 10.9.5 and JRE/JDK 8u20 (I had to update to JRE/JDK 8)
Comment 13 Julien Nabet 2014-10-14 19:11:34 UTC
I must recognize I'm stuck :-(
Hope someone may bring some help here.
Comment 14 frofa 2014-10-16 01:03:32 UTC
Is THIS BUG REPORT relevant?
https://bugs.freedesktop.org/show_bug.cgi?id=74877
Comment 15 Stephan Bergmann 2014-10-16 06:29:56 UTC
(In reply to frofa from comment #14)
> Is THIS BUG REPORT relevant?
> https://bugs.freedesktop.org/show_bug.cgi?id=74877

Sure it is.  Thanks for digging that out (which I at least had already forgotten about again).

*** This bug has been marked as a duplicate of bug 74877 ***