Bug Hunting Session
Bug 81143 - Extension "Copy only visible cells" 1.1: Cells selection box/cursor not show
Summary: Extension "Copy only visible cells" 1.1: Cells selection box/cursor not show
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Extensions (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-10 04:40 UTC by Kevin Suo
Modified: 2015-10-17 12:37 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Suo 2014-07-10 04:40:17 UTC
Steps:

1. Install the extension:
http://extensions.libreoffice.org/extension-center/copy-only-visible-cells

2. New Calc, type "ABC" in A1, and select A1.

3. Edit - Copy only visible cells, then try to select other cells.
> Result: cells selection box/cursor does not show. Whowever, from the column and row labels you can see that the cells are selected.

LibreOffice Verion: 4.3.0.2. 
OS: Win XP SP3.

Someone also reproduce with 4.2.5.2 on Fedora 20 x64, see here: http://libreofficechina.org/thread-141-1-1.html
Comment 1 Kevin Suo 2014-07-10 07:20:30 UTC
This bug only happens if you click the "Edit - Copy only visible cells".

Do not reproduce when using the "Copy only visible cells" toolbar icon or call the macro directly.
Do not reproduce when create a new custom menu and then add "Sub CopyOnlyVisibleCells" as submenu.
Comment 2 Kevin Suo 2014-07-10 10:04:15 UTC
From the unziped Addons.xcu, I see:
<prop oor:name="URL" oor:type="xs:string">					<value>vnd.sun.star.script:SelVisiCell.Module2.CopyOnlyVisibleCells?language=Basic&amp;location=application</value>

Is this a valid UNO "URL"?
Comment 3 yanjingtao 2014-07-14 00:48:35 UTC
Reproduce in 
Fedora 20 X86_64
Version: 4.2.5.2
Build ID: 4.2.5.2-1.fc20
Comment 4 QA Administrators 2015-07-18 17:43:01 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.1 or later): https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-07-18
Comment 5 Buovjaga 2015-10-17 12:37:11 UTC
Not reproduced anymore. WFM.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 186f32f63434e16ff5776251657f902d5808ed3d
TinderBox: Win-x86@39, Branch:master, Time: 2015-10-16_09:42:47
Locale: en-US (fi_FI)