Bug Hunting Session
Bug 81152 - Extension "Copy only visible cells" 1.1: LibreOffice Runtime Error: Object Variable Not Set
Summary: Extension "Copy only visible cells" 1.1: LibreOffice Runtime Error: Object Va...
Status: RESOLVED NOTOURBUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Extensions (show other bugs)
Version:
(earliest affected)
4.3.0.2 rc
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Gustavo Pacheco
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-10 07:41 UTC by Kevin Suo
Modified: 2016-01-26 05:51 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Kevin Suo 2014-07-10 07:41:04 UTC
Steps to reproduce:

1. Install "Copy only visible cells" extension from here:
http://extensions.libreoffice.org/extension-center/copy-only-visible-cells

2. In Calc, type "test" in A1, then select A1.

3. Click the "Copy only visible cells" toolbar icon one time after anoter.

> After a few times of click, it shows "LibreOffice Runtime Error: Object Viable Not Set" error message,
> then Basic macro editor pops up and the following line is highlighted:
> dispatcher.executeDispatch(document, ".uno:Copy", "", 0, Array())

Windows XP SP3, LibreOffice 4.3.0.2.
Comment 1 Buovjaga 2014-11-04 08:38:47 UTC
I copied 20 times, but could not reproduce.

Win 7 64-bit 4.3.3.2
Comment 2 tommy27 2015-01-25 05:57:15 UTC
@Kevin
please retest with updated LibO release.
4.3.0.2 is obsolete. upgrade to 4.3.5.2

I set status to NEEDINFO waiting for deefack after restesting
Comment 3 Kevin Suo 2015-01-28 02:07:10 UTC
(In reply to tommy27 from comment #2)
Still reproducible with version 4.4.0.3
Version: 4.4.0.3
Build ID: de093506bcdc5fafd9023ee680b8c60e3e0645d7
Locale: zh_CN

I click on the "Copy only visible cells" toolbar icon at a speed of 1-click-per-second, and I noticed the following:
* After clicking about 3 times, cell A1 became un-selected. 
* Then when you click for the 4th time, it shows the Runtime Error message.

Set back to UNCONFIRMED.
Comment 4 tommy27 2015-09-19 06:01:09 UTC
any improvement in LibO 5.0.x ?
Comment 5 Kevin Suo 2015-09-20 04:08:33 UTC
(In reply to tommy27 from comment #4)
Still the same in 5.0.1.2

It's not about LO version, only the code of this extension matters. A lot of improvements are needed to the code of this extension.
Comment 6 Hugh 2015-09-26 09:21:49 UTC
Hello, I'm new here and not very computer literate so I hope i can explain. I have Open Office 4.1.1 and I installed copyvisicells-1.1.oxt 
When I highlighted the cells I wanted to copy and then in Edit menu chose "Copy only visible cells" a new Calc window opened but it and the original window were both "not responding" and then closed down. 
Did I do something wrong? Can I try something differently? Is it a bug? 

Any ideas appreciated!

Hugh
Comment 7 Buovjaga 2015-09-26 18:09:25 UTC
(In reply to Hugh from comment #6)
> Hello, I'm new here and not very computer literate so I hope i can explain.
> I have Open Office 4.1.1 and I installed copyvisicells-1.1.oxt 

This bug tracker is for LibreOffice, not Apache OpenOffice.
Please download LibreOffice and give it a try: https://www.libreoffice.org/download/libreoffice-fresh/
Comment 8 Hugh 2015-09-27 17:23:19 UTC
Thank you Beluga. Can I use existing Apache OpenOffice files with LibreOffice? Do all "standard" formulae and commands work the same in both systems?

Hugh
Comment 9 Buovjaga 2015-09-28 05:18:08 UTC
(In reply to Hugh from comment #8)
> Thank you Beluga. Can I use existing Apache OpenOffice files with
> LibreOffice? Do all "standard" formulae and commands work the same in both
> systems?
> 
> Hugh

Yes, because they follow the ODF file format standard, which even Microsoft supports.
Comment 10 Jean-Baptiste Faure 2016-01-26 05:51:22 UTC
(In reply to Kevin Suo from comment #5)
> (In reply to tommy27 from comment #4)
> Still the same in 5.0.1.2
> 
> It's not about LO version, only the code of this extension matters. A lot of
> improvements are needed to the code of this extension.

Ok, so you should ask the author of this extension. 
As stated in https://wiki.documentfoundation.org/QA/BugReport/Extensions bugzilla is not intended to report bug against extensions.

Closing as NotOurBug.
Best regards. JBF