Download it now!
Bug 81181 - Poor gltf default camera position & centering ...
Summary: Poor gltf default camera position & centering ...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: graphics stack (show other bugs)
Version:
(earliest affected)
4.3.0.2 rc
Hardware: Other All
: medium normal
Assignee: Tamás Zolnai
URL:
Whiteboard:
Keywords:
: 82120 (view as bug list)
Depends on:
Blocks: 81107
  Show dependency treegraph
 
Reported: 2014-07-10 16:27 UTC by Michael Meeks
Modified: 2014-09-15 19:56 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
picture of wine in orbit mode (166.07 KB, image/png)
2014-07-10 16:29 UTC, Michael Meeks
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Meeks 2014-07-10 16:27:47 UTC
I know that it is hard to calculate the default camera position (when it is not defined in gltf), but it would be good to find a better way to do that.

For example wine model is very far from the camera in orbit mode (see wine_in_orbit_mode.png) and additionally that camera movement constrain which was added recently does not allow us to move camera closer to the model. It moves a bit closer but after that it stops.

Also - Model center position is not calculated right.
In orbit mode rotation is done around the model center position but it seems it's not calculated in the right way. There are more models where rotation is done around the corner of the model and not around it's center. (see these models: jeep, monster, phoenix, wine)
Comment 1 Michael Meeks 2014-07-10 16:29:09 UTC
Created attachment 102560 [details]
picture of wine in orbit mode
Comment 2 Tamás Zolnai 2014-08-11 13:43:41 UTC
*** Bug 82120 has been marked as a duplicate of this bug. ***
Comment 3 Michael Meeks 2014-09-15 19:56:50 UTC
Seems this is fixed in libgltf and Tamas says:

[snip]
The plan is that these fixes will be part of the next libgltf release (0.0.2) and will be integrated to LibreOffice 4.3.3. I created a page for libglTF where you can see the exact dates:
https://wiki.documentfoundation.org/Development/libgltf
[/snip]