Bug 81222 - FILESAVE: save as xlsx modifies cells number format (French only)
Summary: FILESAVE: save as xlsx modifies cells number format (French only)
Status: RESOLVED DUPLICATE of bug 81939
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: All All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-11 10:27 UTC by bureautiquelibre
Modified: 2016-06-26 11:08 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
example xlsx file (14.05 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2014-07-11 10:27 UTC, bureautiquelibre
Details
result file (after saving in LibreOffice) (9.01 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2014-07-15 08:07 UTC, bureautiquelibre
Details
Test case file with fraction formats and normal escape char (build with Excel 2010) (11.66 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2016-06-26 11:08 UTC, Laurent BP
Details

Note You need to log in before you can comment on or make changes to this bug.
Description bureautiquelibre 2014-07-11 10:27:44 UTC
Created attachment 102612 [details]
example xlsx file

Load the axample file and save as .xlsx

Close and reopen the file in LibreOffice.

Cell format is altered: all figures in the table are displayed as 0's and 1's.
Comment 1 ign_christian 2014-07-11 15:33:43 UTC
Hello.. I just realized no difference in cell number format. Can't confirm with LO 4.2.5.2 and 4.3.0.2 in Ubuntu 12.04 x86.

Have you tried resetting user profile?
Comment 2 bureautiquelibre 2014-07-15 08:07:51 UTC
Created attachment 102841 [details]
result file (after saving in LibreOffice)
Comment 3 bureautiquelibre 2014-07-15 08:08:51 UTC
Hi,

I resetted my user profile and get the same result as described previously.

I just uploaded the file I get after saving as xlsx from LibreOffice so you can try to load it.

Best Regards,
Eric Ficheux
Comment 4 Mathieu Parent 2014-07-15 08:22:23 UTC
Hello,

I can reproduce it on Debian:
Version: 4.2.5.2
Build ID: 420m0(Build:2)

Regards
Comment 5 ign_christian 2014-07-15 08:40:17 UTC
(In reply to comment #0)
> Created attachment 102612 [details]
> example xlsx file

Still don't understand why I can't reproduce with the file. Also with 4.2.6.1, result is the same.
Comment 6 ign_christian 2014-07-15 08:48:06 UTC
Using fresh profile also makes no difference.

I'm using standard English installation package, perhaps it's the cause?
Comment 7 bureautiquelibre 2014-07-15 11:53:34 UTC
Looks like it: I'm using French.

I changed the language to English and tested, it worked fine.
Comment 8 Julien Nabet 2015-10-04 19:55:18 UTC
On pc Debian x86-64 with master sources updated today, I could reproduce this.
Here's the format I notice: _-* # ##0 _€_-;-* # ##0 _€_-;_-* -?? _€_-;_-@_-
Comment 9 Laurent BP 2016-06-18 17:23:12 UTC
When you first open the XLSX file, LibO reads formatted content in the file. But, when you close and reopen, LibO tries to create formatted content, and fails due to conflict between space as character and space as thousand separator.
(In reply to Julien Nabet from comment #8)
> On pc Debian x86-64 with master sources updated today, I could reproduce
> this.
> Here's the format I notice: _-* # ##0 _€_-;-* # ##0 _€_-;_-* -?? _€_-;_-@_-
Lets give some details:
_- leave space for a '-' character
*  (with extra space) complete free space with character spaces
# ##0 display integer part with thousand separator
Up to here, everything is correct. The problem is with the next space, which should be treated as a space character (with quotes) but is seen as a thousand separator in French. As there is no digit after this, LibO display only thousands.
_€ leave space for a '€' character
_- leave space for a '-' character

So LibO should import this format as
_-* # ##0" "_€_-;-* # ##0" "_€_-;_-* -??" "_€_-;_-@_-
Comment 10 Laurent BP 2016-06-18 17:42:07 UTC
As Gnumeric is able to import correctly import attachment 102612 [details] with format
_-* # ##0\ _€_-;-* # ##0\ _€_-;_-* -??\ _€_-;_-@_-
I suggest it is a duplicate of bug 81939
Escape character not imported from XLSX

*** This bug has been marked as a duplicate of bug 81939 ***
Comment 11 Laurent BP 2016-06-26 11:08:11 UTC
Created attachment 125912 [details]
Test case file with fraction formats and normal escape char (build with Excel 2010)

Test file to test the commit