Download it now!
Bug 81224 - Wingdings font special characters not displaying correctly
Summary: Wingdings font special characters not displaying correctly
Status: RESOLVED DUPLICATE of bug 72031
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.6.2 release
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-11 10:49 UTC by fred4u
Modified: 2014-07-12 01:56 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Writer file used to demonstrate garbled Wingdings symbols (8.45 KB, application/vnd.oasis.opendocument.text)
2014-07-11 20:02 UTC, fred4u
Details

Note You need to log in before you can comment on or make changes to this bug.
Description fred4u 2014-07-11 10:49:14 UTC
Writer incorrectly displays some of the Wingdings characters past 0x7F (e.g. numbers in circle characters 0x80..0x95).

Character sequence containing these Wingdings codes, copied from Writer and pasted into other editor (e.g. Wordpad) does not keep Typeface (sequence is pasted with a default Typeface).
Comment 1 Yousuf Philips (jay) (retired) 2014-07-11 11:14:08 UTC
Dear fred4u,

Can you please send a sample file so we can investigate this. Thank you.
Comment 2 fred4u 2014-07-11 20:02:32 UTC
Created attachment 102643 [details]
Writer file used to demonstrate garbled Wingdings symbols
Comment 3 fred4u 2014-07-11 20:06:13 UTC
Problem occurs when the charactes are copied & pasted from other application (like Wordpad, or Charmap).
When the Writer function Insert -> Special character is used, the characters are displayed correctly.

However, if they will be copied/pasted into other (3rd party) application like Wordpad, and copied/pasted again into Writer, they will become garbled.
Comment 4 Urmas 2014-07-12 01:56:46 UTC

*** This bug has been marked as a duplicate of bug 72031 ***