Bug 81292 - TABLE: Crashes on sorting table
Summary: TABLE: Crashes on sorting table
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: Other All
: high major
Assignee: Not Assigned
URL:
Whiteboard: BSA target:6.3.0
Keywords: haveBacktrace, possibleRegression
Depends on:
Blocks:
 
Reported: 2014-07-13 13:18 UTC by Bart Hengeveld
Modified: 2018-12-10 17:52 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
attachment-1855-0.html (2.99 KB, text/html)
2014-07-14 08:45 UTC, Bart Hengeveld
Details
attachment-1855-1.dat (1 bytes, multipart/alternative)
2014-07-14 08:45 UTC, Bart Hengeveld
Details
log-data-zonder.odt (57.17 KB, application/vnd.oasis.opendocument.text)
2014-07-14 08:45 UTC, Bart Hengeveld
Details
backtrace.txt (28.57 KB, text/plain)
2014-07-15 12:22 UTC, Bart Hengeveld
Details
screenshot of the report from Ubuntu with segfault and stacktrace. (102.40 KB, image/png)
2014-07-17 15:18 UTC, sophie
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Bart Hengeveld 2014-07-13 13:18:00 UTC
Problem description: 
I have a table first column alpha-numeric,crashes when sorting is ask.
Steps to reproduce:
1. Load table,
2. select table
3. sort

Current behavior: crash

Expected behavior: alpha-numeric sorting

              
Operating System: Windows 7
Version: 4.2.5.2 release
Last worked in: 4.2.4.2 release
Comment 1 Yousuf Philips (jay) (retired) 2014-07-13 15:47:04 UTC
Hello Bart,

Thank you for filing the bug. Please send us a sample document, as this makes it easier for us to verify the bug.
Comment 2 Bart Hengeveld 2014-07-14 08:45:04 UTC
Created attachment 102749 [details]
attachment-1855-0.html

Attached, I replaced the text in the last column.

Regards,

Bart Hengeveld


bugzilla-daemon@freedesktop.org schreef op 13-7-2014 17:47:
> Jay Philips <mailto:philipz85@hotmail.com> changed bug 81292 
> <https://bugs.freedesktop.org/show_bug.cgi?id=81292>
> What 	Removed 	Added
> Status 	UNCONFIRMED 	NEEDINFO
> CC 		philipz85@hotmail.com
> Ever confirmed 		1
>
> *Comment # 1 <https://bugs.freedesktop.org/show_bug.cgi?id=81292#c1> 
> on bug 81292 <https://bugs.freedesktop.org/show_bug.cgi?id=81292> from 
> Jay Philips <mailto:philipz85@hotmail.com> *
> Hello Bart,
>
> Thank you for filing the bug. Please send us a sample document, as this makes
> it easier for us to verify the bug.
> ------------------------------------------------------------------------
> You are receiving this mail because:
>
>   * You reported the bug.
>
Comment 3 Bart Hengeveld 2014-07-14 08:45:04 UTC
Created attachment 102750 [details]
attachment-1855-1.dat
Comment 4 Bart Hengeveld 2014-07-14 08:45:04 UTC
Created attachment 102751 [details]
log-data-zonder.odt
Comment 5 Yousuf Philips (jay) (retired) 2014-07-14 14:10:11 UTC
Hi Bart,

Thank you for the sample document. I selected the file and sorted it by rows using key 2 in alphanumeric ascending order in LibreOffice 4.2.5 on Linux and 4.2.4 and 4.2.6 on Windows 7 and unfortunately couldnt reproduce the crash. Is there any additional information you can provide that will assist in reproducing this?

Note: Please dont reply to these message by email as it adds unnecessary information into the bug tracking system. Please click on the bug number link provided in the email and you will be taken to this bugzilla page, where you can add your comment and attachments.
Comment 6 Bart Hengeveld 2014-07-14 19:05:05 UTC
First of all I sorted with key 1. I can still with the sample document reproduce the crash. If I delete all text from the last column the sorting goes OK.
I run LibreOffice Versie: 4.2.5.2 Build ID: 1cb170a04bb1f12e77c884eab9192be736ec5f5 on a Windows 7 Professional 32-bit SP1 machine.
Comment 7 Yousuf Philips (jay) (retired) 2014-07-15 01:22:30 UTC
Hi Bart,

I had originally sorted Key 1 and that didnt crash for me and it didnt rearrange the list, as the list is already sorted by Key 1, so i didnt mention that in my previous comment. Well i went ahead and installed 4.2.5 to see if its a bug limited to that version, but still couldnt reproduce it on Windows 7.

Is it possible that you can follow the instructions provided at this link < https://wiki.documentfoundation.org/How_to_get_a_backtrace_with_WinDbg > and submit a backtrace, so that a developer can look into the reasoning of the crash. If you need any assistance during the process, i will be here to assist.
Comment 8 Bart Hengeveld 2014-07-15 12:22:43 UTC
Created attachment 102851 [details]
backtrace.txt

Results from windbg LibreOffice sorting issue.
Comment 9 Bart Hengeveld 2014-07-15 12:23:39 UTC
I hope that I did well.

Bart
Comment 10 Bart Hengeveld 2014-07-15 12:44:20 UTC
I saw something about a write error to a certain memory location. I did run a memtest, no errors.
Comment 11 Yousuf Philips (jay) (retired) 2014-07-15 19:28:01 UTC
Hi Bart,

Thank you for the backtrace. Yes the backtrace looks good and i will pass it on to a developer to evaluate.

I'm glad the instructions were simple enough for you to follow. Was there any information in the wiki that wasnt?

@Meeks: can you have a quick look at the backtrace.
Comment 12 Bart Hengeveld 2014-07-15 20:15:16 UTC
Hi Jay,

I made some mistakes initially due to faulty reading of the instructions, in the end however I read the text properly and than things went OK.
I did not do the mini dump.
Comment 13 sophie 2014-07-17 15:16:50 UTC
Hi, I reproduce the crash with 4.4.0.0 version and 4.3.0.3 version Ubuntu 14.04. I add a copy of the crash report from Ubuntu, not sure it is useful but who knows :)
Comment 14 sophie 2014-07-17 15:18:02 UTC
Created attachment 102987 [details]
screenshot of the report from Ubuntu with segfault and stacktrace.
Comment 15 Bart Hengeveld 2014-08-01 19:46:30 UTC
Also with the newest version of LibreOffice Versie: 4.3.0.4 
Build ID: 62ad5818884a2fc2e5780dd45466868d41009ec0
I can reproduce the crash when sorting a table. On another machine running 64 bit version of Windows 7 same results.
Comment 16 Bart Hengeveld 2014-08-02 09:33:22 UTC
I did now install LibreOffice 4.3.0.4 on my linux machine (Lubuntu 14.04.1 LTS - Mate). Same results, LibreOffice crashes on sorting the table.
Comment 17 Bart Hengeveld 2014-08-29 06:07:12 UTC
With the update to 4.3.1.2 issue is fixed. Sorting now OK.
Comment 18 Yousuf Philips (jay) (retired) 2014-08-29 09:10:36 UTC
Hi Bart,

Glad to hear that its fixed now.
Comment 19 Robinson Tryon (qubit) 2015-12-15 10:57:55 UTC
Migrating Whiteboard tags to Keywords: (possibleRegression)
[NinjaEdit]
Comment 20 Commit Notification 2018-12-10 17:52:26 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

https://git.libreoffice.org/core/+/e34fd6f86f15c96bb42466cc4179f1288863a428%5E%21

uitest for bug tdf#81292 and tdf#99334 - Sort table

It will be available in 6.3.0.

The patch should be included in the daily builds available at
https://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
https://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.