Bug Hunting Session
Bug 81294 - Insertion of a sheet changes values in other sheets
Summary: Insertion of a sheet changes values in other sheets
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.0.0.beta1
Hardware: All All
: highest normal
Assignee: Eike Rathke
URL:
Whiteboard: target:4.4.0 target:4.2.6 target:4.3.1
Keywords: regression
Depends on:
Blocks: mab4.2
  Show dependency treegraph
 
Reported: 2014-07-13 14:06 UTC by Albrecht Müller
Modified: 2014-07-21 08:18 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Example file to show the effect. (57.81 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-07-13 14:06 UTC, Albrecht Müller
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Albrecht Müller 2014-07-13 14:06:22 UTC
Created attachment 102702 [details]
Example file to show the effect.

How to reproduce:
Open the attached file and verify that cells C2 .. C5 in sheet 2 contain the values 16, 19 and 5. Select the first sheet. Use Insert --> Sheet to insert a new sheet before the first sheet. Goto sheet 2 and observe that the cells above now contain zeros.  Pressing Shift+CTRL+F9 to start a hard recalculation does not solve the problem. Saving the spreadsheet and reloading it again seems to fix it. Another way to fix it is to re-enter the formulas contained in these cells, for example you can go to the input line, add a blank at the and of the formula and press enter. Then the correct value reappears. 

Expected behaviour:
Insertion of a sheet should not change the contents of other sheets.

Observed with Libre Office Version: 4.2.5.2 and Windows 7
Comment 1 Joel Madero 2014-07-16 19:33:57 UTC
Thank you for reporting this issue! I have been able to confirm the issue on:
Version: 4.3.0.2 rc
Platform :Ubuntu 14.04
DE: GNOME3

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +

As I've been able to confirm this problem I am marking as:

New (confirmed)
Minor - there is no actual data loss here, so this can slow down professional quality work but won't prevent it
Highest - bumped up from low - relatively common setup, a couple basic formulas, insert a sheet, and user experiences what seems to be data loss.

Adding to MAB list.


@Albrecht - is this a regression? If so please add "regression" to keyword field, bibisectRequest to whiteboard field and leave a comment letting us know in what version it works.



+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + +
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage and join us on freenode at #libreoffice-qa

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 2 ign_christian 2014-07-17 09:06:29 UTC
Reproduced with 4.2.6.1, 4.2.4.2, 4.2.0.0.beta1 on Ubuntu 12.04 x86

Not reproduced with 4.1.6.2
Comment 3 Eike Rathke 2014-07-17 19:09:05 UTC
Trying.
Comment 4 Commit Notification 2014-07-17 22:55:25 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4011b74eb7650a0eeb99d3acebb9ef60b0fcaab9

resolved fdo#81294 store correct sheet number during range names update



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Eike Rathke 2014-07-17 23:09:21 UTC
Pending review
for 4-3 at https://gerrit.libreoffice.org/10374
for 4-3-0 at https://gerrit.libreoffice.org/10375
for 4-2 at https://gerrit.libreoffice.org/10376
for 4-2-6 at https://gerrit.libreoffice.org/10377
Comment 6 Commit Notification 2014-07-18 00:28:09 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0e4ec4059371826c1742206e2ff6509df19e2cd1&h=libreoffice-4-2

resolved fdo#81294 store correct sheet number during range names update


It will be available in LibreOffice 4.2.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2014-07-18 00:28:26 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=76a4eee58830b7faf4fa0a89e82df36e352d5b06&h=libreoffice-4-3

resolved fdo#81294 store correct sheet number during range names update


It will be available in LibreOffice 4.3.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 ign_christian 2014-07-18 05:46:28 UTC
Thanks Eike for the very fast fix :)

Removing BibisectRequest
Comment 9 Jean-Baptiste Faure 2014-07-18 09:29:16 UTC
Vrified fixed in Version: 4.3.1.0.0+
Build ID: 76a4eee58830b7faf4fa0a89e82df36e352d5b06
build at home under Ubuntu 14.04 x86-64

Best regards. JBF
Comment 10 Commit Notification 2014-07-21 08:18:08 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "libreoffice-4-2-6":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7477e87a1baaddf50f332c152568620e3ce32184&h=libreoffice-4-2-6

resolved fdo#81294 store correct sheet number during range names update


It will be available already in LibreOffice 4.2.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.