Bug 81302 - CRASH by segmentation fault when trying to open the contextual menu of a picture
Summary: CRASH by segmentation fault when trying to open the contextual menu of a picture
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.3.0.2 rc
Hardware: x86-64 (AMD64) Linux (All)
: medium critical
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:4.3.0
Keywords: regression
Depends on:
Blocks:
 
Reported: 2014-07-13 18:09 UTC by Jean-Baptiste Faure
Modified: 2014-07-19 08:42 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
bugdoc with a picture (176.30 KB, application/vnd.oasis.opendocument.text)
2014-07-13 18:09 UTC, Jean-Baptiste Faure
Details
backtrace of the crash (7.48 KB, text/x-log)
2014-07-13 18:13 UTC, Jean-Baptiste Faure
Details
linux backtrace (3.13 KB, application/zip)
2014-07-14 22:14 UTC, Yousuf Philips (jay) (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jean-Baptiste Faure 2014-07-13 18:09:13 UTC
Created attachment 102715 [details]
bugdoc with a picture

Steps to reproduce:
1/ open the attached bugdoc
2/ select the picture
3/ right click and choose the picture item

Observed behavior: crash by segmentation fault

Best regards. JBF
Comment 1 Jean-Baptiste Faure 2014-07-13 18:13:47 UTC
Created attachment 102718 [details]
backtrace of the crash

Here is a backtrace.
As my build is incremental, I will make a clean rebuild and try again.

Best regards. JBF
Comment 2 Jean-Baptiste Faure 2014-07-13 18:15:57 UTC
I forgot to indicate my version: 
Version: 4.3.1.0.0+
Build ID: 90939f2b5dfc8a7aafc255322f0fcb66f670241e 
under Ubuntu 14.04 x86-64

Best regards. JBF
Comment 3 Cor Nouws 2014-07-13 20:14:12 UTC
Hi Jean-Baptiste,

No problem here with 4.3.0.2 on Ubuntu 32 bits

Ciao,
Cor
Comment 4 Jean-Baptiste Faure 2014-07-14 06:35:55 UTC
(In reply to comment #3)
> Hi Jean-Baptiste,
> 
> No problem here with 4.3.0.2 on Ubuntu 32 bits

Indeed crash not reproducible for me too with LO 4.3.0.2 on Ubuntu 64 bits

But the crash is reproducible with Version: 4.3.1.0.0+
Build ID: 8eb5dce78943da38d73838b564117c4307b4fcb7 from

Version: 4.3.1.0.0+
Build ID: 8eb5dce78943da38d73838b564117c4307b4fcb7
libreoffice-4-3~2014-07-09_07.59.01_LibreOfficeDev_4.3.1.0.0_Linux_x86-64_deb.tar.gz 
Tinderbox Linux-rpm_deb-x86_64@46-TDF

Best regards. JBF
Comment 5 Jean-Baptiste Faure 2014-07-14 09:18:38 UTC
No crash in Version: 4.3.1.0.0+
Build ID: d72d80aa8393c9416423602779cb63b22141033a
tested from /daily/libreoffice-4-3/Linux-rpm_deb-x86_64@46-TDF/2014-07-04_02.57.24
crash in all more recent build.

Summary:
Last working build ID is d72d80aa8393c9416423602779cb63b22141033a
First crashing build is 1cacd685bf7c3230d3cdff964503adaedd025418

Best regards. JBF
Comment 6 Jean-Baptiste Faure 2014-07-14 15:24:54 UTC
Last non crashing version : Version: 4.3.1.0.0+
Build ID: 3372b1e0b36f3f7e89e88bb7495efad78fdd3417

The problematic commit is http://cgit.freedesktop.org/libreoffice/core/commit/?h=libreoffice-4-3&id=dc17dad5fd7509f191718df8690e5847ab87669a

Best regards. JBF
Comment 7 Jorendc 2014-07-14 15:30:20 UTC
No repro on Linux Mint 17 x64 with LibreOffice Version: 4.4.0.0.alpha0+
Build ID: 25b18c6fe055035a1d5f835cf178acd55a585811 but that is possible, because it is not reverted on master.
Comment 8 Yousuf Philips (jay) (retired) 2014-07-14 22:12:48 UTC
Though i tested this yesterday on the same version and it didnt crash, all of a sudden today, it started crashing.

Version: 4.3.1.0.0+
Build ID: 27fec073a8e78aad1979160bc4c8d9a4aafc3e82
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:libreoffice-4-3, Time: 2014-07-08_16:41:08
Comment 9 Yousuf Philips (jay) (retired) 2014-07-14 22:14:09 UTC
Created attachment 102803 [details]
linux backtrace
Comment 10 Michael Stahl (CIB) 2014-07-15 15:30:10 UTC
crash on accessing tab 8 of 7,
looks like there was one commit that should have been reverted as well.
Comment 11 Commit Notification 2014-07-15 15:31:43 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f899e508c35b6170bc11fc2eb4a74ec58d895625&h=libreoffice-4-3

fdo#81302: Revert "sw: adapt object/picturedialog.ui to FillAttributes"


It will be available in LibreOffice 4.3.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 12 Commit Notification 2014-07-15 17:37:51 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-3-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=541e0098d2207dcc6e4053b2e2243de9a81d258c&h=libreoffice-4-3-0

fdo#81302: Revert "sw: adapt object/picturedialog.ui to FillAttributes"


It will be available already in LibreOffice 4.3.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 Jean-Baptiste Faure 2014-07-19 08:42:00 UTC
Verified fixed for LibreOffice 4.3.1.0.0+ (Build ID: 9451e52b449210a83502b337c6fcc0c240daa576) build at home under Ubuntu 14.04 x86-64.

Thank you very much for the quick fix :-)
Best regards. JBF