Bug 81387 - continually crashing: EXC_BAD_ACCESS (SIGSEGV)
Summary: continually crashing: EXC_BAD_ACCESS (SIGSEGV)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: Other Mac OS X (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: regression
: 81525 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-07-15 15:02 UTC by Thomas Seidler
Modified: 2017-05-26 07:23 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Thomas Seidler 2014-07-15 15:02:01 UTC
Just upgraded and non-stop problems... alas i replaced the old version! Will downgrade till resolved.

Stack trace attached, just keeps crashing... in this  last case i closed a file i think it's the same thing each time.

Process:         soffice [2775]
Path:            /Applications/LibreOffice.app/Contents/MacOS/soffice
Identifier:      org.libreoffice.script
Version:         4.2.5002 (???)
Code Type:       X86 (Native)
Parent Process:  launchd [161]
Responsible:     soffice [2775]
User ID:         502

Date/Time:       2014-07-15 15:55:32.007 +0100
OS Version:      Mac OS X 10.9.4 (13E28)
Report Version:  11
Anonymous UUID:  B23A67BA-6C72-9B18-25C0-E96E5847937D


Crashed Thread:  0  Dispatch queue: com.apple.main-thread

Exception Type:  EXC_BAD_ACCESS (SIGSEGV)
Exception Codes: KERN_INVALID_ADDRESS at 0x00000000c0603b14

VM Regions Near 0xc0603b14:
    CG backing stores      00000000c04f5000-00000000c052c000 [  220K] rw-/rw- SM=SHM  
--> 
    CG shared images       00000000c0d74000-00000000c0d7c000 [   32K] r--/r-- SM=SHM  

Application Specific Information:
objc_msgSend() selector name: release


Thread 0 Crashed:: Dispatch queue: com.apple.main-thread
0   libobjc.A.dylib               	0x94cca4a7 objc_msgSend + 23
1   com.apple.CoreFoundation      	0x9ac16599 -[__NSOrderedSetM dealloc] + 89
2   libobjc.A.dylib               	0x94ce05ef -[NSObject release] + 47
3   com.apple.CoreFoundation      	0x9ac25816 -[__NSOrderedSetArrayProxy dealloc] + 38
4   libobjc.A.dylib               	0x94ce05ef -[NSObject release] + 47
5   com.apple.CoreFoundation      	0x9ab54e74 CFRelease + 436
6   com.apple.HIServices          	0x9a95c3c0 _AXXMIGCopyAttributeNames + 314
7   com.apple.HIServices          	0x9a9664bf _XCopyAttributeNames + 372
8   com.apple.HIServices          	0x9a93f2e7 mshMIGPerform + 229
9   com.apple.CoreFoundation      	0x9abc1e15 __CFRUNLOOP_IS_CALLING_OUT_TO_A_SOURCE1_PERFORM_FUNCTION__ + 53
10  com.apple.CoreFoundation      	0x9abc1d7b __CFRunLoopDoSource1 + 523
11  com.apple.CoreFoundation      	0x9abb24b2 __CFRunLoopRun + 2130
12  com.apple.CoreFoundation      	0x9abb19ea CFRunLoopRunSpecific + 394
13  com.apple.CoreFoundation      	0x9abb184b CFRunLoopRunInMode + 123
14  com.apple.HIToolbox           	0x94e9cb5d RunCurrentEventLoopInMode + 259
15  com.apple.HIToolbox           	0x94e9c8e2 ReceiveNextEventCommon + 526
16  com.apple.HIToolbox           	0x94e9c6bd _BlockUntilNextEventMatchingListInModeWithFilter + 92
17  com.apple.AppKit              	0x90c25349 _DPSNextEvent + 1602
18  com.apple.AppKit              	0x90c24870 -[NSApplication nextEventMatchingMask:untilDate:inMode:dequeue:] + 119
19  libvcllo.dylib                	0x01a72288 AquaSalInstance::Yield(bool, bool) + 1240
20  libvcllo.dylib                	0x01730be9 Application::Yield() + 73
21  libvcllo.dylib                	0x01730c95 Application::Execute() + 53
22  libsofficeapp.dylib           	0x0006fa6b desktop::Desktop::Main() + 7403
23  libvcllo.dylib                	0x01737082 ImplSVMain() + 226
24  libvcllo.dylib                	0x01a70f01 AquaSalInstance::handleAppDefinedEvent(NSEvent*) + 129
25  libvcllo.dylib                	0x01aac9db -[VCL_NSApplication sendEvent:] + 123
26  com.apple.AppKit              	0x90c171bc -[NSApplication run] + 823
27  com.apple.AppKit              	0x90bffff8 NSApplicationMain + 1165
28  libvcllo.dylib                	0x01a71859 ImplSVMainHook(int*) + 489
29  libvcllo.dylib                	0x017370ba SVMain() + 26
30  libsofficeapp.dylib           	0x0009bbc5 soffice_main + 277
31  org.libreoffice.script        	0x00001f4e main + 30
32  org.libreoffice.script        	0x00001f25 start + 53
Comment 1 Keith 2014-07-16 17:07:05 UTC
I am seeing the same error. In Calc, the error occurs when the last open window is closed.
Comment 2 Julien Nabet 2014-07-19 18:45:12 UTC
*** Bug 81525 has been marked as a duplicate of this bug. ***
Comment 3 Julien Nabet 2014-07-19 18:46:24 UTC
Putting it at NEW since there's a bt.

Thorsten: one for you?
Comment 4 retired 2014-07-19 23:29:27 UTC
adding regression since older versions seem to work fine for bug reporter.

Also since two people already are seeing this, and continuous crashes prevent real work from happening raising from medium to major.
Comment 5 Julien Nabet 2014-11-24 20:43:24 UTC
Any update with last stable LO version 4.3.4?
Comment 6 Christopher Chavez 2014-11-24 21:42:21 UTC
(In reply to Julien Nabet from comment #5)
> Any update with last stable LO version 4.3.4?

The issue I described in bug 81525 is definitely no longer apparent. (4.3.4 on OS X 10.10.1)
Comment 7 Julien Nabet 2015-01-24 09:00:42 UTC
Thomas/Keith: following Christopher's comment, any update with last LO version 4.3.5?
Comment 8 Julien Nabet 2015-04-19 19:56:26 UTC
No feedback since a little less than 3 months, let's put this one to WFM.

Thomas/Keith: don't hesitate to reopen this tracker if you can reproduce this with recent LO version (4.4.2 or at least 4.3.6)