Bug 81525 - LibreOffice crashes on OS X after closing last document or startcenter if focused on app
Summary: LibreOffice crashes on OS X after closing last document or startcenter if foc...
Status: RESOLVED DUPLICATE of bug 81387
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.3.0.3 rc
Hardware: x86-64 (AMD64) macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-19 08:31 UTC by Christopher Alexander Chavez
Modified: 2014-07-19 18:45 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments
Example crash report (54.34 KB, text/plain)
2014-07-19 08:31 UTC, Christopher Alexander Chavez
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Christopher Alexander Chavez 2014-07-19 08:31:38 UTC
Created attachment 103085 [details]
Example crash report

(This is OS X specific, since LibreOffice is assumed to stay open; whereas it closes, unless quickstart is enabled, on Linux or Windows.)

If the last document/startcenter ("welcome screen") is closed (red button at top of window) while not focused on the app (i.e. menu bar does not say "LibreOffice"), then I can come back to LibreOffice by command-tab and then choosing something from the File menu or keyboard shortcut, or by clicking the dock icon (which opens startcenter). 

I'm not sure these cases are reliable and what other conditions apply. One attempt, I can close last window but once I clicked the File menu, it crashed.
Comment 1 Julien Nabet 2014-07-19 18:45:12 UTC
Following description + backtrace, it seems a dup of fdo#81387.

*** This bug has been marked as a duplicate of bug 81387 ***