Bug 81409 - FILESAVE: Concordance file (.sdi)
Summary: FILESAVE: Concordance file (.sdi)
Status: RESOLVED INSUFFICIENTDATA
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks: Concordance-File
  Show dependency treegraph
 
Reported: 2014-07-16 05:33 UTC by Emilian
Modified: 2021-03-31 03:41 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Concordance file with the question mark instead of some characters. (68 bytes, text/plain)
2014-07-16 05:33 UTC, Emilian
Details
working ok (29.33 KB, image/png)
2020-08-31 20:51 UTC, BogdanB
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Emilian 2014-07-16 05:33:33 UTC
Created attachment 102892 [details]
Concordance file with the question mark instead of some characters.

Problem description: Concordance file not support all characters.

Current behavior: Put a question mark in place of other than ASCII characters.

Expected behavior: To support all Unicode characters.

              
Operating System: Windows 7
Version: 4.2.5.2 release
Comment 1 tommy27 2014-07-17 04:48:56 UTC
hi, I see this when opening the file in LO 4.2.5.2 and 4.4 master under Win7x64:

test;;;;0;0
?i;;;;0;0
?inem?;;;;0;0
cândva;;;;0;0
lua?i;;;;0;0

I have no experience with .sdi files... which software should be used to correctly view them?
Comment 2 Emilian 2014-07-17 11:12:07 UTC
I think it's a mistake in saving files sdi.
Comment 3 Emilian 2014-07-17 11:17:53 UTC
I tested on OS X and sdi file saves fine. If you want to test you can create an index apfabetic and to add a concordance file to add words with different unicode characters.
Comment 4 Emilian 2014-07-17 11:19:07 UTC
The file should look like this:
test;;;;0;0
și;;;;0;0
ținemă;;;;0;0
cândva;;;;0;0
luați;;;;0;0
Comment 5 tommy27 2014-07-17 12:11:52 UTC
ok, please post a screenshot of that .sdi file opened in another software which renders text correctly.

regarding this bug, are we dealing with a FILESAVE or rather a FILEOPEN issue?
Comment 6 Emilian 2014-07-17 12:31:35 UTC
It is a FILESAVE problem.  I have no better program to see the file that it can not because it's misspelled.
Comment 7 Robinson Tryon (qubit) 2014-09-25 22:07:06 UTC
TESING with LO 4.3.2.2 + Ubuntu 14.04
(In reply to comment #6)
> It is a FILESAVE problem.  I have no better program to see the file that it
> can not because it's misspelled.

Okay, I think I'm now understanding the issue.

The attached .sdi file is not Unicode-encoded:
  $file test.sdi
  test.sdi: ISO-8859 text, with CRLF line terminators

(possible) Repro Steps:
- Open LibreOffice Writer (on Windows)
- Create a Concordance file as described in the Help files [1]
- That includes:
- Insert -> Indexes and Tables -> Indexes and Tables -> Index/Table
- In the Type box, select "Alphabetical Index".
- In the Options area, select the Concordance file check box.
- Click the File button, and then choose New
- Create a new file, copying-in high-unicode words like și, ținemă, cândva, and luați
- Click 'OK'/save the concordance file

RESULT:
For me, everything worked, and the names appear as expected. The file is unicode:
  $ file new-sdi-file.sdi
  new-sdi-file.sdi: UTF-8 Unicode text

We'll need someone on Windows who can confirm the behavior you describe. Because this bug is now better-understood, removing needAdvice tag.


[1] https://help.libreoffice.org/Writer/Edit_Concordance_File
Comment 8 Yousuf Philips (jay) (retired) 2014-09-26 00:01:21 UTC
Confirmed on Windows 7 on master and 3.3.0 using qubit's steps.

Version: 4.4.0.0.alpha0+
Build ID: 0a32edcdc2bda75a7536ce7f88c91cbc56e7afb1
TinderBox: Win-x86@39, Branch:master, Time: 2014-09-24_00:45:04

File is encoded in ascii and this was its contents.

?i;?inem?;cândva;lua?i;0;0
Comment 9 QA Administrators 2016-11-08 10:38:07 UTC Comment hidden (obsolete)
Comment 10 Buovjaga 2017-07-06 12:57:59 UTC
*** Bug 108910 has been marked as a duplicate of this bug. ***
Comment 11 QA Administrators 2018-07-07 02:39:36 UTC Comment hidden (obsolete)
Comment 12 BogdanB 2020-08-31 20:43:34 UTC
The language the reporter is using is romanian. My language is also romanian, so it is easy for me to test this.

What I have discovered:

I saved the file the reporter attached in description. And to insert there one diacritics from romanian language. And I get the message from the text editor:
"We could NOT save the file using Vestic coding (ISO-8859-15). The document contains one or more characters that can not pe coded. Choose another coding from below".

After I choose  "Romana ISO-8859-16" (meaning romanian language) everything worked perfect.
Comment 13 BogdanB 2020-08-31 20:49:59 UTC
Now, in order to see if it is our bug, or is a problem by defining ISO I will try to generate a .sdi file from the Writer: 

1. Open a new file, Insert Table of Contents - Alphabetical index - Concordance file - New
2. After that I inserted into the .sdi file some romanian characters and they were saved and well rendered in the Index (see the screenshot)

For Emilian: please retest this bug with the steps from this comment above (steps 1+2).
Comment 14 BogdanB 2020-08-31 20:51:08 UTC
Created attachment 164940 [details]
working ok
Comment 15 BogdanB 2020-08-31 21:04:30 UTC
Could be a problem with encoding on Windows
See this bug: https://bugs.documentfoundation.org/show_bug.cgi?id=108910
Comment 16 QA Administrators 2021-02-28 04:02:02 UTC Comment hidden (obsolete)
Comment 17 QA Administrators 2021-03-31 03:41:48 UTC
Dear Emilian,

Please read this message in its entirety before proceeding.

Your bug report is being closed as INSUFFICIENTDATA due to inactivity and
a lack of information which is needed in order to accurately
reproduce and confirm the problem. We encourage you to retest
your bug against the latest release. If the issue is still
present in the latest stable release, we need the following
information (please ignore any that you've already provided):

a) Provide details of your system including your operating
   system and the latest version of LibreOffice that you have
   confirmed the bug to be present

b) Provide easy to reproduce steps – the simpler the better

c) Provide any test case(s) which will help us confirm the problem

d) Provide screenshots of the problem if you think it might help

e) Read all comments and provide any requested information

Once all of this is done, please set the bug back to UNCONFIRMED
and we will attempt to reproduce the issue. Please do not:

a) respond via email 

b) update the version field in the bug or any of the other details
   on the top section of our bug tracker

Warm Regards,
QA Team

MassPing-NeedInfo-FollowUp