Bug Hunting Session
Bug 81457 - Document Properties crashes LO
Summary: Document Properties crashes LO
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: BSA target:4.4.0 target:4.3.1 target:...
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-17 08:17 UTC by Daniel
Modified: 2018-04-07 17:24 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Almost empty ODT (50.34 KB, application/vnd.oasis.opendocument.text)
2014-07-17 08:17 UTC, Daniel
Details
gdbtrace.log (27.32 KB, text/plain)
2014-07-17 08:45 UTC, Jorendc
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel 2014-07-17 08:17:35 UTC
Created attachment 102969 [details]
Almost empty ODT

Problem description: 

When starting with a blank document, properties works as normal, but with attached (almost empty) document LO crashes. Both on Windows XP and Linux. LO 3.6.7.2 on Windows XP works.

Steps to reproduce:
1. Open attached document
2. Choose File - Properties
3. Watch LO crash

Current behavior: Crash

Expected behavior: Not crashing
Operating System: Linux (Other)
Version: 4.2.5.2 release
Comment 1 Jorendc 2014-07-17 08:43:47 UTC
Thanks for reporting!

Reproducible using Linux Mint 17 x64 with LibreOffice Version: 4.4.0.0.alpha0+
Build ID: f4a2f1e647354efb75be8c90384d6cd3e5f9b9bd

I'll attach a backtrace.

Kind regards,
Joren
Comment 2 Jorendc 2014-07-17 08:45:38 UTC
Created attachment 102970 [details]
gdbtrace.log

What I did: 
* Run instdir/program/soffice --backtrace
* Open attached file
* File > Properties

LibreOffice did hang, so I did ctrl+C in terminal.
(My build is --enable-debug).

Kind regards,
Joren
Comment 3 Julien Nabet 2014-07-20 10:32:56 UTC
Caolan/Chris: Joren's bt shows vcl part, an infinite loop in vcl/source/window/dlgctrl.cxx (ImplGetSubChildWindow method), one for you?
Comment 4 Caolán McNamara 2014-07-22 10:45:59 UTC
I think its not actual infinite, just ridiculously quadratic and exposed because of the number of custom properties in here.
Comment 5 Commit Notification 2014-07-22 13:39:33 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=13807fbf9f3a4aae6767da8bcf796bea4b065159

Related: fdo#81457 skip setting an empty allocation



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2014-07-22 13:39:49 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=aff263c8b814c6bf352312403d3c1e448c8013a3

Related: fdo#81457 quadratic time required when setting a11y name



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Caolán McNamara 2014-07-22 13:41:26 UTC
Still takes a few seconds to render, but that's opposed to the current situation which is practically infinite.
Comment 8 Commit Notification 2014-07-25 14:45:10 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=602b4643e0d92a1b8102032652abb2b08c790ec2&h=libreoffice-4-3

Related: fdo#81457 skip setting an empty allocation


It will be available in LibreOffice 4.3.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2014-07-25 14:47:02 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=aeef56b3731e746406b441550aea217dcb39371d&h=libreoffice-4-2

Related: fdo#81457 skip setting an empty allocation


It will be available in LibreOffice 4.2.7.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2018-04-07 17:24:12 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=0cff17a62d16f295284cdb17040a03b176ca7cf0

uitest - writer Document properties; tdf#49683; tdf#81457

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.