Bug 81481 - FILEOPEN: MS .doc import regression with table style
Summary: FILEOPEN: MS .doc import regression with table style
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, regression
Depends on:
Blocks:
 
Reported: 2014-07-18 05:17 UTC by Luke
Modified: 2015-12-15 11:03 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Comparison of onedrive, LO 4.2.4.2, and master build (629.27 KB, image/png)
2014-07-18 05:17 UTC, Luke
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2014-07-18 05:17:26 UTC
Created attachment 103015 [details]
Comparison of onedrive, LO 4.2.4.2, and master build

Steps to reproduce the bug:
1. Open attachment 81324 [details] Demo-Hayden-Management.doc the current master
2. Open attachment 81324 [details] Demo-Hayden-Management.doc Writer 4.4 6/17 build or earlier 
3. Compare the documents. 

Note that in recent builds the table loses the color shading. 

On Windows Version: 4.4.0.0.alpha0+
Build ID: 3e82897353e576dc6e3fbf55371fda5a0c3415df
TinderBox: Win-x86@39, Branch:master, Time: 2014-06-17_08:55:34
Result: pass


On Windows Version: 4.4.0.0.alpha0+
master~2014-07-17_08.23.11
Result: fail
Comment 1 tommy27 2014-07-18 05:36:55 UTC
please upload the .doc file
your links are only .png screenshots
Comment 2 Kevin Suo 2014-07-18 05:44:08 UTC
@Luke:
I see it's a financial report, so may be business confidiential document. Maybe you can cut and paste the table, replace the numbers with random number, make sure you can reproduce with the new document, and then attach it here?
Comment 3 Luke 2014-07-18 05:49:21 UTC
Sorry for the confusion. It's attachment 81325 [details]
Comment 4 Kevin Suo 2014-07-18 05:57:45 UTC
Confirmed with
Version: 4.4.0.0.alpha0+
Build ID: 461e46904ffa29820be1ccb64cdb9cb6d4469b6c
TinderBox: Win-x86@39, Branch:master, Time: 2014-07-17_08:23:11

Table cell backcolor is lost.
Comment 5 Miklos Vajna 2014-07-18 11:29:19 UTC
daily.git:
- oldest is good
- master is bad
- [49ffb467231cc09d9e351aa2d37f2c0d99c3eb3d] 2014-06-19 is good
- [3c19bff344aa6109cdd40e5ab4986a95ecdd7542] 2014-07-03 is bad
- [f63a0377260f507effb987cd66ebbc0772906a2c] 2014-06-26 is good
- [998f4b7ef8a3213b3cb94628acd93fa624f9268c] 2014-06-29 is good
- [51d0b5cdc80ce7b0a3e0694e91547d3e7942f19f] 2014-07-01 is good -> 88bd199e761a165b8add0cebac9f149dc4250829 in core.git
- [b7ea5ebd0e0fee42d8971dd75b8efbc6e0e47739] 2014-07-02 is bad -> 4f90623dba6a211e7b4c9e98def91605627c5072 in core.git

git log
88bd199e761a165b8add0cebac9f149dc4250829..4f90623dba6a211e7b4c9e98def91605627c5072
contains 5 ALG cherry-picks, probably it is worth bisecting the range to see
the exact commit.
Comment 6 Michael Stahl (CIB) 2014-07-24 13:09:32 UTC
bug 81297 has a HTML attachment that is also affected, table cell background lost
Comment 7 Luke 2014-08-14 08:17:51 UTC
I narrowed this down to:
a5e137eb1d37361c60175e8fba780fc46b377a23 is good
0df2e8d6826cb8672d61e05280d98840a51b2771 is bad

I could not narrow this down further since all of Armin Le Grand's patches generate an Unknown Property Exception. This build error was not fixed until 0df2e8d6826cb8672d61e05280d98840a51b2771.
Comment 8 Luke 2014-09-30 06:02:14 UTC
commit	5aa360cae0383f270c12708e7e94179a7fde6711 fixed this issue in 4.4.
Thanks Caolán!

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5aa360cae0383f270c12708e7e94179a7fde6711
Comment 9 Robinson Tryon (qubit) 2015-12-15 11:03:42 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]