Bug 81518 - FILEOPEN: Table margins and border not imported correctly
Summary: FILEOPEN: Table margins and border not imported correctly
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.4.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-19 05:01 UTC by Luke
Modified: 2016-05-25 21:44 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot highlighting the issue with the table (238.19 KB, image/png)
2014-07-19 05:01 UTC, Luke
Details
minimal test case (16.18 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-07-19 06:55 UTC, tommy27
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Luke 2014-07-19 05:01:32 UTC
Created attachment 103078 [details]
Screenshot highlighting the issue with the table

Steps to reproduce the bug:
1. Open attachment 81684 [details] in Writer 4.3
2. Open attachment 81684 [details] in Writer 4.4
3. Compare the documents. 

Note the right border is incorrectly rendered in recent 4.4 builds.

In windows, Version: 4.4.0.0.alpha0+
Build ID: f38bf4c6c29d685ec4f1015be09f64c7ae2eb172
TinderBox: Win-x86@39, Branch:master, Time: 2014-07-04_02:13:48
Result:PASS

Version: 4.4.0.0.alpha0+
Build ID: eddd7646d672ea9b0561dacb09da224d098e531e
TinderBox: Win-x86@39, Branch:master, Time: 2014-07-18_06:42:50
Result:FAIL
Comment 1 tommy27 2014-07-19 06:46:28 UTC
very recent 4.4.x regression 

table was rendered correctly in 4.4.0.0.alpha0+
Build ID: abc28ffc04067eb24840fbf564c311aaee10f84d
TinderBox: Win-x86@42, Branch:master, Time: 2014-07-15_07:20:05

table has missing right border in 4.4.0.0.alpha0+
Build ID: b9dca968c6fd0ab5ca140c65b0e54d153cd34986
TinderBox: Win-x86@42, Branch:master, Time: 2014-07-18_22:51:20
Comment 2 tommy27 2014-07-19 06:55:09 UTC
Created attachment 103081 [details]
minimal test case

easier to debug
Comment 3 Luke 2014-07-23 03:32:17 UTC
In MS Word 2007, when you force the table to the left column by inserting a manual page break above it, the border disappears just like Writer. 

The real issue here is why is 4.4 doing a worse job of laying out the page? Why does the table end up in the wrong page and column? Is there something between "related project plan." and "Revenue Forecasting" that is causing 4.4 to move the text to a new page?

Since this is a layout issue not a table issue, should I open a new report or should I just change the title?
Comment 4 Luke 2014-07-23 06:56:34 UTC
Word 2013 also cuts off the right side of the border when the table is pushed to the next page. 

Between "marketing claims." and "License Agreements" there is a column break that the prior versions of Writer were not respecting.( 2 bugs were canceling each other out) The issue here is the 3D bar chart is positioned incorrectly, pushing all the text down. I'll create a new bug report for that. In the meantime, I'll close this as "Not a Bug"
Comment 5 Robinson Tryon (qubit) 2015-12-17 08:26:59 UTC
Migrating Whiteboard tags to Keywords: (bibisectRequest)
[NinjaEdit]
Comment 6 Luke 2016-05-25 21:44:13 UTC
The 3D bar chart is positioned incorrectly because of Bug 82824.