Download it now!
Bug 81542 - EDITING: formulas referencing another sheet not updating
Summary: EDITING: formulas referencing another sheet not updating
Status: RESOLVED DUPLICATE of bug 79441
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.3.0.3 rc
Hardware: All All
: high minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, regression
Depends on:
Blocks:
 
Reported: 2014-07-19 16:03 UTC by janekptacijarabaci
Modified: 2015-12-15 11:03 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
Test/Example - Loss of linking for cells (*.ods + screenshots) (69.87 KB, application/zip)
2014-07-19 16:03 UTC, janekptacijarabaci
Details

Note You need to log in before you can comment on or make changes to this bug.
Description janekptacijarabaci 2014-07-19 16:03:46 UTC
Created attachment 103112 [details]
Test/Example - Loss of linking for cells (*.ods + screenshots)

Steps to reproduce:
1) Open "test_loss-of-linking-for-cells_2.ods"
2) List1: Button "Delete Martin and Sort by Name"
3) List2: Loss of linking for cells: List1.B11 => List2.B11 (bad: value = 10, correctly: value = 0)

Thank you very much for the correction.

LibreOffice:
This bug is in version 4.3.0.0Beta1+ (including version 4.3.0.3RC3), but NOT ALSO in the version 4.2.4.2(Final/Stable).

See Also:
https://bugs.freedesktop.org/show_bug.cgi?id=61344
https://bugs.freedesktop.org/show_bug.cgi?id=70815
https://bugs.freedesktop.org/show_bug.cgi?id=79441
https://bugs.freedesktop.org/show_bug.cgi?id=81330
Comment 1 Joel Madero 2014-07-19 20:34:40 UTC
Confirmed:
Ubuntu 14.04 x64
LibreOffice 4.3.0.2 rc


New - confirmed
Minor - it can slow down professional quality work but won't prevent it (you can force the refresh with shift + ctrl + f9)
High - I think this could affect a significant amount of people using formulas across sheets (which is common I think)

regression (works fine in 4.2)



bibisected:
6d8b2818a069e151a49fdba573f0db45face1651 is the first bad commit
commit 6d8b2818a069e151a49fdba573f0db45face1651
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Tue May 20 09:28:30 2014 +0000

    source-hash-da1425650b0c3e0921d2c9d51d461aca99038650
    
    commit da1425650b0c3e0921d2c9d51d461aca99038650
    Author:     Thomas Arnhold <thomas@arnhold.org>
    AuthorDate: Thu Apr 24 04:18:55 2014 +0200
    Commit:     Thomas Arnhold <thomas@arnhold.org>
    CommitDate: Thu Apr 24 11:58:14 2014 +0200
    
        add missing modelines to idl files
    
        Change-Id: If52651c70ee659c83ef127da4fe5e266cfe7eec2

:100644 100644 4a8d5565ecefcfdd4078edd5700de0efc8132c02 62b086808cceca8afd3b1840ff28b7dcab3cfc8e M	autogen.log
:100644 100644 bd53ed3cc9847c47658266fa59383ff0e60ebe43 2d692f932ea7b5bdddcc39a7685106a170201f94 M	ccache.log
:100644 100644 80d9656c29aca4e90745e26552bda0bbf7f7cabf c7777ae6f94f5f6034bd795f1da86043f00352c4 M	commitmsg
:100644 100644 b465c495534db58c79ef3d68275b63fb7351e6bf 874c9489bd7a796783a09051c1f2bdf41bc1613e M	make.log
:040000 040000 21b874fef5ab6f9a92e4d5db990b06c510018458 d7045a9a32ad3b402f21dfced13cbd12dcd9592d M	opt


# bad: [423a84c4f7068853974887d98442bc2a2d0cc91b] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect start 'latest' 'oldest'
# good: [e02439a3d6297a1f5334fa558ddec5ef4212c574] source-hash-6b8393474974d2af7a2cb3c47b3d5c081b550bdb
git bisect good e02439a3d6297a1f5334fa558ddec5ef4212c574
# good: [4850941efe43ae800be5c76e1102ab80ac2c085d] source-hash-980a6e552502f02f12c15bfb1c9f8e6269499f4b
git bisect good 4850941efe43ae800be5c76e1102ab80ac2c085d
# skip: [a900e72b6357882284c5955bdf939bf14269f5fb] source-hash-dd1050b182260a26a1d0ba6d0ef3a6fecc3f4e07
git bisect skip a900e72b6357882284c5955bdf939bf14269f5fb
# skip: [3dda83fc3a43afc6af7f5c0ffd029e610ec1b9a3] source-hash-c59b3d6c5c8096486730007d9b9b053793b90b1e
git bisect skip 3dda83fc3a43afc6af7f5c0ffd029e610ec1b9a3
# good: [4f705a8cfb1998b09f2062510b207d35a33647d8] source-hash-1eeb20f3958666ec6ba6e0fcf52e92e5eb447a14
git bisect good 4f705a8cfb1998b09f2062510b207d35a33647d8
# good: [465e2be02951f9645beb3024506a5212907caf5f] source-hash-674801eb4af21c9ae83c122499f15fa4f4785b0f
git bisect good 465e2be02951f9645beb3024506a5212907caf5f
# bad: [1de992ed60dad1fd65ff0383a8610b0468d9d772] source-hash-8bf0b9536cb33dfcce8a811b70c2ead285300f3f
git bisect bad 1de992ed60dad1fd65ff0383a8610b0468d9d772
# good: [ce3d21bc00b0756f1e7dbb4974db30e6d51b913b] source-hash-8485a276022e05bd34afb2321e72ecfad4589f7e
git bisect good ce3d21bc00b0756f1e7dbb4974db30e6d51b913b
# bad: [89894d82385af13d5393f07abeb76a2c309b1828] source-hash-062e69f40b749aa8a6058c3e6ca328af86aeb45b
git bisect bad 89894d82385af13d5393f07abeb76a2c309b1828
# bad: [c567bb961271596a852b55742a65e04f0b92ecbb] source-hash-2e41702ed4f224f195d33054e2e714f546b4442c
git bisect bad c567bb961271596a852b55742a65e04f0b92ecbb
# bad: [6d8b2818a069e151a49fdba573f0db45face1651] source-hash-da1425650b0c3e0921d2c9d51d461aca99038650
git bisect bad 6d8b2818a069e151a49fdba573f0db45face1651
# first bad commit: [6d8b2818a069e151a49fdba573f0db45face1651] source-hash-da1425650b0c3e0921d2c9d51d461aca99038650
Comment 2 janekptacijarabaci 2014-08-01 07:53:34 UTC
There is no test for it. As a result, a similar error is repeated... :-/

Thank you in advance :-)
Comment 3 Eike Rathke 2014-08-15 01:38:04 UTC
Fixed with the latest commits for bug 79441 on master, pending review for 4-3, see 79441#c37 and 79441#c39
Comment 4 V Stuart Foote 2014-12-01 14:23:29 UTC

*** This bug has been marked as a duplicate of bug 79441 ***
Comment 5 Robinson Tryon (qubit) 2015-12-15 11:03:42 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]