Download it now!
Bug 81559 - EDITING: Undo function confuses formula calculation
Summary: EDITING: Undo function confuses formula calculation
Status: RESOLVED DUPLICATE of bug 80846
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-20 10:16 UTC by realnico
Modified: 2014-07-20 22:18 UTC (History)
0 users

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description realnico 2014-07-20 10:16:33 UTC
Problem description: 
If I delete a cell content that is used in a formula of another cell and undo the deletion the formula does not recalculate even if forced to do so with F9 or after reopening the document.

Steps to reproduce:
1. Open a new spreadsheet.
2. Type in 3 values in one column, e.g. 1,5,8 in A1 - A3
3. In cell A4 type: =SUM(A1:A3). The cell displays 14.
4. Now delete the contents of e.g. cell A2 (5). A4 correctly shows 9.
5. Now undo the deletion using the undo-function.

Current behavior:
A4 continues showing 9 but should be 14 again. Even if closing and reopening the document or recalculating with F9 the wrong value stays until you reedit one of the cells.

This is a showstopper since in large tables you cannot ensure correct values in all formulas!

Expected behavior:
After undoing the deletion A4 should show 14 again.

Additional info: this error does not appear in OpenOffice.
Operating System: Windows 7
Version: 4.2.5.2 release
Comment 1 ign_christian 2014-07-20 12:30:19 UTC
Hello..this problem's been known. Thanks for reporting

*** This bug has been marked as a duplicate of bug 80846 ***
Comment 2 realnico 2014-07-20 22:18:24 UTC
Ok, thank you.

At least it led me to the (temporary) solution of the problem for me: hard recalc with Ctrl+Shift+F9.

Unfortunately Google didn't find any forums where someone posted the solution :-(