Bug Hunting Session
Bug 81561 - SVG: Text dropped when exporting embedded spreadsheet as svg from Draw
Summary: SVG: Text dropped when exporting embedded spreadsheet as svg from Draw
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.0.6.2 release
Hardware: All Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: bibisected, bisected, regression
Depends on:
Blocks: SVG-Import
  Show dependency treegraph
 
Reported: 2014-07-20 12:14 UTC by adrian@apthorpia.com
Modified: 2018-06-19 10:07 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Draw file with embedded Calc spreadsheet that exhibits problem when exporting to SVG (14.30 KB, application/vnd.oasis.opendocument.graphics)
2014-07-20 12:14 UTC, adrian@apthorpia.com
Details
result of export to SVG from LO Draw 6.1 beta 2 (11.01 KB, image/svg+xml)
2018-06-19 10:06 UTC, Roman Kuznetsov
Details
svg from LO Draw 6.1 beta 2 in Chrome (2.67 KB, image/png)
2018-06-19 10:07 UTC, Roman Kuznetsov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description adrian@apthorpia.com 2014-07-20 12:14:17 UTC
Created attachment 103137 [details]
Draw file with embedded Calc spreadsheet that exhibits problem when exporting to SVG

I have a simple Calc spreadsheet embedded in Draw. When I export to SVG the outline of the spreadsheet is shown but not the cell content (text). This seems to be a bug as confirmed by 

http://ask.libreoffice.org/en/question/37270/text-dropped-when-exporting-embedded-spreadsheet-as-svg-from-draw/
Comment 1 ign_christian 2014-07-20 13:52:27 UTC
Reproduced with LO 4.3.0.3, 4.2.6.1, 4.1.6.2, 4.0.6.2 -> no text (only border)

Exporting from LO 3.6.7.2, 3.5.7.2 : failed to load by Image Viewer, but Chrome & Firefox can open that (little glitch in some border).

Exporting from LO 3.3.0.4 : failed to load by Image Viewer, Chrome shows nothing, Firefox only shows slight border.

Exporting from AOO 3.4.1, 4.1.0 : correctly opened in Image Viewer, Chrome, Firefox.

Tested on Ubuntu 12.04 32bit
Comment 2 Regina Henschel 2015-03-31 23:19:25 UTC
I see nothing in browser Seamonkey on Windows 7. The reason for seeing nothing is the use of clip-path.

The text is missing because the text has no explicit x= attribute. The default x="0" is out of the viewing box.

Besides that:
Attributes x and y are not valid in tspan, although browsers might interpret them.
Without an explicit x attribute for each cell content, the cell contents will be rendered one after the other without space.
The element tspan is only allowed as child of element text, element textArea, or element tspan, but not of element g. But browsers are fault-tolerant and will render such anyway.
Comment 3 Matthew Francis 2015-04-06 14:55:01 UTC
The text stopped appearing across the following set of commits (the intermediate commits have a compile error)

Adding Cc: to mrcekets@gmail.com; Could you possibly take a look at this one? Thanks

(* This is the same set of commits as bug 90284, but it's not certain that the fix for one bug is the fix for the other, so not merging the two for now)


commit 8c673fa8af0ac7419b6b6d03621d91d44a87ca7a
Author: Marco Cecchetti <mrcekets@gmail.com>
Date:   Fri Aug 24 10:55:30 2012 +0200

    Now debugging code is conditionally compiled and JavaScript debug log are turned off.

commit f77bd4a7c83e8d84655f4e3a4f3c6c44a735053e
Author: Marco Cecchetti <mrcekets@gmail.com>
Date:   Mon Aug 20 20:22:09 2012 +0200

    some improvement in making text animation compatible with text selection

commit df9a436a85fa281cd53d46fdb832965d36aa9135
Author: Marco Cecchetti <mrcekets@gmail.com>
Date:   Sat Aug 18 19:25:17 2012 +0200

    Handled META_BMPSCALE_ACTION, supported hyperlinks, text selection support.

commit dd188c470acbd6151b4ed6b71b194ed0bb3c2685
Author: Marco Cecchetti <mrcekets@gmail.com>
Date:   Wed Aug 15 22:32:42 2012 +0200

    Now MasterPage text fields work, list items are detected correctly,  some effect work on text.

commit 5626e723945eb39ed211a26ba5386ee486b8a4e8
Author: Marco Cecchetti <mrcekets@gmail.com>
Date:   Sat Aug 4 17:44:13 2012 +0200

    text-export: meta-action based implementation
Comment 4 itsGord 2015-07-11 14:19:41 UTC
Reproducible with LO 4.1.4.2, Win 7 SP1 64 bit.

Steps done:
1. Open the attached odg file
2. Go to FILE -> EXPORT and select as file type SVG and click Save
3. Open the SVG file
Comment 5 Robinson Tryon (qubit) 2015-12-13 11:10:53 UTC Comment hidden (obsolete)
Comment 6 Xisco Faulí 2016-09-26 15:34:49 UTC
Adding Cc: to Marco Cecchetti
Comment 7 QA Administrators 2018-06-18 02:42:09 UTC Comment hidden (obsolete)
Comment 8 Roman Kuznetsov 2018-06-19 10:06:19 UTC
Created attachment 142909 [details]
result of export to SVG from LO Draw 6.1 beta 2
Comment 9 Roman Kuznetsov 2018-06-19 10:07:10 UTC
Created attachment 142910 [details]
svg from LO Draw 6.1 beta 2 in Chrome
Comment 10 Roman Kuznetsov 2018-06-19 10:07:52 UTC
looks fine if make export from LibreOffice Draw 6.1 beta 2

Status -> WFM