Bug Hunting Session
Bug 81596 - export to OOXML format is broken for Calc functions that need argument changes
Summary: export to OOXML format is broken for Calc functions that need argument changes
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Master old -3.6
Hardware: All All
: medium normal
Assignee: Winfried Donkers (retired)
URL:
Whiteboard: target:4.5.0 target:4.4.1
Keywords:
: 89042 (view as bug list)
Depends on:
Blocks: 40835
  Show dependency treegraph
 
Reported: 2014-07-21 11:37 UTC by Winfried Donkers (retired)
Modified: 2015-02-20 10:01 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Winfried Donkers (retired) 2014-07-21 11:37:24 UTC
When saving a Calc document to OOXML, functions that need changes in arguments (e.g. addition of arguments tha are optional in calc and mandatory in Excel) are no longer adjusted to Excel specifications.

Example: GAMMADIST(1,2,5,0) should be written as GAMMADIST(1,2,5,1), but is written as GAMMADIST(1,2,5), which will produce an error in Excel.

First occurrence version number is a bit of a guess, it at least occurs with version 4.2.5.
Comment 1 Eike Rathke 2014-07-21 17:33:32 UTC
Was always the case, setting Version to Master-old; and Component to Spreadsheet.
Comment 2 Winfried Donkers (retired) 2014-07-29 06:21:20 UTC
I'll give it a try, using formula/source/core/api/FormulaCompiler.cxx  FormulaCompiler::CreateStringFromTokenArray() to handle OOXML-functions (FormulaGrammar::isOOXML( meGrammar ) being true) in a similar way PODF-functions are handled.
Don't expect instant fixes, my available time is limited.
Comment 3 Commit Notification 2014-11-27 20:10:20 UTC
Winfried Donkers committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4feaf96f50fa89eccb4e7a638220099e9a8482f1

fdo#81596 export to OOXML that need argument changes

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2014-11-28 01:04:46 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=3dd241c52d6db424bd4696ff8f223976542e411b

sensible indenting, fdo#81596 related

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2014-11-28 01:04:50 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=14aabee5a73e57e26b2062b1ebf00c3f1dff1250

simplify RewriteMissing() and switch in Add...(), fdo#81596 related

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2014-11-28 01:04:53 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8f031861f590ba914321816657a003375d93ef5d

write TRUE() for 2nd IF() parameter, fdo#81596 related

It will be available in 4.5.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Eike Rathke 2014-12-09 16:39:19 UTC
Let's call this fixed.
Comment 8 Eike Rathke 2015-02-02 20:19:27 UTC
*** Bug 89042 has been marked as a duplicate of this bug. ***
Comment 9 Kami 2015-02-03 16:10:11 UTC
Will this patch get backported to 4.4, 4.3?
Comment 10 Eike Rathke 2015-02-04 13:30:47 UTC
For 4-4 I'll try, for 4-3 probably not as it is quite invasive and 4.3.7 would be the last release from the 4-3 branch.
Comment 11 Eike Rathke 2015-02-09 18:00:24 UTC
Pending review at https://gerrit.libreoffice.org/14388 for 4-4