Download it now!
Bug 81602 - images in a draw file are lost while editing (memory managing ?)
Summary: images in a draw file are lost while editing (memory managing ?)
Status: RESOLVED DUPLICATE of bug 46447
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Draw (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-21 13:33 UTC by Rpnpif
Modified: 2014-07-23 02:09 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Rpnpif 2014-07-21 13:33:45 UTC
Some Draw document lost images.

I followed this procedure :

1. Open a new draw.
2. Copy/paste (with Xfce on Debian) A4 (2448x3475 pixels) sized images in Draw. One image per pages.
3. Copy until 72 images so 72 pages.
4. While editing, the backup file is saving some times.
Note that some images are reflected with LO to 180° rotation.
5. When I review the file from 72th pages to the first, I noted that some images are disappeared and are now blank. The image frame is visible but not the content. Only the twenty last pages have a visible image content.
6. I saved the file.
7. I reopened. The images are still invisible as a missing link (but they are not linked only embedded in the file.
8. I extracted the file with unzip. I remarked that only the 20 last images are present. The others images are lost. 

I had noted this issue some months ago but I had not write a report.

Perhaps memory managing problem with LO ?
Perhaps, this bug is a variant of #74703.

I created a new Draw document with this picture on each pages (A4) :
http://upload.wikimedia.org/wikipedia/commons/thumb/1/1d/Penguin_in_Antarctica_jumping_out_of_the_water.jpg/1280px-Penguin_in_Antarctica_jumping_out_of_the_water.jpg

About 60 pages created, I saw that some icons of LO was changing and became green with other garbage. When I put the mouse cursor over, these icons are refreshing. Yet memory managing problems ?

But with this last file, none images are lost.
Comment 1 Jean-Baptiste Faure 2014-07-22 11:12:59 UTC
Probably duplicate of bug 46447. Please could you have a look at this bug report to see if it matches what you noted?

That said, did you play with graphic memory options? menu Options > LibreOffice > Memory.

Best regards. JBF
Comment 2 sophie 2014-07-22 16:30:36 UTC
I also think it's a duplicate of #46447, there is a workaround on comment 69 of this bug, could you try it and give us your feedback - Thanks - Sophie
Comment 3 Rpnpif 2014-07-22 16:52:01 UTC
(In reply to comment #2)
> I also think it's a duplicate of #46447, there is a workaround on comment 69
> of this bug, could you try it and give us your feedback - Thanks - Sophie

Oh yes, this bug seems the same.
Thank you for your help. I'll try the workaround.
Comment 4 Rpnpif 2014-07-22 16:56:40 UTC
(In reply to comment #1)
> That said, did you play with graphic memory options? menu Options >
> LibreOffice > Memory.

Graphics cache : 20 MB
Memory per oibject : 5,2 MB

Cache for inserted objets : number : 20.

I'll try other settings as soon as possible.
Comment 5 Jean-Baptiste Faure 2014-07-22 17:50:56 UTC
(In reply to comment #4)
> (In reply to comment #1)
> > That said, did you play with graphic memory options? menu Options >
> > LibreOffice > Memory.
> 
> Graphics cache : 20 MB

The maximum possible value is 256 MB. I always use this value ...

Best regards. JBF
Comment 6 Joel Madero 2014-07-23 02:09:48 UTC

*** This bug has been marked as a duplicate of bug 46447 ***