Bug Hunting Session
Bug 81692 - Hidden text not displayed when set to be displayed in options
Summary: Hidden text not displayed when set to be displayed in options
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: ux-advise (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Formatting-Mark
  Show dependency treegraph
 
Reported: 2014-07-23 23:17 UTC by Yousuf Philips (jay) (retired)
Modified: 2016-09-22 04:45 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
sample document (8.86 KB, application/vnd.oasis.opendocument.text)
2014-09-06 15:39 UTC, Yousuf Philips (jay) (retired)
Details
Screenshot of hidden text and options under GNU/Linux + LOv4400 2014-09-05 (59.91 KB, image/png)
2014-09-07 07:45 UTC, Owen Genat (retired)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Yousuf Philips (jay) (retired) 2014-07-23 23:17:47 UTC
Steps to Reproduce:
1) goto Tools > Options > LibreOffice Writer > Formatting Aids and check 'hidden text'
2) Type some words
3) select the words and in the right-click context menu, select 'Character...'
4) select font effects tab, check 'hidden', and press OK

Expected: that hidden text would still be displayed

It is possible this is not the behaviour of this feature and i'm only guess that it is. :)
Comment 1 Joel Madero 2014-07-27 01:16:09 UTC
Looks like this isn't how the feature works: https://help.libreoffice.org/Writer/Hiding_Text


Closing as NOTABUG
Comment 2 Yousuf Philips (jay) (retired) 2014-07-27 15:23:45 UTC
Thanks for the clarification. I guess i should change this bug to the renaming of 'hidden text' to 'field hidden text', as the current title is not very clear.
Comment 3 Yousuf Philips (jay) (retired) 2014-07-30 00:28:21 UTC
Reopening this as i think the entry needs to be worded better, as other can misinterpret this, as i did due to it not being worded well.

I think 'Hidden text fields' is the best wording possible, as you are putting hidden text within a field that will only be displayed when particular conditions are met.
Comment 4 Joel Madero 2014-07-30 00:31:10 UTC
@Jay - you mind getting UX input before requesting these types of things. Just remember that every minor language change requires multiple teams to do translations and what not.
Comment 5 Owen Genat (retired) 2014-08-23 10:41:05 UTC
(In reply to comment #0)
> Expected: that hidden text would still be displayed

Works exactly as indicated in the description under GNU/Linux using v4.3.0.4. There are many ways to hide content and this is just one method. In the indicated options location:

- "Hidden text" hides/reveals text using Format > Character (or a paragraph style using this setting).
- "Fields: Hidden text" hides/reveals fields using Insert > Fields > Other > Function tab > Type Hidden text.
- "Fields: Hidden paragraph" hides/reveals paragraphs containing a field using Insert > Fields > Other > Function tab > Type Hidden Paragraph.

The last option is also available via View > Hidden Paragraphs. I think the current wording of these options is quite clear given the variety of situations to be covered (and text can also be hidden using sections).
Comment 6 Yousuf Philips (jay) (retired) 2014-09-06 15:38:26 UTC
(In reply to comment #5)
> - "Hidden text" hides/reveals text using Format > Character (or a paragraph
> style using this setting).

Tested this on 4.4 master and this doesnt work. Changing the summary back to its original wording as "Fields: Hidden text" is already in the dialog.
Comment 7 Yousuf Philips (jay) (retired) 2014-09-06 15:39:30 UTC
Created attachment 105840 [details]
sample document

I've hidden the word 'Is' and with 'Hidden text' enabled, it doesnt display it.
Comment 8 Owen Genat (retired) 2014-09-07 07:45:13 UTC
Created attachment 105852 [details]
Screenshot of hidden text and options under GNU/Linux + LOv4400 2014-09-05

(In reply to comment #6)
> Tested this on 4.4 master and this doesnt work. Changing the summary back to
> its original wording as "Fields: Hidden text" is already in the dialog.

(In reply to comment #7)
> I've hidden the word 'Is' and with 'Hidden text' enabled, it doesnt display
> it.

There must be some deeper / other issue here because under GNU/Linux using:

- v4.1.6.2 Build ID: 40ff705089295be5be0aae9b15123f687c05b0a
- v4.2.6.3 Build ID: 3fd416d4c6db7d3204c17ce57a1d70f6e531ee21
- v4.3.1.2 Build ID: 958349dc3b25111dbca392fbc281a05559ef6848
- v4.4.0.0.alpha0+ Build ID: 652b807658a54cd2ccd04ebc6900d2cf1ce85015 TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2014-09-05_01:32:46

... the indicated option reveals the hidden text "Is Up". Refer attached.
Comment 9 Yousuf Philips (jay) (retired) 2014-09-07 08:30:21 UTC
Now looking at your screenshot, i see where i was going wrong, as i didnt have non-printing characters enabled. Thanks Owen. :)