Bug 81772 - FILEOPEN: Libreoffice crashes when opening file via "open" command line
Summary: FILEOPEN: Libreoffice crashes when opening file via "open" command line
Status: RESOLVED DUPLICATE of bug 74447
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.5.2 release
Hardware: Other macOS (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-26 04:08 UTC by Laurent
Modified: 2014-08-01 16:34 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
ODT file that crashes LO when opened via "open Empty.odt" (7.98 KB, application/vnd.oasis.opendocument.text)
2014-07-26 17:35 UTC, Laurent
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Laurent 2014-07-26 04:08:00 UTC
Problem description: 

Steps to reproduce:
1. Run "open somefile.odt" from the OS X Terminal

Current behavior:

The LibreOffice icon temporarily appears in the dock, then the application crashes. The following message appears in the OS X Console:

> com.apple.launchd.peruser.501[733]: (org.libreoffice.script.31536[4415]) Exited with code: 1


Expected behavior:

The application does not crash and open the file.

This definitely used to work in earlier versions of LibreOffice (maybe 3.x?) but doesn't work anymore in recent versions.
Operating System: Mac OS X
Version: 4.2.5.2 release
Comment 1 Christopher Chavez 2014-07-26 07:24:01 UTC
I am able to use "open …" on .odt or any other type for LibreOffice 4.3.0.3 (aka RC3), OS X 10.9.4.
What version of OS X are you using specifically? Does actually double-clicking the file result in a crash?

[QA: should this be set to NEEDINFO?]
Comment 2 Christopher Chavez 2014-07-26 07:26:43 UTC
possible duplicate of bug 74447?
Comment 3 Laurent 2014-07-26 16:54:04 UTC
My version of OS X is 10.9.4 though LibreOffice was already crashing before this version. If I double-click the file it opens fine.
Comment 4 ign_christian 2014-07-26 17:04:41 UTC
Laurent, please attach your file (keep in mind that your file will open to public) if that only happen with particular file.

You could also try 
- LO 4.3.0.3 : http://www.libreoffice.org/download/libreoffice-fresh/?version=4.3.0
- Reset user profile : https://wiki.documentfoundation.org/UserProfile
Comment 5 Laurent 2014-07-26 17:35:41 UTC
Created attachment 103511 [details]
ODT file that crashes LO when opened via "open Empty.odt"
Comment 6 Laurent 2014-07-26 17:37:05 UTC
I'm not sure but I think it might have something to do with document corruption and/or the document restoration feature. I can replicate the issue consistently like this:

1. Open LibreOffice and create a new, empty, ODT file.
2. Save and quit LibreOffice
3. Run "open empty.odt" - the file opens fine.
4. Quit LibreOffice
5. Run "open empty.odt" again - the dialog for document restoration briefly shows up (no controls are visible but, from the size, I assume it is this one) then LO crashes.

If I open empty.odt again by double-clicking on the file, the restoration dialog shows up and I can restore the file. From there, it's possible to repeat step 2 to 5 and crash LO again.

I've attached empty.odt at a point where it crashes LO for me, though I don't know if it's going to do it on different configurations.

For info, I've also tried deleting my profile and I could still replicate this.
Comment 7 Alex Thurgood 2014-08-01 10:13:08 UTC
(In reply to comment #6)
> I'm not sure but I think it might have something to do with document
> corruption and/or the document restoration feature. I can replicate the
> issue consistently like this:
> 
> 1. Open LibreOffice and create a new, empty, ODT file.
> 2. Save and quit LibreOffice
> 3. Run "open empty.odt" - the file opens fine.
> 4. Quit LibreOffice
> 5. Run "open empty.odt" again - the dialog for document restoration briefly
> shows up (no controls are visible but, from the size, I assume it is this
> one) then LO crashes.
> 

I can not reproduce this on either :

ersion: 4.3.0.0.beta2+
Build ID: d0930b170d11cd834b34b95202ebdc3e4a96182d
TinderBox: MacOSX-x86@49-TDF, Branch:libreoffice-4-3, Time: 2014-06-07_05:20:24

or on 

Version: 4.2.4.2
Build ID: 63150712c6d317d27ce2db16eb94c2f3d7b699f8
Comment 8 Alex Thurgood 2014-08-01 10:19:43 UTC
Not reproducible with 

Version: 4.4.0.0.alpha0+
Build ID: a0b89100be8ccc2b60d08d7e3819cd247a6042b0
Comment 9 Alex Thurgood 2014-08-01 10:23:05 UTC

*** This bug has been marked as a duplicate of bug 74447 ***
Comment 10 Alex Thurgood 2014-08-01 10:26:18 UTC
(In reply to comment #6)

@Laurent : by any chance, are you saving to / reading from a USB connected drive? I have seen similar behaviour (file corruption in such a case) ?
Comment 11 Laurent 2014-08-01 16:34:38 UTC
@Alex, I've just tried with my local HSF+ partition and with a FAT32 one and it's crashing in both cases.

By the way, before each crash, I see the following line in the Console, could it be related?

> 01/08/2014 13:32:22,118 gkbisd[704]: Unable to collect cdhash for /Applications/LibreOffice.app (error code -67028)