Bug Hunting Session
Bug 81807 - Undo after pasting text leaves formatting behind at cursor
Summary: Undo after pasting text leaves formatting behind at cursor
Status: RESOLVED DUPLICATE of bug 50713
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-07-27 13:35 UTC by Matthew Francis
Modified: 2015-01-20 17:21 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Matthew Francis 2014-07-27 13:35:04 UTC
After pasting formatted text in Writer, then undoing, the format of the pasted text remains at the cursor

Steps to reproduce
1. Create two blank documents. In the first document, type "abc". In the second document, type "123", then apply a text highlight to the "123"
2. Copy the "123" and paste it in the first document immediately after the "abc"
3. Undo
4. Type anything

Result
The newly typed text will be highlighted. The undo should also reset the format under the cursor

I typically meet this issue when pasting text, then deciding I should have pasted as unformatted text, undoing, and pasting again as unformatted text - after which the pasted text still has the undesired formatting applied because it had become the current format under the cursor after the first paste
Comment 1 ign_christian 2014-07-27 15:21:07 UTC
Reproduced with LO 4.3.0.3, 4.2.6.2, 4.1.6.2, 4.0.6.2, 3.3.0.4 - Ubuntu 12.04 x86
Also with AOO 4.1.0, seems inherited from OOO

Same result with pasting Bold & Underlined text, not try yet other formats.
Comment 2 Matthew Francis 2015-01-20 17:21:06 UTC

*** This bug has been marked as a duplicate of bug 50713 ***